Status

defect
P5
major
RESOLVED WONTFIX
13 years ago
6 months ago

People

(Reporter: asqueella, Unassigned)

Tracking

({uiwanted})

Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

13 years ago
When you open a malformed feed, you get an error from here: http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/components/feeds/src/FeedProcessor.js&rev=1.13&mark=1177#1176
reported to Error console, and the displayed feed page looks broken. There should be a user-visible error message displayed instead.

Comment 2

13 years ago
IE7 refuses to display this, good for them. We shouldn't have JS Console errors here. It's up to management to decide whether we want to show a partial feed or throw our hands up similarly.
Assignee: nobody → sayrer

Comment 3

13 years ago
Mike, could we get an opinion on what to do here? We have a reliable indication that the feed has fatal errors.

Updated

13 years ago
Attachment #237659 - Flags: review?(mconnor)
Attachment #237659 - Flags: review?(mconnor) → review+
Upping to MAJOR.

It is plain bad if we leave a user staring at an empty prettyprint page without informing him the feed broke.
Severity: normal → major

Updated

13 years ago
Severity: major → normal

Updated

13 years ago
Severity: normal → major
*** Bug 363490 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 366599
Robert: Is there a reason your patch did not get checked in? I would err on the side of displaying something letting the user know that the feed is malformed.

Comment 9

12 years ago
(In reply to comment #8)
> Robert: Is there a reason your patch did not get checked in? I would err on the
> side of displaying something letting the user know that the feed is malformed.

Yeah, this needs to get fixed. The patch is checked in, it just makes the situation not as bad.
Duplicate of this bug: 381799

Comment 11

12 years ago
(In reply to comment #9)
> (In reply to comment #8)
> > Robert: Is there a reason your patch did not get checked in? I would err on the
> > side of displaying something letting the user know that the feed is malformed.
> 
> Yeah, this needs to get fixed. The patch is checked in, it just makes the
> situation not as bad.
> 

As mentioned in Bug 381799, we need to fix this single line.
http://lxr.mozilla.org/mozilla1.8/source/browser/components/feeds/content/subscribe.xhtml#47

From my point of view this are two bugs, fixing the js console error and
fixing the user interface. I suggest to reopen 381799 for interface change and using this to resolve js console issues.

Comment 12

12 years ago
Seems that we simply never reach the following line which would remove the style="display: none;" mentioned by comment #11:

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/components/feeds/src/FeedWriter.js&rev=1.2.2.31&mark=366-370#343

Fixing the error from comment #0 might/should already make this happen.

Comment 13

12 years ago
This will need l10n strings, most likely. Assigning to beltzner or his delegate, so we can figure out what should happen for feeds we can't parse. IE7 and Safari both show "we give up" screens.
Assignee: sayrer → beltzner
Flags: blocking-firefox3?
Target Milestone: --- → Firefox 3
Blocking (and tackling!)
Flags: blocking-firefox3? → blocking-firefox3+

Comment 15

12 years ago
When adding http://news.hereisthecity.com/news/business_news_rss091.xml Live Bookmark tells me the feed was empty.

Since the feed is working properly with other RSS-readers I was wondering whether it is part of this bug.

PS: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a7pre) Gecko/2007071711 Minefield/3.0a7pre

Comment 16

12 years ago
(In reply to comment #15)
By the error I get in the console that looks like bug 381357.  
Target Milestone: Firefox 3 → Firefox 3 M8
Keywords: uiwanted
Alex, can you pull together some sort of UI for this failure state?  Not a feature, doesn't need to make M8
Assignee: beltzner → faaborg
Target Milestone: Firefox 3 M8 → Firefox 3 M9
Duplicate of this bug: 393635
I'll work on the UI for this after M8
Target Milestone: Firefox 3 M9 → Firefox 3 M10
Target Milestone: Firefox 3 M10 → Firefox 3 M11
Priority: -- → P5
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Priority: P5 → P4
Target Milestone: Firefox 3 Mx → Firefox 3 M11
Duplicate of this bug: 415593
Duplicate of this bug: 420289
Taking off the "this._reader has no properties" since it's no longer true, and aligning the milestone with the reality that we didn't choose a few words of text before freezing.
Summary: Malformed feeds look empty; "Error: this._reader has no properties" in JS console → Malformed feeds look empty
Target Milestone: Firefox 3 beta3 → Future
Duplicate of this bug: 429034
Any update on this bug? Alex?
OS: Windows XP → All
Hardware: x86 → All
This fell off my radar, not sure if we can fix it given the string freeze, but I'll get the text ready so we can fix this on trunk.
Alex, what is the status on this?
in the middle of a unfortunately very large uiwanted queue.  Just put up an error icon (the red one with the X), and some temporary text, and we can clean the text up in ui-review.
Assignee: faaborg → nobody
Keywords: uiwanted
Priority: P4 → P5
The feed preview code has been removed by bug 1477669.
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → WONTFIX

Updated

6 months ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.