Downloads Complete alert (slider) no longer shows

VERIFIED FIXED

Status

()

Toolkit
Downloads API
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Assigned: sdwilsh)

Tracking

({regression})

Trunk
regression
Points:
---
Bug Flags:
in-testsuite -
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070523 Minefield/3.0a5pre Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070523 Minefield/3.0a5pre Firefox/3.0

Downloads Complete Slider no longer appears when downloads are complete.



Reproducible: Always

Steps to Reproduce:
1. Download any file
2. Note that the Slider does not appear when the download is complete.
3.


Expected Results:  
Slider should appear when the download is complete.

Latest hourly:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070523 Minefield/3.0a5pre Firefox/3.0 ID:2007052316 [cairo]

Also, there was some text at the bottom of the DM that stated something to the affect:  This file downloads to:  (Blank area, mouse over shows a empty button)

This text and the empty button are no longer present in this build after 
bug: https://bugzilla.mozilla.org/show_bug.cgi?id=381538 landed.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Assignee)

Comment 1

11 years ago
Second issue is Bug 381542, but that is being reported as fixed.
Assignee: nobody → sdwilsh
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #1)
> Second issue is Bug 381542, but that is being reported as fixed.
> 

Fixed I guess if Removing the line about Downloads to, and the empty button is the fix and was not supposed to be there in the first place. 

Same in the '17' build, the text & button are missing:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070523 Minefield/3.0a5pre Firefox/3.0 ID:2007052317 [cairo]

Text and Button are there in the '15' build, missing in 16,and 17 at noted above.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070523 Minefield/3.0a5pre Firefox/3.0 ID:2007052315 [cairo]
Checking with others on IRC, it appears this may be Vista only problem.  Sorry for all the posts... posting as I learn new things to report.
Aja reports it works if the save to is set to Desktop.  Confirmed, when I change to save to Desktop the text appears and shows: Desktop. 

If set to 'Always ask where to save'.. the text is missing.  Maybe design? If so, seems redundant to only show Desktop, and not the name of the folder assigned by user at the start of the download.  

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070523 Minefield/3.0a5pre Firefox/3.0 ID:2007052317 [cairo]

(Assignee)

Comment 8

11 years ago
All this really should be in Bug 381542 ;)
Status: NEW → ASSIGNED

Comment 9

11 years ago
See bug 381542 comment 9 re: the "All files downloaded to:" line in DM UI.

I can confirm that the "Download complete" status message popup is not
appearing on Win/XP SP2. 

Comment 10

11 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a5pre) Gecko/20070522 Minefield/3.0a5pre

Happens on Linux, too. Also, in the future, please file separate bugs for different problems.
Severity: major → normal
Keywords: regression
OS: Windows Vista → All
Summary: Download Complete Slider - missing after DM change → Downloads Complete alert (slider) no longer shows
(Assignee)

Comment 11

11 years ago
Created attachment 265963 [details] [diff] [review]
v1.0

I clearly put that line in the wrong place.  I also switched the default value of the pref to true since it is now enabled on all platforms (Bug 282185)
Attachment #265963 - Flags: review?(mano)
(Assignee)

Updated

11 years ago
Blocks: 380250
Flags: blocking-firefox3?
Hardware: PC → All

Updated

11 years ago
Attachment #265963 - Flags: review?(mano) → review+
(Assignee)

Comment 12

11 years ago
Checking in toolkit/components/downloads/src/nsDownloadManager.cpp;
new revision: 1.82; previous revision: 1.81
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 13

11 years ago
VERIFIED

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070531 Minefield/3.0a5pre ID:2007053120 [cairo]
Status: RESOLVED → VERIFIED

Comment 14

11 years ago
Surely a Litmus test for this behavior exists or should exist.
Flags: in-testsuite?

Comment 15

11 years ago
Yep, we do: http://litmus.mozilla.org/show_test.cgi?&id=3980.
Flags: in-testsuite?
Flags: in-testsuite+
Flags: blocking-firefox3?

Updated

11 years ago
Flags: in-testsuite-
Flags: in-testsuite+
Flags: in-litmus+
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.