Need GUI for disabling spell-checking

VERIFIED WONTFIX

Status

Camino Graveyard
Preferences
VERIFIED WONTFIX
11 years ago
11 years ago

People

(Reporter: Chris Lawson (gone), Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
Based on the amount of feedback we're getting (who would have thought?) about the "annoying" spellchecker, we probably ought to put a toggle for the spellchecker in the General prefs pane. Filing as UNCO for discussion.
3 people hardly makes this worthwhile.  We have many things that people want/use a lot that we don't have GUIs for that we confine to /hiddenprefs/ instead.  I'm much more inclined to add it there if there is actually a groundswell of anti-spellcheck people (how do they live with the rest of Mac OS X?).

Comment 2

11 years ago
The standard Cocoa spelling UI has an option to turn check-as-you-type on and off. I thought we were always planning on supporting that along with the other standard UI (and I thought it was covered by another bug already, but I may be wrong).
(Reporter)

Comment 3

11 years ago
Well, there's bug 364550, but I didn't see anything in there about enable/disable -- just switching dictionaries/languages.
Probably bug 348702.  

Sam and I did have the Edit:Spelling menu on our menu rewrite lists; I forget why it got axed from menu rewrite (aside from spelling not working yet then).

Comment 5

11 years ago
Also, as a reminder, we already checked in strings to match the standard Cocoa Edit:Spelling menu items.

Maybe we should create a meta bug for totally implementing this spelling menu:

Spelling > Spelling... (bug 364550)
           Check Spelling (re-check entire range; no bug for this yet?)
           Check Spelling as You Type (bug 348702)
The hidden pref is now documented on the website: http://www.caminobrowser.org/documentation/hiddenprefs/#DisableSpellcheck

Instead of this bug, we should file bugs on whatever pieces of the Cocoa spelling UI are still missing (and have them block bug 383663), and fix this the "normal Cocoa" way.
Duplicate of this bug: 385300
(Reporter)

Comment 8

11 years ago
I agree with comment 6, and since I filed it...WONTFIX in favour of doing this the Mac Way™.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX

Comment 9

11 years ago
I agree this is a problem, and schould be fixed as in comment 5. The fix in comment 6 is usfeul to avoid the annoyance of underlined text, but then removes a useful feature.

The biggest problem is that Camino cannot change language, and seems to choose the default one for the system it is running on. for example, while I'm currently writing in English, the spelling checker assumes it should correct my spelling according to the Italian dictionary.

Paolo

Comment 10

11 years ago
Read the rest of comment 6; we are going to support all the standard Cocoa spelling options, which doesn't remove any useful features. That's all covered by other bugs.

Please don't argue in WONTFIXed bugs.
(In reply to comment #9)
> The biggest problem is that Camino cannot change language, and seems to choose
> the default one for the system it is running on. for example, while I'm
> currently writing in English, the spelling checker assumes it should correct my
> spelling according to the Italian dictionary.

You want http://www.caminobrowser.org/documentation/faq/#troub_switchspell and bug 364550, anyway, not this one.
Status: RESOLVED → VERIFIED

Comment 12

11 years ago
Stuart, sorry for ignoring the Wontfix flag. Please allow me an additional answer.

Smokey, it seems that in Camino 1.5 the Spelling sub-menu no longer appears in teh Ctrl-click contextual menu. If you confirm, I will see if I must open a new bug issue.

Comment 13

11 years ago
(In reply to comment #12)
> it seems that in Camino 1.5 the Spelling sub-menu no longer appears in
> teh Ctrl-click contextual menu.

It does in the toolbar, which is what that workaround describes. It does not anywhere else, which is what our open bugs cover.

This bug is closed; please stop adding noise to it. If you have questions, use the forums at forums.mozillazine.org, not bugzilla.
You need to log in before you can comment on or make changes to this bug.