Closed Bug 385141 Opened 15 years ago Closed 12 years ago

SeaMonkey lacks UI for browser.tabs.warnOnClose

Categories

(SeaMonkey :: Preferences, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0

People

(Reporter: tonymec, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

(Keywords: fixed-seamonkey2.0)

Attachments

(2 files, 2 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/20070619 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/20070619 SeaMonkey/2.0a1pre

SeaMonkey lacks a checkbox, "Warn me when closing multiple tabs", in its Tabbed Browser preferences


Reproducible: Always

Steps to Reproduce:
1. Edit => Preferences => Navigator => Tabbed Browsing

Actual Results:  
There is no setting to warn when closing multiple tabs.

Expected Results:  
There should ba a checkbox, "Warn me when closing multiple tabs", reflecting the preference browser.tabs.warnOnClose (boolean, default=true).
Version: unspecified → Trunk
P.S. As it is now, if the user clicks "Don't warn me again" on the warning popup, there's no easy way to get the warning back (about:config must be used).
(In reply to comment #1)
> P.S. As it is now, if the user clicks "Don't warn me again" on the warning
> popup, there's no easy way to get the warning back (about:config must be used).

Isn't that the same for most of the warning dialogs that are in that style though?
(In reply to comment #2)
> (In reply to comment #1)
> > P.S. As it is now, if the user clicks "Don't warn me again" on the warning
> > popup, there's no easy way to get the warning back (about:config must be used).
> 
> Isn't that the same for most of the warning dialogs that are in that style
> though?
> 

Maybe; but in this case, the presence of such a checkbox in the Firefox UI is one of the _rare_ points where I feel Firefox's UI is superior to SeaMonkey's. I'm also thinking of the poor newbie who clicked the checkbox in the dialog without quite knowing what he was doing, and later decides that he prefers getting the warning. If the pref were visible he wouldn't have to (1) find about the support newsgroups, (2) ask how to get that warning back: as you probably realize, Edit => Preferences is easier to find than about:config, and its content is also structured in a more readable way.
(In reply to comment #3)
> (In reply to comment #2)
> > Isn't that the same for most of the warning dialogs that are in that style
> > though?
> > 
> Maybe; but in this case, the presence of such a checkbox in the Firefox UI is
> one of the _rare_ points where I feel Firefox's UI is superior to SeaMonkey's.

Yeah I saw a screenshot earlier with that, so I agree we should have it.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think we should have UI prefs for most of such things.

Thanks for filing this, we really should fix most of the few spots where Firefox is more configurable than SeaMonkey :)
Attached patch Adds the pref (obsolete) — Splinter Review
Adds the pref to the tabs pane.
Assignee: prefs → bugzilla
Status: NEW → ASSIGNED
Attachment #275133 - Flags: review?(iann_bugzilla)
This breaks the pref window on mac :/
(In reply to comment #7)
> Created an attachment (id=275156) [details]
> Mac screenshot of tab pref window (Classic) with patch applied
> 
> This breaks the pref window on mac :/
> 

Actually, from this screenshot, all the prefs on the page are still visible, though the bottom two are clipped halfway through.

On Linux, even without this fix [Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007080301 SeaMonkey/2.0a1pre], the tabbed browser prefs page already needs resizing: with the "Modern" theme, the bottom two prefs are not visible at all. (I don't know about the Mac, but happily on Linux I can drag the bottom edge downwards though.)

Conclusion: A somewhat longer prefs popup would do no harm. (Maybe add a scrollbar on low-resolution screens?)
(In reply to comment #8)
> (In reply to comment #7)
> > Created an attachment (id=275156) [details] [details]
> > Mac screenshot of tab pref window (Classic) with patch applied
> > 
> > This breaks the pref window on mac :/
> > 
> 
> Actually, from this screenshot, all the prefs on the page are still visible,
> though the bottom two are clipped halfway through.

I consider that broken.
> 
> On Linux, even without this fix [Mozilla/5.0 (X11; U; Linux i686; en-US;
> rv:1.9a7pre) Gecko/2007080301 SeaMonkey/2.0a1pre], the tabbed browser prefs
> page already needs resizing: with the "Modern" theme, the bottom two prefs are
> not visible at all. (I don't know about the Mac, but happily on Linux I can
> drag the bottom edge downwards though.)

You can't resize the window on mac. Iirc you can't on windows either.
Mark,

if you increase the height to 43em in suite/locales/en-US/chrome/common/pref/mac/platformPrefOverlay.dtd it'll work. Would you mind updating help as well? The relevant file that'll need an update is suite/locales/en-US/chrome/common/help/cs_nav_prefs_navigator.xhtml(section starts at #415).
Comment on attachment 275133 [details] [diff] [review]
Adds the pref

Patch itself is fine, but as mentioned elsewhere needs a tweak on mac, I was going to suggest 45em but if 43em works then go for that. Also needs the help updating as stefan suggests.
Attachment #275133 - Flags: review?(iann_bugzilla) → review-
If we already go into converting the prefwindow dimensions, could we go and convert the width to ch instead of em in the same step?
Still I'm not sure if we might want to take another look into those dimensions with bug 342087 anyways.
(In reply to comment #12)
[...]
> Still I'm not sure if we might want to take another look into those dimensions
> with bug 342087 anyways.
> 

According to bug 342087 comment#0 that bug is targeted at SeaMonkey 1.5 only, not current (suiterunner, 2.0a) trunk. IMHO the prefwindow in Sm trunk should be made large inough for whatever is to be displayed in it.
oops, I guess I misunderstood that bug description. Sm 1.5 is dead anyway.
I'm not actively working on this at the moment, as I'm concentrating on other areas.
Assignee: bugzilla → prefs
Status: ASSIGNED → NEW
Duplicate of this bug: 342307
I suggest that the pop-up dialog box should not have the option 'don't warn me again' inside the pop-up. 
My point is that developers are mixing warning pop-ups with configuration options.
If it is a warning pop-up it should remain as it is and not include configuration options; it could instead include a message to point to where the user must go to change this option. Of course this suggestion assumes that there will be an option in the tabbed browser preferences to select/unselect the warn.on.close.
(In reply to comment #17)
> I suggest that the pop-up dialog box should not have the option 'don't warn me
> again' inside the pop-up. 
> My point is that developers are mixing warning pop-ups with configuration
> options.

So, you'd rather get a pop-up that could be annoying to you and rather than looking at it and saying "oh I can just turn off this annoying pop-up by selected this check box", you'd prefer them to say, "oh, not that annoying pop-up again. Maybe I can turn it off in preferences", and then proceed into preferences to find it?

IMO that is bad. The user may not realise they can find it in preferences, and it means they would have to do 6 actions rather than just 1.
Every warning dialog that has an option to be turned off should expose that option directly on the dialog, so users can say "oh, no, I don't want to see _this_ again".

What we still need though, is a UI option to turn it back on from prefs :)
It would be annoying only if I did not choose this warning to show up everytime I try to close several open tabs.
As you can see, I'm not an expert. I agree with your point.
Let's focus on the real solution, that is include the option in prefs.
Thanks and have a good work.
(Filter "spam" on 'prefs-nobody-20080612'.)
Assignee: prefs → nobody
QA Contact: prefs
Blocks: 436934
This patch (based on Mark's one):
* Adds pref to tabbed browsing pane.
* Updates help to reflect above change.
* Tweaks size of Mac's preference window so prefs fit within it.
Assignee: nobody → iann_bugzilla
Attachment #275133 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #397748 - Flags: ui-review?(stefanh)
Attachment #397748 - Flags: superreview?(neil)
Attachment #397748 - Flags: review?(mnyromyr)
Comment on attachment 397748 [details] [diff] [review]
Add pref, help and mac fix patch v0.1

      size of this window for en-US. -->
-<!ENTITY  prefWindow.size             "width: 58em; height: 41em;">
+<!ENTITY  prefWindow.size             "width: 58em; height: 43em;">

You don't need this change anymore, I've checked both Classic and Modern and there's pleny of room with a 41em height.
Attachment #397748 - Flags: ui-review?(stefanh) → ui-review+
Comment on attachment 397748 [details] [diff] [review]
Add pref, help and mac fix patch v0.1

>-<!ENTITY  prefWindow.size             "width: 58em; height: 41em;">
>+<!ENTITY  prefWindow.size             "width: 58em; height: 43em;">
sr=me with this removed if we can do without it.
Attachment #397748 - Flags: superreview?(neil) → superreview+
Attachment #397748 - Flags: review?(mnyromyr) → review+
Comment on attachment 397748 [details] [diff] [review]
Add pref, help and mac fix patch v0.1

>+<!ENTITY warnOnClose.label "Warn me when closing multiple tabs">

That's a bit misleading - I close two out of nine tabs and get warned? There seems to enough space for "Warn me when closing a window with multiple tabs".


r=me with that.
Changes since v0.1:
* Removed change to height on mac.
* Changed checkbox label to be more explicit.

Carrying forward r/sr/uir and requesting a= for low risk patch.
Attachment #397748 - Attachment is obsolete: true
Attachment #400352 - Flags: ui-review+
Attachment #400352 - Flags: superreview+
Attachment #400352 - Flags: review+
Comment on attachment 400352 [details] [diff] [review]
Add pref with fuller label patch v0.1a [Checkin: Comment 28]

Really asking for a= on low risk patch this time!
Attachment #400352 - Flags: approval-seamonkey2.0?
Attachment #400352 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+
Comment on attachment 400352 [details] [diff] [review]
Add pref with fuller label patch v0.1a [Checkin: Comment 28]

http://hg.mozilla.org/comm-central/rev/7239026f9414
Attachment #400352 - Attachment description: Add pref with fuller label patch v0.1a → Add pref with fuller label patch v0.1a [Checkin: Comment 28]
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0
Blocks: 423281
You need to log in before you can comment on or make changes to this bug.