Favicons for bookmarks are not updated when location changes

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
12 years ago
5 months ago

People

(Reporter: whimboo, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
This can be seen on trunk and current 2.0.0.5pre Firefox builds under Windows and Mac OS X. If you change the location of a bookmark the favicon never gets updated. The old one is still visible. I think this should be a regression.

Steps to reproduce:

1. Add a new bookmark e.g. http://weblogs.mozillazine.org/qa
2. Click bookmark to let Firefox set the favicon
3. Change bookmark location to any other website e.g. http://quality.mozilla.org/
4. Click on bookmark => no favicon update

Even if you click multiple times on the bookmark the favicon never gets updated. You have to remove and redefine the bookmark. The bookmarks favicon should immediately updated when we click the bookmark or even better after the properties dialog was closed.
Bug 330179 is the opposite.
(In reply to comment #0)
> This can be seen on trunk and current 2.0.0.5pre Firefox builds under Windows
> and Mac OS X

> I think this should be a regression.

What makes you think this is a regression? Does it work in an earlier 2.0.0.x build, or 1.5.0.x?

It's not clear if you're filing this against Places or against the branch bookmark code - if you think it's a bug on both, and that the branch change is a regression from an earlier branch fix, you should file a separate bug on that. If it's not a regression from a branch fix, I doubt we'd change this behavior on the branch at this point.
(Reporter)

Comment 3

12 years ago
Correct. I remembered that it was working sometimes ago. Perhaps the behavior changed since we are using the bookmarks.html to store favicons. I update the component to Places to reflect the missing feature on trunk. I don't think that this will ever be fixed on the 1.8 branch so I don't file a new bug against it.
Component: Bookmarks → Places
Flags: blocking-firefox3?
Keywords: regression
QA Contact: bookmarks → places
Hardware: PC → All
I'm not sure this is a missing feature at all, its consistent with how things have always (since pre-1.0, I believe) worked.
Severity: normal → minor
Although there are also a lot of people who want their favicons to be updated with every visit, it would be annoying and a loss of functionality if this would be fixed. It's the only way to adjust favicons: go to a site that has the favicon that you prefer and then change the address in the address field. An extension like Favicon Picker would also lose its function.
(Reporter)

Comment 6

12 years ago
I don't talk about updating the favicon each time the user clicks on the bookmark. That's not necessary and will stop such extensions, right. We only have to change the favicon when you update the location. Why we cannot show the favicon inside the bookmarks property dialog and adding an update button next to it?
Not going to block on this, possibly WONTFIX, needs some more thought.
Flags: blocking-firefox3? → blocking-firefox3-

Comment 8

11 years ago
dupe /connected to bug 253045?
(Reporter)

Comment 9

11 years ago
(In reply to comment #8)
> dupe /connected to bug 253045?

Marco, this bug is about places not bookmarks.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Updated

5 months ago
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.