Closed Bug 253045 Opened 16 years ago Closed 7 years ago

favicon should be reset when bookmark URL changes.

Categories

(Firefox :: Bookmarks & History, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ts, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040724 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040724 Firefox/0.8

Favicons do not update once they are loaded into the bookmarks. Changing the URI
for the bookmark (or the favicon on the bookmarked site itself) does not reflect
in the bookmark.

Reproducible: Always
Steps to Reproduce:
1. Visit www.cnn.com
2. Bookmark
3. Visit bookmark to make sure favicon is saved
4. Edit the properties of the bookmark and change the URL to www.nbc.com
5. Visit the bookmark again
Actual Results:  
The icon is not updated

Expected Results:  
The icon should be updated to reflect the change of URI or the update of the
favicon graphic on the site

The same happens if a site changes its favicon from an old to a new
This is by design
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → INVALID
Either this bug or bug 253044 should be acknowledged, since it would otherwise
be impossible to change/reset a favicon without deleting a bookmark and adding
it again.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 240795 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
This is pretty valid actually, IMO; changing the URL should reset the favicon
and have it get loaded next time the site is visited.  Reopening; quickie 2-line
fix, probably.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
morphing per vlad's comments.  The rest is still a dupe though.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Favicons do not update once they are loaded into the bookmarks → favicon should be reset when bookmark URL changes.
Assignee: vladimir → vladimir+bm
Assignee: vladimir+bm → nobody
*** Bug 331300 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
Duplicate of this bug: 423127
Unless bug 423127 gets fixed, this is currently WORKSFORME on Firefox 3.
WFM
Status: NEW → RESOLVED
Closed: 16 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.