The default bug view has changed. See this FAQ.

Status

Core Graveyard
XForms
--
critical
RESOLVED FIXED
10 years ago
9 months ago

People

(Reporter: aaronr, Unassigned)

Tracking

({fixed1.8.1.12})

Trunk
x86
All
fixed1.8.1.12

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.92 KB, patch
Doron Rosenberg (IBM)
: review+
smaug
: review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
Due to checkin for bug 386903, xforms build is broken on the trunk.  We use makejs.pl which that bug removed.  It is used in conjunction with install.jst to create an install.js.  Looks like to fix this build break we'll have to keep around a static install.js like other extensions do.  I think we really only needed it to get our version number and the space required variables.  But when this is fixed we'll have to build both firefox and seamonkey and make sure nothing else is broken.
Duplicate of this bug: 388085
(Reporter)

Comment 2

10 years ago
Created attachment 272542 [details] [diff] [review]
patch

I basically moved the contents of install.jst to install.js.  I hardcode the version number and the space required numbers, using the numbers from the install.js that 1.8 branch still generates.  These space required values are just a guide, anyhow.  I also added the function verifyDiskSpace (copied from the chatzilla install.js).

I also think that this change should be made on the 1.8 branch too, just to keep things common between branch and trunk.
Attachment #272542 - Flags: review?(doronr)
(Reporter)

Updated

10 years ago
Attachment #272542 - Flags: review?(Olli.Pettay)

Updated

10 years ago
Attachment #272542 - Flags: review?(doronr) → review+
Attachment #272542 - Flags: review?(Olli.Pettay) → review+
(Reporter)

Comment 3

10 years ago
Fix checked into trunk.  Branch is closed, so will have to wait on that until 2.0.0.5 goes out.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: xf-to-branch
(Reporter)

Updated

9 years ago
Blocks: 410239
(Reporter)

Comment 4

9 years ago
checked into 1.8 branch via bug 410239.
Keywords: fixed1.8.1.12
Whiteboard: xf-to-branch
(Reporter)

Comment 5

9 years ago
note: this was effectively backed out of the 1.8 branch with bug 411960.  I shouldn't have checked this into 1.8 in the first place.  Doh!
(Assignee)

Updated

9 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.