Status

()

Core
Layout: Misc Code
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Peter6, Assigned: Eli Friedman)

Tracking

Trunk
Points:
---
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
Created attachment 274030 [details]
testcase

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072607 Minefield/3.0a7pre ID:2007072607

repro:
Open FF
install http://ted.mielczarek.org/code/mozilla/fullpagezoom.xpi (pagezoom ext.)
open testcase and zoom in

result:
broken frames
(Assignee)

Updated

10 years ago
No longer blocks: 4821
(Assignee)

Updated

10 years ago
Blocks: 4821
(Reporter)

Comment 1

10 years ago
Created attachment 274067 [details]
testcase including content/scrollbars

testcase including content to show all weirdness.
The scrollbar issues is bug 389659, I don't know if 389659 will fix the odd content selection when you touch the bottom toolbars too.

Updated

10 years ago
Flags: blocking1.9?

Updated

10 years ago
Duplicate of this bug: 389794

Comment 3

10 years ago
I think the fix here is to use CallChildren just like in text zoom. However, that means that the check for the root PresContext would have to go.
(Assignee)

Updated

10 years ago
Component: GFX → Layout: Misc Code
QA Contact: general → layout.misc-code
(Assignee)

Updated

10 years ago
Assignee: nobody → sharparrow1
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 4

10 years ago
Created attachment 274544 [details] [diff] [review]
Patch

I think this is the best way to go about fixing this... we have to make sure to run the style change on subdocuments even though the device context thinks nothing has changed.
Attachment #274544 - Flags: review?(roc)
Attachment #274544 - Flags: superreview+
Attachment #274544 - Flags: review?(roc)
Attachment #274544 - Flags: review+
(Assignee)

Comment 5

10 years ago
Comment on attachment 274544 [details] [diff] [review]
Patch

Low-risk patch; only touches codepath for page zoom.
Attachment #274544 - Flags: approval1.9?
Comment on attachment 274544 [details] [diff] [review]
Patch

a19=dbaron
Attachment #274544 - Flags: approval1.9? → approval1.9+

Updated

10 years ago
Whiteboard: [checkin needed]
a) eli is capable of checking in his own bugs
b) we have a checkin-needed keyword now, use that instead
Whiteboard: [checkin needed]
(Reporter)

Comment 8

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080714 Minefield/3.0a8pre ID:2007080714

testcase 2: scrollbars don't appear when zooming in
----------------------------------------------------
more complex case with many frames:
open gmail
zoom in
click on [Sent Mail] link
click on [inbox] link
reset zoom (zoomfactor 1)

result: a part of the content is not painted, a part is painted enlarged, a part is painted correctly.
(a zoom in/out followed by reset zoom fixes the display again)
(Assignee)

Comment 9

10 years ago
Ugh, that's a regression... not frameset-specific, though.  It's a page navigation regression.
(Assignee)

Comment 10

10 years ago
I'll mark this fixed since the patch was checked in... I'll do the regression fixing in other bugs.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
I couldn't find a bug about it (although I think it was already filed), but I filed bug 421096 for the frame resizer looking wrong while being zoomed in.
You need to log in before you can comment on or make changes to this bug.