Closed Bug 389732 Opened 15 years ago Closed 13 years ago

GetHandlerAppFromPrefs still partially used in unix helper app service

Categories

(Core Graveyard :: File Handling, defect, P4)

x86
Linux
defect

Tracking

(status1.9.2 beta1-fixed, status1.9.1 .4-fixed)

RESOLVED FIXED
mozilla1.9.3a1
Tracking Status
status1.9.2 --- beta1-fixed
status1.9.1 --- .4-fixed

People

(Reporter: dmosedale, Assigned: wolfiR)

References

()

Details

(Keywords: memory-footprint, regression, Whiteboard: [proto][tb3needed])

Attachments

(1 file, 1 obsolete file)

When the protocol handling dialog landed, we got rid of the code that allows a protocol handler to be invoked entirely from information contained in preferences on Unix systems in order to simplify the code (more discussion about that decision will ensue in the newsgroups shortly).  However, the helper app service still looks at that information in OSProtocolHandlerExists and GetApplicationDescription, which could leave it in a confused state for those users who have tweaked this stuff until now.  Thanks to bz for noticing this.
Flags: blocking1.9?
No longer blocks: 385065
Depends on: 385065
Assignee: nobody → dmose
Flags: blocking1.9? → blocking1.9+
Whiteboard: [proto]
Target Milestone: --- → mozilla1.9 M9
Target Milestone: mozilla1.9 M9 → ---
Priority: -- → P2
Priority: P2 → P3
Priority: P3 → P4
Version: unspecified → Trunk
Dmose we gonna get this fixed?
With a few exceptions, I'm mostly focused on MailCo-related hacking now.  Reassigning a bunch of bugs to default component owners.  I'm happy to help with brainstorming/advice as needed, however.  

Search for the string MAILMONKEY to delete any bugmail generated by this change.
Assignee: dmose → nobody
Flags: tracking1.9+ → wanted-next+
Attached patch patch (obsolete) — Splinter Review
Not sure if that is enough. Anything else to modify?
Comment on attachment 318362 [details] [diff] [review]
patch

I think this is it.
Attachment #318362 - Flags: superreview?(dmose)
Attachment #318362 - Flags: review?(cbiesinger)
Comment on attachment 318362 [details] [diff] [review]
patch

maybe we should migrate those prefs to the RDF DS?
Attachment #318362 - Flags: review?(cbiesinger) → review+
ping for sr ? Shwn
Attachment #318362 - Attachment is obsolete: true
Attachment #318362 - Flags: superreview?(dmose)
This doesn't contain an API change, and so doesn't need sr anymore.
Duplicate of this bug: 480709
http://hg.mozilla.org/mozilla-central/rev/b17077657692
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Attachment #395299 - Attachment description: patch (unbitrot) → patch (mozilla-central) (checked in)
Assignee: nobody → mozilla
I think we'll need this for thunderbird3, there's been a fair number of reports of people being unable to open links due to this.
Whiteboard: [proto] → [proto][tb3needs]
Target Milestone: --- → mozilla1.9.2b1
Attachment #395299 - Flags: approval1.9.2?
Magnus, you're closer to this than I am, can you request 1.9.1 approval with a risk analysis if you think we need to for TB 3. Thanks.
Comment on attachment 395299 [details] [diff] [review]
patch (mozilla-central) (checked in)

Requesting branch approval so we can get this for tb3. This patch affects unix code only. The risk shouldn't be very high, given that it's pretty broken as is for users who had the old prefs set. 

The gain is obvious as not being able to open links in a mail is quite frustrating. I think the prefs were fairly commonly used as it used to be hard to get things working as you wanted without them a few years back.
Attachment #395299 - Flags: approval1.9.1.3?
Whiteboard: [proto][tb3needs] → [proto][tb3needs][awaiting branch approval]
Duplicate of this bug: 512944
Attachment #395299 - Flags: approval1.9.1.3? → approval1.9.1.4?
Comment on attachment 395299 [details] [diff] [review]
patch (mozilla-central) (checked in)

Seems reasonable enough, but I'd like some 1.9.2 testing/baking before approving for 1.9.1
Flags: blocking1.9.2?
Attachment #395299 - Flags: approval1.9.1.4?
Comment on attachment 395299 [details] [diff] [review]
patch (mozilla-central) (checked in)

Please re-request 1.9.1 approval after this lands on 1.9.2

Since this is a non-blocking bug you may need to track down the drivers via IRC or mail because this may never bubble onto their queries.
Attachment #395299 - Flags: approval1.9.2? → approval1.9.2+
Comment on attachment 395299 [details] [diff] [review]
patch (mozilla-central) (checked in)

a192=beltzner
Whiteboard: [proto][tb3needs][awaiting branch approval] → [proto][tb3needs][needs 192 landing][needs baking 192 before approval on 191]
I pushed this to 1.9.2 so we can get some baking time before we need it on 1.9.1 for TB 3: http://hg.mozilla.org/releases/mozilla-1.9.2/rev/4114e5200fbb
Keywords: checkin-needed
Whiteboard: [proto][tb3needs][needs 192 landing][needs baking 192 before approval on 191] → [proto][tb3needs][baking on 192 before request approval on 191]
Target Milestone: mozilla1.9.2b1 → mozilla1.9.3a1
Duplicate of this bug: 514826
Comment on attachment 395299 [details] [diff] [review]
patch (mozilla-central) (checked in)

Requesting 1.9.1 branch approval, please see comment 13 for more details.

I've taken a look through the recently filed bugs and not found any regressions filed.
Attachment #395299 - Flags: approval1.9.1.4?
Whiteboard: [proto][tb3needs][baking on 192 before request approval on 191] → [proto][tb3needs][awaiting 1.9.1 approval]
Comment on attachment 395299 [details] [diff] [review]
patch (mozilla-central) (checked in)

Approved for 1.9.1.4, a=dveditz for release-drivers
Attachment #395299 - Flags: approval1.9.1.4? → approval1.9.1.4+
Checked into 1.9.1 branch:

http://hg.mozilla.org/releases/mozilla-1.9.1/rev/d6b7f6c45a8e

Had to adjust the patch slightly because bug 469023 isn't on 1.9.1 - but this just meant not doing a change in an ifdef section.
Flags: blocking1.9.2?
Whiteboard: [proto][tb3needs][awaiting 1.9.1 approval] → [proto][tb3needed]
Can I get clear repro steps for this issue so QA can verify it is fixed and close it?
(In reply to comment #23)
> Can I get clear repro steps for this issue so QA can verify it is fixed and
> close it?

Bug 480709 was duped to this bug. Bug 480709 comment 19 look like reasonably clear STR (but other comments on that bug might be useful as well).
I don`t see how this should be resolved!
Thunderbird 3.0b4 still ignores the network.protocol-handler.app.http(s) property and still does not offer a user friendly way to select the default browser.
Elmar, why do you think it is in Thunderbird, Beta 4? Did someone tell you it was fixed in that build? This was checked into 1.9.1, where Thunderbird 3 is built from, on September 14. I suspect that TB Beta 4 was forked before this went in and you'll need to check in the final release.

You could also get a 1.9.1 Thunderbird nightly at ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-1.9.1/ and check to see if it is fixed there.
(In reply to comment #25)
> I don`t see how this should be resolved!

This bug was about removing a bunch of code, not about restoring the old functionality.

> Thunderbird 3.0b4 still ignores the network.protocol-handler.app.http(s)
> property and still does not offer a user friendly way to select the default
> browser.

If you feel the UI offered in the Attachments pane of the preferences dialog is insufficient in some way, feel free to file another bug.  You may wish to look through the Gecko file-handling bugs first, as there are already some bugs filed on various deficiencies related to that UI.  Feel free to CC me on any bug you file.
Duplicate of this bug: 547370
This bug is still in the code as of Eudora 1.0 rc1 (which I guess is based on T'Bird 3.0.4.

Is the protocol to open a new one, or reopen this one?
Sorry, I hit the "save" button too soon.

The symptom I'm referring to is "https links in emails don't work."  This is on Windows XP, with Firefox as the target browser for T'Bird

network.protocol-handler.app.https;firefox

Everything works fine with the corresponding ftp and http links.
A new bug would be great; thanks!
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.