Last Comment Bug 390331 - Thunderbird does not configure Word XP (2002) "File, Send To: Mail Recipient" options
: Thunderbird does not configure Word XP (2002) "File, Send To: Mail Recipient"...
Status: RESOLVED FIXED
[64 bit + non-regression see Bug 393302]
: regression
Product: MailNews Core
Classification: Components
Component: Simple MAPI (show other bugs)
: unspecified
: x86 Windows XP
: -- normal with 2 votes (vote)
: Thunderbird 19.0
Assigned To: Hiroyuki Ikezoe (:hiro)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 11:13 PDT by Matt
Modified: 2012-11-06 14:35 PST (History)
15 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
A workaround for WinXP (1.06 KB, patch)
2010-09-15 17:30 PDT, Hiroyuki Ikezoe (:hiro)
robert.strong.bugs: review-
Details | Diff | Splinter Review
Set HLKM key as possible (2.08 KB, patch)
2012-07-18 16:23 PDT, Hiroyuki Ikezoe (:hiro)
standard8: review+
Details | Diff | Splinter Review

Description Matt 2007-07-31 11:13:51 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20061201 Firefox/2.0.0.5 (Ubuntu-feisty)
Build Identifier: version 2.0.0.5 (20070716)

I've found that doing an install of Thunderbird (TB) 2x onto a fresh install of XP with Office XP fails to set up the particulars that would allow a user to "File > Send To > Mail Recipient" in MS Word. While I don't have any problem right clicking a file and choosing "Send To > Mail Recipient" from the desktop, I cannot do so in Word (or Excel).

This is only the case with the 2x client. If I go back, install 1.5 (tested with a few different versions) the option is available. I can then upgrade to TB 2x and the functionality remains. 

Background:
Windows XP (Fully patched)
Office XP SP3 (Fully patched)
Thunderbird 2x (I've tested with all of the 2.x installs)

Missing (or grayed) Options in Send To menu:
Mail Recipient (for Review)
Mail Recipient (as Attachment) 

To see what steps have been taken to work this out, please view http://forums.mozillazine.org/viewtopic.php?p=2990470#2990470

Reproducible: Always

Steps to Reproduce:
1. Install Windows XP
2. Install Office XP (you can install office before or after step 3, makes no diff)
3. Install Thunderbird 2.0x
4. Open Word
5. Navigate: File > Send To
6. Observe that you aren't sending anything to a mail recipient.
Comment 1 Todd Baremore 2007-08-05 11:40:42 PDT
FWIW, I'm having exactly the same experience with the same versions. Reinstalling both applications had no effect. Using Symantec Internet Security on Windows XP Pro SP2, fully patched.  
Comment 2 Magnus Melin 2007-09-02 12:18:16 PDT
Do you have 64 bit machines? (Bug 393302, or maybe that bug is more general.)
Comment 3 Matt 2007-09-03 04:33:15 PDT
All 32bit machines in my case.
Comment 4 Magnus Melin 2007-09-25 07:59:02 PDT
Does reinstall help? Reinstall into another empty folder? Works fine for me after a normal install...
Comment 5 James Paige 2008-03-25 09:35:29 PDT
I have seen this same symptom appear after an automatic upgrade. I have a system with 2.0.0.12 on Windows XP. I don't know what the version was before the automatic upgrade, but "Send to" used to work fine in Excel and Word, and now it doesn't (Insists on using Outlook if it is present, or saying "General Mail Failure" if I remove Outlook entirely)

"Send to" to thunderbird works fine if I right-click on a saved file outside of Excel/Word
Comment 6 Magnus Melin 2008-08-25 14:13:14 PDT
To reiterate comment 4. Have you tried reinstalling? (Into another, empty folder.)
Comment 7 James Paige 2008-08-26 08:04:59 PDT
(In reply to comment #6)
> To reiterate comment 4. Have you tried reinstalling? (Into another, empty
> folder.)
> 

I can't speak for the original poster, but I have tried installing into anothe folder, and it makes no difference. I have tried installing thunderbird on a machine that has never had any version of thunderbird on it before, and it makes no difference. MAPI send to is broken on Windows with Thunderbird 2.x (I have tested up to 2.0.0.16)

I do have a workaround for this problem. If I install Thunderbird 15.0.0.14 and then I install 2.0.0.16 over the top of it, then MAPI send works everywhere, even inside Microsoft Word.

Note that my profiles make no difference. I get the same results with a pristine profile as I do with a old profile.

Also, In addition to affecting Microsoft Word, this problem also affects any Scanners which use MAPI to implement a "Scan To E-Mail" feature.
Comment 8 Robert Strong [:rstrong] (use needinfo to contact me) 2008-08-26 11:43:40 PDT
Has anyone reproduced with a non MS product?

I don't know of any special requirements for Word / Excel 2002 to use MAPI and it appears other apps aren't having a problem with using send to as stated in comment #0... does anyone else know of any? Office does rewrite the reg keys for icons and then stores it in a different part of the reg... it may be that it is doing the same here.
Comment 9 James Paige 2008-08-26 11:54:25 PDT
(In reply to comment #8)
> Has anyone reproduced with a non MS product?

I have reproduced it with the "Scan Document to E-Mail" feature of the HP's scan utility software for the HP Laserjet 3055.

(this was on two of the same computers where I tested the MS Office "Send To" problem)
Comment 10 hy67691 2009-06-24 06:07:40 PDT
I am having a similar problem. Occuring now after the upgrade to 2.0.0.22 was working fine before I did the update yesterday. Was working fine in all applications - Word, Excel, and Adobe Acrobate Professional 9. Any ideas on a fix would be appreciated. If not a fix, how do we go back to 2.0.0.21?
Comment 11 hy67691 2009-06-24 06:08:54 PDT
I am having a similar problem. Occuring now after the upgrade to 2.0.0.22 was working fine before I did the update yesterday. Was working fine in all applications - Word, Excel, and Adobe Acrobat Professional 9. Any ideas on a fix would be appreciated. If not a fix, how do we go back to 2.0.0.21? 

Tried to "fix" Acrobat and re-booted but still not working there or any of the other applications.
Comment 12 James Paige 2009-06-24 09:18:55 PDT
This problem does not just affect "Send To" in Microsoft Office XP 2002. This affects any MAPI send operation. For example, open "My Documents", right click on a file, and pick "Send To->Mail Recipient" and it will also fail. So will scanners that have a scan-to-email feature.

I do know a workaround for this problem. Apparently the problem is NOT with Thunderbird 2.0.0.22, the problem is actually with the automatic upgrade to 2.0.0.22

If you download the thunderbird installer from http://mozilla.org/ and manually reinstall, "Send To" will start working again.

(Also, hy67691@yahoo.com although you don't need to go back to an older version to fix this problem, there is a complete archive of all older versions available at ftp://ftp.mozilla.org/pub/thunderbird/releases/ )
Comment 13 James Paige 2009-07-02 07:36:35 PDT
I noticed [64 bit + non-regression see Bug 393302] added to the whiteboard, and I just wanted to notice that I have reproduced this problem on dozens of 32 bit machines. There is nothing 64-bit specific about this bug.
Comment 14 oahmad 2009-11-05 18:31:13 PST
I have the same problem (XP Home, Word 2003).  The instructions to modify the registry values HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem 
fixed the problem.  See http://support.microsoft.com/kb/834008/en-us
for step-by-step instructions.
Comment 15 Patrick Seher 2010-06-28 07:40:33 PDT
hello,

back to the original problem: 
- MS Word: "File > Send To > Mail Recipient" doesnt work
- Desktop: Send To > Mail Recipient works

I have this problem on every machine with NO MS-Outlook installed. If you install MS-Outlook (but set Thunderbird as default mailer) everything works as exepected.

The Problem still appears in TB 3.1!

-> Big problem for all People which have no Outlook installed...
Comment 16 Hiroyuki Ikezoe (:hiro) 2010-09-08 19:09:06 PDT
(In reply to comment #8)
> Has anyone reproduced with a non MS product?

Robert, please try a test program in bug 594224.

If HKEY_LOCAL_MACHINE\Software\Clients\Mail is not "Mozilla Thunderbird", you will not see a compose window of Thunderbird.
Comment 17 Robert Strong [:rstrong] (use needinfo to contact me) 2010-09-08 19:12:13 PDT
(In reply to comment #16)
> (In reply to comment #8)
> > Has anyone reproduced with a non MS product?
> 
> Robert, please try a test program in bug 594224.
> 
> If HKEY_LOCAL_MACHINE\Software\Clients\Mail is not "Mozilla Thunderbird", you
> will not see a compose window of Thunderbird.
I trust you. :)

That sounds like there is an OS bug if it requires the system level default to be set. Glad to see you are working on bug 594224.
Comment 18 Hiroyuki Ikezoe (:hiro) 2010-09-08 19:20:07 PDT
(In reply to comment #17)
> (In reply to comment #16)
> > (In reply to comment #8)
> > > Has anyone reproduced with a non MS product?
> > 
> > Robert, please try a test program in bug 594224.
> > 
> > If HKEY_LOCAL_MACHINE\Software\Clients\Mail is not "Mozilla Thunderbird", you
> > will not see a compose window of Thunderbird.
> I trust you. :)
> 
> That sounds like there is an OS bug if it requires the system level default to
> be set. 

Agreed. But I suppose Microsoft does not think so.

So if Thunderbird supports simple MAPI on Win XP, Thunderbird should change the system registry key for users.
Comment 19 Robert Strong [:rstrong] (use needinfo to contact me) 2010-09-08 19:33:47 PDT
I wouldn't be surprised if Microsoft does think it is a bug but won't fix it regretfully.
Comment 20 Hiroyuki Ikezoe (:hiro) 2010-09-15 17:30:13 PDT
Created attachment 475718 [details] [diff] [review]
A workaround for WinXP
Comment 21 Robert Strong [:rstrong] (use needinfo to contact me) 2010-09-15 17:35:07 PDT
Comment on attachment 475718 [details] [diff] [review]
A workaround for WinXP

This isn't a complete workaround since you won't always have admin privs though it will fix this for the case where the user is running with admin privs.

A potentially better solution would be to just steal that registry key on app update when we will typically have admin privs as well as on install.

You should probably get approval on the behavior of whichever workaround is used from someone on the Thunderbird team first and then I can review the code.
Comment 22 Hiroyuki Ikezoe (:hiro) 2010-09-15 17:48:19 PDT
(In reply to comment #21)
> Comment on attachment 475718 [details] [diff] [review]
> A workaround for WinXP
> 
> This isn't a complete workaround since you won't always have admin privs though
> it will fix this for the case where the user is running with admin privs.

I think the function (SetAsDefaultMailAppUserHKCU) is always invoked with admin privs, isn't it?

http://mxr.mozilla.org/comm-central/source/mail/installer/windows/nsis/shared.nsh#667

> You should probably get approval on the behavior of whichever workaround is
> used from someone on the Thunderbird team first and then I can review the code.

I am going to request another person. Thank you for your quick review!
Comment 23 Robert Strong [:rstrong] (use needinfo to contact me) 2010-09-15 17:49:54 PDT
(In reply to comment #22)
> (In reply to comment #21)
> > Comment on attachment 475718 [details] [diff] [review] [details]
> > A workaround for WinXP
> > 
> > This isn't a complete workaround since you won't always have admin privs though
> > it will fix this for the case where the user is running with admin privs.
> 
> I think the function (SetAsDefaultMailAppUserHKCU) is always invoked with admin
> privs, isn't it?
No, it isn't. It is for setting the KHCU registry keys which don't require admin privs.
Comment 24 WADA 2011-02-17 23:29:27 PST
To all problem reporters in this bug after 2010/01:
Your problem is one explained in bug 618678? (mozMapi32_InUse.dll in DLLPath of the cited Win's registry entry in this bug too)
Comment 25 Hiroyuki Ikezoe (:hiro) 2011-02-17 23:36:59 PST
No. This bug is for Windows XP not for Windows 7.
Comment 26 WADA 2011-02-18 00:04:25 PST
(In reply to comment #25)
> No. This bug is for Windows XP not for Windows 7.

Ikezoe san, bug 618678 was reported by Win7 user, but it's not Win7 only problem(there is no "Platform: Windows-All" choice.)
There seems being several variants in Simple MAPI problems with Tb;
 (1) Only installer creates relevant registry key.
 (2) DLLPath in the registry key is set as mozMapi32_InUse.dll by running Tb.
 (3) Some MAPI modules which Simple MAPI uses was broken by Win7
     after drop of Simple MAPI support by Win7. Hotfix by MS is available.
 Problems seem to have been born in this order. (2) is newer than (1).
 Win7 only problem is (3).
Comment 27 Hiroyuki Ikezoe (:hiro) 2012-07-18 16:23:52 PDT
Created attachment 643660 [details] [diff] [review]
Set HLKM key as possible

"-setDefaultMail" of command line options is already set HKLM\Software\Clients\Mail.

Outlook Express does set the key if the user has a write permission for the HKLM key.

This patch does set the key the user, who are going to install Thunderbird (or set Thunderbird as default mail client), has a write permission of the key. If the user does not have the permission, WriteRegStr silently fails.
Comment 28 Mark Banner (:standard8) 2012-10-30 01:53:24 PDT
Comment on attachment 643660 [details] [diff] [review]
Set HLKM key as possible

Sorry for the delay, this looks fine.
Comment 29 Ryan VanderMeulen [:RyanVM] 2012-11-06 14:35:09 PST
https://hg.mozilla.org/comm-central/rev/6090d96d358e

Note You need to log in before you can comment on or make changes to this bug.