Open Bug 391190 Opened 13 years ago Updated 7 years ago

message "forward as attachment" from pop or local folder loses attachment if original email is moved/deleted before message is sent

Categories

(Thunderbird :: Message Compose Window, defect, P3)

defect

Tracking

(Not tracked)

Thunderbird 3.0rc1

People

(Reporter: waynegwoods, Unassigned)

References

(Depends on 2 open bugs, Blocks 1 open bug)

Details

(Keywords: dataloss, Whiteboard: proposed fix: immediate snapshot copy upon attaching (bug 378046))

I'm surprised I can't find a dupe for this. There must be one somewhere...

Select a message in the threadpane and choose to "Forward as attachment". Then move that message before the new one containing the attachment can be sent.

The new message is sent with no warnings or errors, despite the fact that it can no longer find an email to attach. It sends a seemingly empty attachment with a suffix that ends in ".zmc" instead of .eml, and with all whitespaces removed from the filename. However the copy placed in the Sent folder displays the original attachment name and .eml suffix, again suggesting that nothing is wrong.

Usually the scenario in which this happens is when the network is slow and I manage to delete the received email before the one to which it was attached has been sent (e.g. when sending spam to SpamCop).

This is related to bug 216776, though that bug is about bad error messages when trying to send moved file attachments. But if it's an email that is moved, no warning is given at all.

Setting severity to Major since this could result in the loss of important data.
Flags: blocking-thunderbird3?
hey wayne :)

imap - WFM version 3.0a1pre (2007082004) whether I move original or delete it.
local - fails if sent from local folder
pop - fails also
it is an edge case, but dataloss is indeed possible

tested "save as draft" for pop and the attachment is corrrectly saved with the draft

see also bug 273349
Severity: major → critical
Keywords: dataloss
OS: Windows XP → All
Hardware: PC → All
Summary: No error message when an attached email is moved/deleted before message is sent → message "forward as attachment" from pop or local folder loses attachment if original email is moved/deleted before message is sent
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3-
Mainly due to inconsistent behaviour on "when attachment data is copied".
It causes problem of this bug, Bug 378046, etc.
And in this bug's case, silently fails, then null attachment is sent.
This bug & Bug 378046 won't occur if "Save As Draft"(including auto-save) is executed, after action of "add attachment", before other action such as "delete mail(this bug)", "alter content of attachment file(Bug 378046)".
Keeping as wanted‑thunderbird3+ for now. Any takers?
Priority: -- → P3
Target Milestone: --- → Thunderbird 3.0rc1
Depends on: 378046
It's quite suprising how dataloss bugs can go for years without any attention.
Has this been fixed?

If not, maybe a developer can set Target Milestone to something more recent, also in view of the fact that David Ascher has flagged this wanted-thunderbird3+ ?
Whiteboard: proposed fix: immediate snapshot copy upon attaching (bug 378046)
No longer depends on: attach-paradigm-fail
Depends on: 722094
You need to log in before you can comment on or make changes to this bug.