Addition of "Lock Tab" to lock a tab, and force links to another tab

UNCONFIRMED
Unassigned

Status

()

enhancement
UNCONFIRMED
12 years ago
10 years ago

People

(Reporter: dmcritchie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wontfix?)

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Enhancement request "Lock Tab" so that invoking a link within will be invoked to a new tab (default for target="new").  

Preparation of the content of a tab for viewing can take awhile for example using a link checker that color codes severity of link problems by checking each link, would like to be safe from losing view of this tab, and of losing my place as I scroll down checking links for replacements that no link would inadvertently be placed on top.

Additional attributes: a locked tab can not be closed, modified, or refreshed unless first unlocked.  A locked tab must not interfere with find, selection, scrolling, moving tab within the tab bar.
 
Context Menu on the tab itself
   "Lock this tab"   vs "Unlock this tab"

keywords:  lock tab, freeze tab

Reproducible: Always

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 330279
FWIW TabMixPlus extension can add this functionality.
Reporter

Comment 3

12 years ago
Reply to Comment #1,

And how does "Enhancement request "Lock Tab" so that invoking a link within will be invoked to a new tab (default for target="new")."  even resemble Bug 330279. 


That enhancement request (Bug 330l79} specicically stated like in Opera and I just checked Opera and a locked tab in Opera does not prevent a link from being invoked into the same tab.  Nor does it prevent use of reset. And while you can't close a locked tab in Opera you can close the window with locked tabs and other tabs without even the warning that Firefox issues when you attempt to close multiple tabs   

As far as the minor resemblance to Bug 330179 about no way to close, Firefox does issue a warning when an attempt is made to close multiple tabs, so that part is not even a big deal.at you can heed or ignore when closing multiple tabs.  
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

12 years ago
* I do see a significant resemblance between the 2 bugs.
* IMO this is less likely than the other bug to be used by a significant portion of the user base and therefore belongs in an extension.  (also, there already is some related functionality in an extension although I'm not sure exactly what)

btw, you can change whether new tabs from links opened are focused immediately in the 'Tabs' tab in preferences and you can reverse the behavior for individual clicks by adding shift.  (so ctrl/cmd-click -> ctrl/cmd-shift-click)

Note: the only bug link in the previous comment that is actually related is the one that this was duped against.
Reporter

Comment 5

12 years ago
Reply to comment #4
I know about shortcut keys, the idea is to prevent accidentally forgetting
to use the short cut keys when in a specific tab.  But I checked out TMP
and results were as follows:

Reply to Comment #2

I checked out TMP (addon #1122) and use of Link Checker (addon #532) as
something that the results should be protected and found that the tab context
menu combination does match two out of three things I asked for.  Preventing
links from being opened in a specific tab was the most important. 

 Lock Tab  - prevents a link from being opened in same tab

 Protect Tab - prevents closing a tab with [x] or Ctrl+W like in Opera's "Lock
    Tab"   and unlike Opera it does warn you if you attempt to close Window.

So TMP does address the enhancement request though, I think it should be part
of Firefox, and I personally would not use TMP in my default profile.

I also think the option naming in TMP is reversed logically with what one would generally expect "Lock" to mean.

Updated

12 years ago
Whiteboard: wontfix?

Comment 6

10 years ago
This bug should have been marked as DUPLICATE.

Comment 7

10 years ago
Duplicate of?

Comment 8

10 years ago
You posted the comment yourself above:

> Comment #1 From Kevin Brosnan 2007-08-15 06:59:29 PDT (-) [reply]
> 
> *** This bug has been marked as a duplicate of bug 330279 ***

but it never got marked as duplicate.

Comment 9

10 years ago
If you view the history of the bug then you will see that the reporter disagreed with my evaluation. https://bugzilla.mozilla.org/show_activity.cgi?id=392313
You need to log in before you can comment on or make changes to this bug.