Proper font fallback for variant selectors

REOPENED
Assigned to

Status

()

Core
Graphics
REOPENED
11 years ago
6 years ago

People

(Reporter: Jean-Marc Desperrier, Assigned: smontagu)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
As visible on the page http://babelstone.blogspot.com/2007/06/secret-life-of-variation-selectors.html
font fallback doesn't work properly for character on which a variant selector has been applied.

The fallback font is selected by searching a font that contains the character without taking into account the variation selector. So the first font found is used, and it usually can't display properly the variant selected by the variation selector, even though another font exists on the system that can.

Reproduction steps :
- download and install a recent version of code2000:
http://www.code2000.net/code2000_page.htm
- display the "Mathematical Variation Sequences" table on the following page:
http://babelstone.blogspot.com/2007/06/secret-life-of-variation-selectors.html
- Without a fix for bug 387888, none of the VS1 character will be displayed correctly. With a fix for bug 387888, all of them will be displayed correctly
- In the Fx option, disable the "Allow pages to choose their own fonts, instead of my selections above" option
- the characters above U+2A3C will be displayed properly, because they only exist inside code2000
- the characters between U+2229 and U+22DB will not be displayed properly, because they exist in some very common windows fonts (Arial Unicode MS, Batang, ect.) and they will be displayed using one of those
(Reporter)

Comment 1

8 years ago
I think now the description above is not very clear.
Better method :

- download and install a recent version of code2000:
http://www.code2000.net/code2000_page.htm
- display this page:
http://jmdesp.free.fr/i18n/varsel/math-variation-selectors-axx.html
- colon 3 should be similar to colon 2. In fact it's similar to colon 1, because the variant selector is not taken into account when doing font fall-back.

As variant selector version of character won't usually be available in the default font, that behavior is quite a problem.

Comment 2

6 years ago
This was implemented in bug 569350.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569350
Bug 569350 didn't implement font fallback described in comment #1.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 571372
Blocks: 552460
You need to log in before you can comment on or make changes to this bug.