Closed Bug 392812 Opened 14 years ago Closed 14 years ago

Restart button in Installation tab remains grayed out after an update of multiple extensions

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9alpha8

People

(Reporter: Peter6, Assigned: mossop)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081910 Minefield/3.0a8pre ID:2007081910

repro:
set extensions.checkCompatibility false
Open the add-ons manager and check for update(s)
When you're lucky, AM jumps to the installation tab
Install the update(s)

result:
the updates are installed, but the Resyart button remains grayed out.
when you go to the extensions tab, the Restart button can be used.

expected:
the restart button in the installation tab to work
bug 351819 is branch, and I really don't know if the trunk add-ons manager (code) is the same.

bug 390878 has too little information about how to reproduce.
extensions.checkCompatibility false wasn't mentioned
Bug 351819 at one point was also trunk though I haven't verified whether we reenable the button with the change to the ui code.

Can you reproduce without extensions.checkCompatibility set to false. extensions.checkCompatibility is for testing and is use at your own risk so if this is the only way to reproduce this bug will be a lower priority.
(In reply to comment #4)
> Can you reproduce without extensions.checkCompatibility set to false.
> extensions.checkCompatibility is for testing and is use at your own risk so if
> this is the only way to reproduce this bug will be a lower priority.
> 

Yeah, same happens when extensions.checkCompatibility is true
(neither extension is compatible with FF3.0A7 though)
This sounds like it is a dupe of Bug 351819 in that we don't update the state after a compatibility check (due to there being nothing to inform us at present).
This is a somewhat different case to bug 351819 (which now appears fixed). This bug only happens when updating extensions, and from my tests it appears only when updating multiple extensions. When the updates are running the restart button is enabled, when all the updates have finished the restart button disabled.

The extensions I was testing with required no compatibility update check.
Summary: Restart button in Installation tab remains grayed out after an extension update → Restart button in Installation tab remains grayed out after an update of multiple extensions
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: --- → Firefox 3 M9
Duplicate of this bug: 393453
Attached patch patch rev 1Splinter Review
There's a combination of failures going on here:

updateOptionalViews isn't resetting gInstallCount.

updateOptionalViews (correctly I think) counts downloads that are waiting and will in the future send DOWNLOAD_START.

The DOWNLOAD_START and INSTALL_DONE handlers are not called if we are viewing a pane of the add-ons UI that doesn't contain the relevant add-on.

The patch removes the gInstallCount increment and instead ensures we always call updateOptionalViews and updateGlobalCommands after any new downloads are added (I think that should be happening anyway). Then I ensure that the INSTALL_DONE handler is always used. This has a side effect of displaying installation errors even when not on the install pane, I think that's sensible too.

There is also a minor change to the extension manager, not actually needed but I can't see why we should maintain multiple entries in the transactions list for a single transaction. And deleting a function parameter apparently does nothing and there appears no need to anyway.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #278759 - Flags: review?(robert.bugzilla)
Just a remark: The Restart button is also grayed out after updating a _single_ extension (not only after updating multiple extensions as the topic suggests).
Attachment #278759 - Flags: review?(robert.bugzilla) → review+
Checking in toolkit/mozapps/extensions/content/extensions.js;
/cvsroot/mozilla/toolkit/mozapps/extensions/content/extensions.js,v  <--  extensions.js
new revision: 1.141; previous revision: 1.140
done
Checking in toolkit/mozapps/extensions/src/nsExtensionManager.js.in;
/cvsroot/mozilla/toolkit/mozapps/extensions/src/nsExtensionManager.js.in,v  <--  nsExtensionManager.js.in
new revision: 1.246; previous revision: 1.245
done
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 3 M9 → Firefox 3 M8
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.