Closed Bug 351819 Opened 15 years ago Closed 13 years ago

When installing an incompatible extension that is made compatible via its update rdf the Restart button is not enabled (1.8 branch only)

Categories

(Toolkit :: Add-ons Manager, defect)

1.8 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: JasnaPaka, Unassigned)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060908 BonEcho/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060908 BonEcho/2.0b2

Latest Thunderbird 2.0 NB:
1. Open Add-ons dialog.
2. Choose Install, select extension from local drive, confirm install dialog. 

Reproducible: Always

Actual Results:  
Section "Installation" is showed but button "Restart Thunderbird" is disabled.

Expected Results:  
Section "Installation" is showed, button "Restart Thunderbird" is enabled.

When I choose section "Extensions" and next "Installation", button is enabled. Maybe same problem in latest Firefox 2.0 NB but there is Install button disabled by default.
This is an Add-ons manager problem. I saw this early this summer and pointed it out to Robert Strong, but I guess it never got filed.
Assignee: mscott → nobody
Status: UNCONFIRMED → NEW
Component: General → Extension/Theme Manager
Ever confirmed: true
OS: Windows XP → All
Product: Thunderbird → Firefox
QA Contact: general → extension.manager
Hardware: PC → All
Summary: Disable button Restart Thunderbird after extension install → After installing some extensions, Restart Firefox/Thunderbird button is disabled
Version: unspecified → 2.0 Branch
The problem can be reproduced with the Mouse Gestures extension for Firefox. https://addons.mozilla.org/firefox/39/
Summary: After installing some extensions, Restart Firefox/Thunderbird button is disabled → When installing an incompatible extension that is made compatible via its update rdf the Restart button is not enabled
*** Bug 352164 has been marked as a duplicate of this bug. ***
The version of Adblock that I installed in Bug 352164 wasn't incompatible fwiw.
(In reply to comment #4)
> The version of Adblock that I installed in Bug 352164 wasn't incompatible fwiw.
Actually, the version of adblock you installed in Bug 352164 was only compatible with versions up to 2.0a3 and has a minVersion of 0.7. So, unless you were using 2.0a3 or below it was incompatible.
*** Bug 356647 has been marked as a duplicate of this bug. ***
*** Bug 358545 has been marked as a duplicate of this bug. ***
With the number of extensions that *didn't* break between 1.5 and 2.0, this is pretty visible now (because there's a lot of extensions that didn't have to be updated for 2.0 and only had their maxVersion bumped on the addons site).  I've run into this on almost every extension I've installed in 2.0 so far.
Flags: blocking1.8.1.2?
Assignee: nobody → robert.bugzilla
Not blocking, but we will take a patch is something turns up.  Rob says they're going to figure this out for 3.0 eventually... so we can port it to the branches then.
Flags: blocking1.8.1.2? → blocking1.8.1.2-
Depends on: 369075
Duplicate of this bug: 371719
Duplicate of this bug: 372481
Duplicate of this bug: 378367
Duplicate of this bug: 378560
I've been getting a lot of reports from thunderbird users running into this too.
Duplicate of this bug: 379362
iirc when I looked at this a while back this won't fix it when on a slow connection and the update rdf is not cached due to doing an install instead of an update? I think the better solution is to rewrite the EM service to handle it but if this does in fact fix it in the case I asked then I am all for it until the EM can be rewritten.
Ah,I guess that explains why I have to use such a large timer. I guess this won't work for slow connections. I don't know anything about this code. The patch is just a hack. Clearly, something more sensible should be done.
Duplicate of this bug: 379961
Duplicate of this bug: 383103
This appears fixed by bug 369075 (or one of its dependencies)
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Duplicate of this bug: 390878
Duplicate of this bug: 397399
Should this be reopened by comment #19? This bug affect Firefox 2.0.0.x
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
2.0 Branch only. Fixed on trunk by bug 369075
(In reply to comment #26)
> 2.0 Branch only. Fixed on trunk by bug 369075
> 

Well,now that there is no longer a permanent restart button on trunk either (which is what bug 369075 did to fix this) this seems to be back there as well.
Flags: blocking-firefox3?
(In reply to comment #27)
> (In reply to comment #26)
> > 2.0 Branch only. Fixed on trunk by bug 369075
> > 
> 
> Well,now that there is no longer a permanent restart button on trunk either
> (which is what bug 369075 did to fix this) this seems to be back there as well.
> 
Hmm. Guess I should have done this first.  When I went back to document the steps to reproduce I could not reproduce it.  Something must have recently changed as i did run into this when applying updates within the last couple of weeks.

Either that or there is something else required to run into the issue.  In either event it would appear to be different than this bug.
Flags: blocking-firefox3?
This was fixed on trunk by bug 396129 which is not viable for the branch.
Assignee: robert.bugzilla → nobody
Status: REOPENED → NEW
Product: Firefox → Toolkit
Per comment 29 this is fixed in Firefox 3, we're not going to be porting a fix back to Firefox 2.
Status: NEW → RESOLVED
Closed: 14 years ago13 years ago
Resolution: --- → FIXED
(In reply to comment #30)
> Per comment 29 this is fixed in Firefox 3, we're not going to be porting a fix
> back to Firefox 2.

In that case we should close this bug, which is about mozilla1.8, as WONTFIX and not FIXED. As you have said bug 396129 is about mozilla1.9.
Resolution: FIXED → WONTFIX
Summary: When installing an incompatible extension that is made compatible via its update rdf the Restart button is not enabled → When installing an incompatible extension that is made compatible via its update rdf the Restart button is not enabled (1.8 branch only)
Duplicate of this bug: 456762
You need to log in before you can comment on or make changes to this bug.