Closed Bug 392980 Opened 14 years ago Closed 14 years ago

nsFaviconLoadListener needs to list nsIRequestObserver in its IMPL_ISUPPORTS line (###!!! ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr')

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Biesinger, Assigned: Biesinger)

References

()

Details

(Keywords: assertion)

Attachments

(1 file)

###!!! ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr', file ../../../dist/include/xpcom/nsCOMPtr.h, line 594

It's because nsFaviconLoadListener inherits from nsIRequestObserver but can't be QI'd to it:

800 NS_IMPL_ISUPPORTS3(FaviconLoadListener,
801                    nsIStreamListener, // is a nsIRequestObserver
802                    nsIInterfaceRequestor,
803                    nsIChannelEventSink)
Duplicate of this bug: 393201
Duplicate of this bug: 393717
Keywords: assertion
Summary: nsFaviconLoadListener needs to list nsIRequestObserver in its IMPL_ISUPPORTS line → nsFaviconLoadListener needs to list nsIRequestObserver in its IMPL_ISUPPORTS line (###!!! ASSERTION: QueryInterface needed: 'query_result.get() == mRawPtr')
Attached patch patchSplinter Review
Assignee: nobody → cbiesinger
Status: NEW → ASSIGNED
Attachment #279184 - Flags: review?(mano)
Attachment #279184 - Flags: review?(mano) → review+
Attachment #279184 - Flags: review+
Checking in toolkit/components/places/src/nsFaviconService.cpp;
/cvsroot/mozilla/toolkit/components/places/src/nsFaviconService.cpp,v  <--  nsFaviconService.cpp
new revision: 1.16; previous revision: 1.15
done
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.