message does not load when using open button on search dialog when using thread filters/view

RESOLVED DUPLICATE of bug 377093

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 377093
11 years ago
11 years ago

People

(Reporter: Jonathan Ostrus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: version 2.0.0.6 (20070728)

I'm not sure if I worded the summary right but the url demonstration should be pretty explanitory. In any case I use the mail/news feature a lot and like to "filter" out the read stuff so I almost always leave the View|Threads|Unread option marked so I only see the new unread contents when I open the folder. However there is sometimes that I will do a search and find something I maybe missed or whatever. If you try to open the message from the search dialog it opens a blank window instead of the message.

Reproducible: Always

Steps to Reproduce:
1. locate a message that you will do a search for that is marked read
2. mark the folder view options as unread threads so it does not show the message you will search for
3. search for said message
4. in the search results double click or click the open button to attempt reading the "read" message.

Actual Results:  
A new window opens up blank and the message does not load.

Expected Results:  
A new window opening with the message.

I'm marking it as normal severity as it can be worked around but its somewhat bothersome if you think about the steps involved to change the folder view options *after* you do the search and find what folder the item is in. The URL link I added is a doubled screenshot one with the unread filter on and the other without. I'm fairly sure this is a bug and not the way it was intended to work
(Reporter)

Comment 1

11 years ago
Ok I feel a bit dumb as I just found a easy work around being the view options by customizing the toolbar. Though do I do think this still is an issue that should be addressed unless it was intended to not load messages when the folder view options were set in such a way.
Severity: normal → minor

Comment 2

11 years ago
Confirmed on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007091403 Thunderbird/3.0a1pre ID:2007091403

Error: uncaught exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIMsgDBView.loadMessageByViewIndex]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://messenger/content/messageWindow.js :: LoadMessageByViewIndex :: line 1157"  data: no]

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 3

11 years ago
In STR 4 I think that should be click on *another* message that matched (not the read one).

Comment 4

11 years ago
Same for pop and imap.

Comment 5

11 years ago
Sorry, my comment 3 is incorrect - the STR are correct. Just realized I did it the other way around (marked one message in a thread as *not* read...)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Summary: message does not load when using open button on search dialog when using thread filters → message does not load when using open button on search dialog when using thread filters/view
Version: unspecified → 2.0
Duplicate of bug: 377093
You need to log in before you can comment on or make changes to this bug.