messages not deleted although folder retention policy is set

RESOLVED DUPLICATE of bug 330772

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 330772
11 years ago
11 years ago

People

(Reporter: lijuan wang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Test on 
solaris 11 thunderbird 2.0.0.6(2007081415)
solaris 11 thunderbird trunk version 3.0a1pre (2007082113)
Windows XP thunderbird 2.0.0.6(20070728)

Reproduce Steps:
1.Launch thunderbird, create an IMAP account
2.Right click a folder of the account, like "Junk" or "Draft", click "Properties", 
3.In the "Folder Properties" dialog->"Retention Policy"-> uncheck "use server defaults", select "Delete messages more than 30 days old"
4.Restart launch thunderbird

Actual results:
After #3: The messages more than 30 days old still in the folder.
After #4: The messages more than 30 days old still in the folder.

Expected results:
After #3:The messages more than 30 days old in the folder will be deleted in the folder.
After #4: he messages more than 30 days old in the folder will be deleted in the folder.

Comment 1

11 years ago
By deleted do you mean "marked as deleted" or really removed? I think the retention checker runs every 5 min by default, there's some pref for it though...
Summary: Cannot delete messages by configuring folder properties → messages not deleted although folder retention policy is set

Comment 2

11 years ago
Magnus, I think that's mean really removed, that's to say : after set the Retention Policy, all the older messages should be removed from the folders. 

Comment 3

11 years ago
Ah, dupe of bug 330772 then.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 330772
You need to log in before you can comment on or make changes to this bug.