Closed Bug 394299 Opened 13 years ago Closed 11 years ago

UI to provide access to extension options from app options cut off

Categories

(Firefox :: Preferences, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 3 alpha8

People

(Reporter: stevee, Assigned: robert.strong.bugs)

References

Details

Attachments

(3 files)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007083003 Minefield/3.0a8pre ID:2007083003

After landing of bug 384956, the UI falls off the bottom of the options pane for me. (Win2k, default theme, new profile). See attached image.
Flags: blocking-firefox3?
OS: Windows 2000 → All
Same sort of clipping occurs with XP default theme, too.
(In reply to comment #2)
> This is Bug 283697.
> Target Milestone: Firefox 3 M9
> https://bugzilla.mozilla.org/show_bug.cgi?id=283697#c180
> 

No it isn't so don't dupe this one to it.
And don't count on 283697 to be fixed in 3M9 either.
taking
Assignee: nobody → robert.bugzilla
mano, this is a different approach to fixing essentially the same bug that added the height via a locale file for Bug 345572.
Attachment #279054 - Flags: review?(mano)
Comment on attachment 279054 [details] [diff] [review]
patch - use a containing box with 1px bottom padding

r=mano, please file a bug for the underlying issue.
Attachment #279054 - Flags: review?(mano) → review+
Checked in to trunk

Checking in mozilla/browser/components/preferences/main.xul;
/cvsroot/mozilla/browser/components/preferences/main.xul,v  <--  main.xul
new revision: 1.15; previous revision: 1.14
done
Checking in mozilla/browser/components/preferences/security.xul;
/cvsroot/mozilla/browser/components/preferences/security.xul,v  <--  security.xul
new revision: 1.19; previous revision: 1.18
done
Checking in mozilla/browser/locales/en-US/chrome/browser/preferences/preferences.dtd;
/cvsroot/mozilla/browser/locales/en-US/chrome/browser/preferences/preferences.dtd,v  <--  preferences.dtd
new revision: 1.8; previous revision: 1.7
done
Checking in mozilla/browser/themes/winstripe/browser/preferences/preferences.css;
/cvsroot/mozilla/browser/themes/winstripe/browser/preferences/preferences.css,v  <--  preferences.css
new revision: 1.18; previous revision: 1.17
done
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Flags: blocking-firefox3?
Target Milestone: --- → Firefox 3 M8
Filed Bug 394433 for the underlying issue.
Reopening... the hourly build still exhibits problems while my own build does not.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007083103 Minefield/3.0a8pre ID:2007083103
Hmm. WFM with the above build.
I got the wrong build and with how much the prefpanes have been a PITA I assumed the worst. Glad to hear it worked.

Resolving -> Fixed.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007083103 Minefield/3.0a8pre ID:2007083103 [20070831_0348_firefox-3.0a8pre.en-US.win32.zip]
--> VERIFIED
Status: RESOLVED → VERIFIED
Duplicate of this bug: 393945
Duplicate of this bug: 345808
But DOES NOT appear to be fixed.
Just got Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007090303 Minefield/3.0a8pre ID:2007090303
and the Add-ons area is still cut off.
...fixed with clean profile so it's an extension issue perhaps.
No longer blocks: 395432
To get it completely fixed, replace in preferences.css:
.bottomBox{padding-bottom:2px}
with:
prefpane>.content-box{padding-bottom:4px}
as not not all panes have a 'bottomBox', but all do have a '.content-box'.
This ensures that all panes will not be cut off (or at least give it less chance to do so).

Note, the same fix should also be added to gnomestripe for Linux (see bug 412325).
Blocks: 412325, 345808, 394433
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Note, with the change from comment #18, one can also remove the .bottomBox workaround and the hack in preferences.xml (lines 830-843).
The other hack (XXX rstrong) is however a valid 'hack' to ensure that the pane/window grows when the content doesn't fit the initial fixed window size.
I highly suspect that just lessens the likelihood of this happening by increasing the padding and applying to all prefpanes vs. the ones that actually have this bug. Whatever the case bug 394433 is for fixing the underlying issue that causes this bug which should remove the .bottomBox hack and not require any other hack.

If you'd like to try to fix the underlying bug that causes this please do so in bug 394433. If you'd like to try a different hack please file a new bug.
Status: REOPENED → RESOLVED
Closed: 13 years ago11 years ago
Resolution: --- → FIXED
No longer blocks: 394791
No longer blocks: 412325
No longer blocks: 394433
Depends on: 394433
No longer blocks: 396541
No longer blocks: 349098
No longer depends on: 394433
No longer blocks: 283697
Depends on: 283697
You need to log in before you can comment on or make changes to this bug.