Last Comment Bug 394796 - "I'm added to or removed from this capacity" for "CCed" doesn't work correctly if several users are added or removed at once from the CC list
: "I'm added to or removed from this capacity" for "CCed" doesn't work correctl...
Status: RESOLVED FIXED
:
Product: Bugzilla
Classification: Server Software
Component: Email Notifications (show other bugs)
: 2.20
: All All
: -- major (vote)
: Bugzilla 3.0
Assigned To: Frédéric Buclin
: default-qa
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-03 13:56 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2008-06-30 23:35 PDT (History)
7 users (show)
LpSolit: approval+
LpSolit: approval3.0+
mkanat: blocking3.0.3+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Gavin's Bugzilla Email Prefs (28.46 KB, image/png)
2007-09-03 13:56 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details
Phil's prefs (59.02 KB, image/png)
2007-09-03 14:09 PDT, Phil Ringnalda (:philor, back in August)
no flags Details
patch, v1 (799 bytes, patch)
2007-09-23 09:03 PDT, Frédéric Buclin
wurblzap: review+
Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2007-09-03 13:56:50 PDT
Created attachment 279505 [details]
Gavin's Bugzilla Email Prefs

Based on some ad-hoc testing, it looks as though "The CC field changes" preference on the current instance of b.m.o overriddes "I'm added or removed from this capacity", but only for some people (it seems to work for me, but not work for Phil). This means that you can't disable getting mail for other people's CC changes, but still get mail when you're added or removed from the list.

When Ryan CCed me to bug 234982 (a bug that I had no previous relationship to), I got mail for the CC addition that said "You are receiving this mail because: You are on the CC list for the bug." (note that I don't have "CCed x The CC field changes" checked). When I CCed Phil on bug 394791, he didn't get mail. He then checked "CCed x The CC field changes", and then I CCed him on bug 394775. He got bugmail for that change. He had "CCed x I'm added or removed from this capacity" checked in both cases.

Here's a screenshot of my bugzilla email prefs.
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-09-03 13:57:58 PDT
I just CCed mkanat and philor (and made no other changes) - mkanat got mail, philor didn't.
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-09-03 13:59:11 PDT
This is potentially related to bug 366181.
Comment 3 Phil Ringnalda (:philor, back in August) 2007-09-03 14:09:18 PDT
Created attachment 279510 [details]
Phil's prefs

No difference that should be significant, the only difference that shouldn't be, but might, being that I don't have anything at all in the "The CC field changes" row checked. Neither of Gavin's checks applied when he did get it, but maybe it's the condition of nothing, rather than the condition of matching, that matters?
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-09-20 05:50:59 PDT
I didn't get any mail when I was added to bug 396830's CC list (I only got mail when Jesse posted a comment). I think this is caused by people adding more than one person to the CC list at a time (Jesse and I were added at the same time). Is the check for whether "I'm being added or removed from this capacity" exact, such that adding me+someone else doesn't trigger it?

This is a fairly major issue, because myself and others are missing bugmail that we should be getting.
Comment 5 Max Kanat-Alexander 2007-09-22 15:14:07 PDT
Yeah, this is important enough to be a blocker.
Comment 6 Frédéric Buclin 2007-09-23 09:03:18 PDT
Created attachment 282015 [details] [diff] [review]
patch, v1

Gavin was right. The problem only occurs if you add/remove several users at once to/from the CC list, due to an incorrect regexp. This looks like a regression due to bug 73665, meaning that Bugzilla 2.20 and 2.22 are also affected by this bug.
Comment 7 Marc Schumann [:Wurblzap] 2007-09-23 14:03:08 PDT
Comment on attachment 282015 [details] [diff] [review]
patch, v1

r=Wurblzap provided you tested (I didn't). Nit: don't we want to allow whitespace before the following comma, too? I think so. (Fix this on check-in, if you want.)
Comment 8 Frédéric Buclin 2007-09-23 14:10:42 PDT
(In reply to comment #7)
> (From update of attachment 282015 [details] [diff] [review])
> r=Wurblzap provided you tested (I didn't).

Yes, I tested it, on both 3.1.2 and 3.0.2.


> Nit: don't we want to allow
> whitespace before the following comma, too?

No, because process_bug.cgi (3.0.x) and Bug.pm (3.1.x) both use join(", ", @list), and so it's a bug if a whitespace appears *after* the email address.
Comment 9 Frédéric Buclin 2007-09-23 15:13:57 PDT
tip:

Checking in Bugzilla/User.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/User.pm,v  <--  User.pm
new revision: 1.160; previous revision: 1.159
done

3.0.2:

Checking in Bugzilla/User.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/User.pm,v  <--  User.pm
new revision: 1.148.2.4; previous revision: 1.148.2.3
done
Comment 10 Max Kanat-Alexander 2008-06-30 23:35:06 PDT
Removing relnote keyword as this was fixed and probably relnoted in a 3.0.x release long ago.

Note You need to log in before you can comment on or make changes to this bug.