If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Applications prefpane doesn't have "file extension" column

RESOLVED WONTFIX

Status

()

Firefox
File Handling
P1
normal
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: V. Korn, Unassigned)

Tracking

unspecified
Firefox 3 beta1
Points:
---
Bug Flags:
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007090704 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007090704 Minefield/3.0a8pre

After landing of https://bugzilla.mozilla.org/show_bug.cgi?id=377784, "MIME-type configuration system" (now present as Applications tab in Options window) show only Content Type and Application columns
In some cases (like my case) this is not enough
On this screenshot
http://i195.photobucket.com/albums/z291/Vednier/snap.jpg
You can see that in case if Firefox incorrectly determine content type description on some file type ("php-файл" is .torrent, in my case, downloaded through http://domain.com/download.php?&i=148954-like link, - this, maybe, separate bug) you cannot easily understand THAT is file type associated with some handler (program or plugin) if there is no "file extention" column exists

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
presented information is not enough

Expected Results:  
As many information columns as needed to exactly and faultlessly identify content/file type
Blocks: 377784
No longer blocks: 377784
Depends on: 377784
Blocks: 377784
No longer depends on: 377784
Removing the file extension column was intentional, and it sounds to me like the problem you're experiencing is really that Firefox (or the OS) is incorrectly describing the torrent content type.

If the description were correct, then you wouldn't have to see the file extension to know what content type the entry represents.  So I'm inclined to say that we won't fix this bug about re-adding the file extension column but would fix another bug about describing the type correctly.

But I'm cc:ing faaborg and mconnor, my two UX reviewers, for their thoughts.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Priority: -- → P1
Hardware: PC → All
Summary: "MIME-type configuration system" window must also show "file extention" column → Applications prefpane doesn't have "file extension" column
Target Milestone: --- → Firefox 3 M9
File extensions should override mime types in the content column, so instead of displaying "php-файл" it should be displaying ".torrent". Unless there are two identical file extensions, in which case we will be showing the mime type as well (bug #395646).

>So I'm inclined to
>say that we won't fix this bug about re-adding the file extension column but
>would fix another bug about describing the type correctly.

I agree.
(In reply to comment #2)
> File extensions should override mime types in the content column, so instead of
> displaying "php-файл" it should be displaying ".torrent". Unless there are
> two identical file extensions, in which case we will be showing the mime type
> as well (bug #395646).

File extensions override MIME types, but currently OS-provided descriptions (or hard-coded descriptions in Firefox) override file extensions.  And that seems to be the problem here.  The OS provides "php-файл", which is apparently incorrect.
(Reporter)

Comment 4

10 years ago
Ok, i make some checking, and..found that at current moment no description was set on .torrent file type
I changed it to "torrent file", restarted Minefield and found that nothing changed at all
After i deleted manually entry and download test .torrent file, select bittorent software as program needed to open .torrent file type, mark checkbox to save preferences - description has changed to "torrent file", as needed.
So, partially it's my mistake, yes. BUT.

This is really strange for me - on my system .php file have "php-файл" description, .torrent have no description at all
I download .torrent file from http://domain.com/download.php URL and Mine field just set .torrent description as equal to .php ?
And, then if i download any NEW and unknown file type via php link it all will be recognized as php files?
Very odd for me.
Why not use file extension as failsafe solution?
My system not know anything about .ter files. Fine, just mark them as .ter in Application prefpane - logically?

(In reply to comment #4)
> This is really strange for me - on my system .php file have "php-файл"
> description, .torrent have no description at all
> I download .torrent file from http://domain.com/download.php URL and Mine field
> just set .torrent description as equal to .php ?
> And, then if i download any NEW and unknown file type via php link it all will
> be recognized as php files?
> Very odd for me.
> Why not use file extension as failsafe solution?
> My system not know anything about .ter files. Fine, just mark them as .ter in
> Application prefpane - logically?

Hmm, that does sound strange.  cc:ing some content handling folks who might know why that happens.
Duplicate of this bug: 395801
(In reply to comment #5)
> (In reply to comment #4)
> > This is really strange for me - on my system .php file have "php-файл"
> > description, .torrent have no description at all
> > I download .torrent file from http://domain.com/download.php URL and Mine field
> > just set .torrent description as equal to .php ?
> > And, then if i download any NEW and unknown file type via php link it all will
> > be recognized as php files?
> > Very odd for me.
> > Why not use file extension as failsafe solution?
> > My system not know anything about .ter files. Fine, just mark them as .ter in
> > Application prefpane - logically?
> 
> Hmm, that does sound strange.  cc:ing some content handling folks who might
> know why that happens.

I talked to dmose on IRC about it, and he suggested this may be the result of bug 299372.

Since this change was intentional, it's not a regression, so adding it to the list of followup bugs to bug 377784 rather than the list of blockers.
No longer blocks: 377784
Depends on: 377784
Keywords: regression

Comment 9

10 years ago
So on Windows, it looks like this:
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
Winamp media file   QuickTime Plug-In 7.2 (in Minefield)

That's not really helpful...

In Firefox 2.x on the other hand, there's an additional column with the file extension, like mid, au, aiff, mp4, wav, mpg, mp3, aac, wma, wmv, m4a. (And you can optionally display another column with the mime type.)
Flags: in-litmus-
(In reply to comment #9)
> So on Windows, it looks like this:
> Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
...
> Winamp media file   QuickTime Plug-In 7.2 (in Minefield)
> 
> That's not really helpful...

Hmm, indeed, but I think this will be fixed by bug 395182, which appends MIME types to entries with duplicate type names.
I've just checked in the fix for bug 395182.  Please test with tomorrow's nightlies and let me know if you still see a bunch of duplicate descriptions in the list.

Comment 12

10 years ago
It's better now since the MIME type is displayed as well.
It looks like this:
Winamp media file (audio/aac)
Winamp media file (audio/aiff)
Winamp media file (audio/basic)
Winamp media file (audio/mid)
Winamp media file (audio/midi)
Winamp media file (audio/mp4)
Winamp media file (audio/mpeg)
Winamp media file (audio/wav)
Winamp media file (audio/x-aac)
Winamp media file (audio/x-aiff)
Winamp media file (audio/x-m4a)
Winamp media file (audio/x-midi)
Winamp media file (audio/x-mpeg)
Winamp media file (audio/x-ms-wma)
Winamp media file (audio/x-wav)

Can we at least group entries with and without "x-" together?
mid, midi, x-midi...

Or do I need 4 entries for 3GPP (I don't even know what that is):
3GPP Movie (audio/3gpp)
3GPP Movie (video/3gpp)
3GPP Movie (audio/3gpp2)
3GPP Movie (video/3gpp2)

There's also a bunch of entries I can't tell apart:
Session Description Protocol (applic...
Session Description Protocol (applic...
Shockwave Flash Object (applicatio...
Shockwave Flash Object (applicatio...
Windows Media-Wiedergabeliste für...
Windows Media-Wiedergabeliste für...
Windows Media-Wiedergabeliste für...
Windows Media-Wiedergabeliste für...

Comment 13

10 years ago
(In reply to comment #12)
> There's also a bunch of entries I can't tell apart:
> Session Description Protocol (applic...
> Session Description Protocol (applic...
> Shockwave Flash Object (applicatio...
> Shockwave Flash Object (applicatio...
> Windows Media-Wiedergabeliste für...
> Windows Media-Wiedergabeliste für...
> Windows Media-Wiedergabeliste für...
> Windows Media-Wiedergabeliste für...

I noticed this too, wouldn't it be better if the full content type (and application too, when that's long enough to get an ellipsis) was displayed as a tooltip?

(In reply to comment #12)
> Can we at least group entries with and without "x-" together?
> mid, midi, x-midi...
>
> Or do I need 4 entries for 3GPP (I don't even know what that is):
> 3GPP Movie (audio/3gpp)
> 3GPP Movie (video/3gpp)
> 3GPP Movie (audio/3gpp2)
> 3GPP Movie (video/3gpp2)

Yes, that'd be useful.  Perhaps this is one of the cases to be solved by bug 395645.


(In reply to comment #13)
> (In reply to comment #12)
> > There's also a bunch of entries I can't tell apart:
> > Session Description Protocol (applic...
> > Session Description Protocol (applic...
> > Shockwave Flash Object (applicatio...
> > Shockwave Flash Object (applicatio...
> > Windows Media-Wiedergabeliste für...
> > Windows Media-Wiedergabeliste für...
> > Windows Media-Wiedergabeliste für...
> > Windows Media-Wiedergabeliste für...
> 
> I noticed this too, wouldn't it be better if the full content type (and
> application too, when that's long enough to get an ellipsis) was displayed as 
> a tooltip?

Yes, it certainly would be.  Can you file a new bug on this?

As discussed earlier, I'm going to wontfix this bug, as the core problem seems to be fixed without needing to add a column for file extension.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Comment 15

10 years ago
(In reply to comment #14)
> Yes, it certainly would be.  Can you file a new bug on this?

Filed bug 400050.
You need to log in before you can comment on or make changes to this bug.