Open Bug 395596 Opened 12 years ago Updated 4 years ago

provide Ctrl+Shift+F to do "search messages" from compose window

Categories

(Thunderbird :: Message Compose Window, enhancement)

enhancement
Not set

Tracking

(Not tracked)

REOPENED

People

(Reporter: wsmwk, Unassigned)

References

(Blocks 2 open bugs)

Details

.
David, would bug 267992 (Mac) be dependent on (or dupe of) this bug, or something like it?

Magnus, am I correct in guessing that you see this on linux?
OS: Windows XP → All
Hardware: PC → All
David, see comment 1
Wayne, no, bug 267992 is more general though highly unlikely to be "fixed" in a general way, other than adding the "global" commands to each window - fixing this would just be a small part of it.
For Mac this is a subcase of bug 267992 (and probably the most important one). However, this bug requests the enhancement for all platforms, which makes a lot of sense.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-thunderbird3?
Hmm, I wonder what we want to do with this...
fix :)

but seriously, search should be integral, easy, and natural wherever one may be in "main screens" of the product - i.e. a click or keystroke away.  

This bug was of course written in the context of the current "advanced search". So it's not clear how this fits into the tab world. But it should.  

A separate but blocking issue is whether standalone search window may/should/is or may not be going away, and if it stays what should it look like. Sounds like a subject for mdat.
Flags: wanted-thunderbird3?
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 537378
Not a dupe though arguably the summary of bug 537378 could be updated...
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Magnus, would it be very difficult to enable the command/key for "Search messages" for the composition window (this bug), similar to what you have done in bug 537378?

(In reply to Wayne Mery (:wsmwk) from comment #6)
> fix :)
> but seriously, search should be integral, easy, and natural wherever one may
> be in "main screens" of the product - i.e. a click or keystroke away.  

FTR: +1
Blocks: 267992
Depends on: 537378
I don't think it would be hard - though different from that bug.
You need to log in before you can comment on or make changes to this bug.