Closed Bug 395813 Opened 15 years ago Closed 14 years ago

Weird behavior with add bookmarks dialog (long dialogs with extra fields/delete and done buttons don't work/title not filled out)

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta3

People

(Reporter: u88484, Assigned: mano)

References

(Depends on 1 open bug)

Details

Attachments

(2 files)

Sorry about the title but too much going on to sum it up in a summary.

Happened to me a few times today with different builds, oldest 090704 and newest 09110? build.  Steps that I did:

1) Clicked once on the white star and the add bookmark dialog came up (first sign of this whole bug report)
2) There was no title filled out and the location and description fields were shown which usually aren't (bug 394104)
3) I hit delete to not save the bookmark
4) nadda happens, i click on the page to make that dialog lose focus and close 
5) I look in the error console and have the below errors
6) click the yellow star and delete the "bookmark"
7) try to reproduce my steps after restarting firefox and I can't reproduce

(the dialog opening)
Error: gEditItemOverlay is not defined
Source File: chrome://browser/content/browser.js
Line: 5070

(clicking delete)
Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.getItemTitle]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/places/editBookmarkOverlay.js :: EIO__getItemStaticTitle :: line 246"  data: no]

(I guess making the dialog lose focus)
Error: this._folderTree has no properties
Source File: chrome://browser/content/places/editBookmarkOverlay.js
Line: 345

I have reproduced this a few times today but it happened at random times and seems to only happen once per build or at least once per session
Flags: blocking-firefox3?
I've had the random/intermittent step 2) only, as recently as yesterday's hourly builds, I think.

Haven't seen 1), and instead of 3-7) I've just filled in the title.  I'll try to remember to pay more attention next time, as far as steps/error console/etc.
Oops.
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a8pre) Gecko/2007091207 Minefield/3.0a8pre - Build ID: 2007091207
, but not yet seen with this build.
Now when this happens and I click the delete button, and nothing happens, this error is in the error dialog and not the second one listed in OP.  BTW the add bookmark dialog had at least 10 fields to fill out like the feed location, keyword and all the other possibilities for bookmarking other things.

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.removeItem]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/browser.js :: PCH_deleteButtonCommand :: line 5264"  data: no]
Flags: blocking-firefox3? → blocking-firefox3+
Duplicate of this bug: 394104
Target Milestone: --- → Firefox 3 M10
Summary: Weird behavior with add bookmarks dialog (Places) → Weird behavior with add bookmarks dialog (long dialogs with extra fields/delete and done buttons don't work/title not filled out)
One weird effect of this bug is that whenever the extended dialog appears, the Close Window and Close Tab menu options become disabled, which in turn disable the Ctrl-W and Ctrl-Shift-W shortcuts. Ctrl-F4 and Alt-F4 still work, though, and a restart brings back the menu items and shortcuts.
Experienced on various builds (including newer ones) on Windows and Linux.
I would bet this is a side-effect of bug 392515 (setTimeout _apparently_ isn't enough). If we don't fix that for 1.9, a workaround would be to put the script element inside browser.xul itself.
Frankly, we should fix bug 392515.  A good start would be someone answering my questions in that bug.... ;)
Target Milestone: Firefox 3 M10 → Firefox 3 Mx
Target Milestone: Firefox 3 Mx → Firefox 3 M11
Adding steps to reproduce, as advised on irc.mozilla.org #testday.

1. Start/restart Windows.
2. Launch Minefield.
3. Click the star twice to show the dialog with the extra fields
4. Click the star again to show the normal dialog with fields pre-filled

Alternatively:
1. Install new version/overwrite old version of Minefield
2. Start new version
3. Click the star twice to show the dialog with the extra fields
4. Click the star again to show the normal dialog with fields pre-filled

Reproducible: always (with these steps).
Priority: -- → P4
Hardware: PC → All
I have seen this bug in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1.

Please can we can get an option to have the location, description, and keyword fields shown in the bookmark dialog?  That would make the star useful to me!
Agreed, as far as I'm concerned, it's a Bug that it doesn't show all this info ALL the time! And that Bug is 89001 -  https://bugzilla.mozilla.org/show_bug.cgi?id=89001 - filed in 2001 on Mozilla Application Suite.
Duplicate of this bug: 404724
Not going to continue to block on this, please renominate with reasons why we can't ship with this in final
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Has anyone confirmed that this is a side-effect of bug 392515? Just wondering so I can make this dependent on that bug and hopefully that one will get fixed.
(In reply to comment #13)
> Not going to continue to block on this, please renominate with reasons why we
> can't ship with this in final
> 

Don't know if it is so important to block final or not, but in my case there is constant problem with this. I know how to get around, but it is annoying. I am sure others will too. At random cases the star is not useful for me and apparently to some others also. You see the overall picture, therefor the call is yours ...
The STRs outlined in comment #9 still work for me. That means there's a good chance *every* first-time Fx3 user would see the 'extended' dialog. Strikes me as a pretty obvious problem for ordinary users ("What's up with my star?"), and a potential killer for switchers. The workaround is not necessarily obvious for those two categories of users - I think they'd be likely to conclude Fx3 is broken. Not to mention the potential fallout if a big-name reviewer stumbled across it!
Still see this with latest hourly, even after bug 393509 landed.  I seen this after restarting from updating to a nightly, first page that loads click the star button and the contextual dialog is huge with every field possible in it.
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b3pre) Gecko/2008013104 Minefield/3.0b3pre

Happens every first time after start, as described in comment #17.
OS: Windows XP → All
Assignee: nobody → mano
Depends on: 392515
Priority: P4 → P2
Comment on attachment 300716 [details] [diff] [review]
workaround until 392515 is fixed

r=me, thanks
Attachment #300716 - Flags: review?(dietrich) → review+
Comment on attachment 300716 [details] [diff] [review]
workaround until 392515 is fixed

a=beltzner
Attachment #300716 - Flags: approval1.9b3? → approval1.9b3+
mozilla/browser/base/content/browser-places.js 1.91
mozilla/browser/base/content/browser.xul 1.423
mozilla/browser/components/places/content/editBookmarkOverlay.xul 1.12
mozilla/browser/components/places/content/places.xul 1.103
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Even, with the patch when starting the browser for the 1st time and clicking the 'Star' I see a flash of the larger dialog box, then it falls back to what would 'normal' looking dialog box. 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008013116 Minefield/3.0b3pre Firefox/3.0 ID:2008013116
File that separately please.
(In reply to comment #23)
> Even, with the patch when starting the browser for the 1st time and clicking
> the 'Star' I see a flash of the larger dialog box, then it falls back to what
> would 'normal' looking dialog box. 

This is already mentioned in my bug 415140.

Otherwise verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008020104 Minefield/3.0b3pre
Status: RESOLVED → VERIFIED
Depends on: 415140
Duplicate of this bug: 416064
Duplicate of this bug: 400773
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.