Form does not display non-ascii characters

VERIFIED DUPLICATE of bug 6262

Status

()

Core
Internationalization
P3
major
VERIFIED DUPLICATE of bug 6262
19 years ago
18 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DEPEND - Intl, URL)

(Reporter)

Description

19 years ago
Tested 3-17-99 Win32 build.

In the above page, the Japanese selection under the items (商品名) and the Japanese  buttons at the end of the page are not
displayed correctly.
(Reporter)

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M4

Updated

19 years ago
Assignee: ftang → trudelle

Comment 1

19 years ago
I believe this will be fix when our GFX base widget land (or I should say switch
to the GFX based widget).

Reassign this to Peter Trudelle since he own Toolkit. Peter, take your time to
land GFX based widget. Just remember this bug is depend on that.... (Make sure
you call the PRUnichar* or nsString based GetWidth/DrawString so it will render
Japanese correctly) :) Please close this bug after you land them.

Updated

19 years ago
Assignee: trudelle → evaughan
Priority: P2 → P3
Target Milestone: M4 → M5

Comment 2

19 years ago
reassigning to evaughan, since the only widgets mentioned are buttons. p3 for
m5

Updated

19 years ago
Assignee: evaughan → teruko

Comment 3

19 years ago
Apprunner now uses GFX widgets so it should render japanese. Can you confirm
this with the current build and close out this bug if is displays correctly?

You can also test with viewer is you turn GFX rendering on by selecting
tools->style->widget rendering mode->gfx from the menu. Then loading the page.

-E

Comment 4

19 years ago
I tried 1999-04-16-08 apprunner on US NT4.  After I hit reload, the drop-downs
and buttons display Latin1 garbage characters.  Elsewhere in the page, Japanese
displays correctly.

There is no viewer.exe in this day's zip file.
(Reporter)

Updated

18 years ago
Assignee: teruko → evaughan
(Reporter)

Comment 5

18 years ago
I tested the 4-20-99 build.  I got the same result as Bob mentioned.

Updated

18 years ago
Assignee: evaughan → kmcclusk

Comment 6

18 years ago
Kevin,

Talked to Vidur and he said your the man for this. I guess you own DrawString. I
looked at my code and it seems to do everything right. Gets the string from the
attribute and draws it. Not sure why it doesn't work in japanese.

Updated

18 years ago
Target Milestone: M5 → M6

Comment 7

18 years ago
Moving to M6.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M6 → M7
(Assignee)

Updated

18 years ago
Target Milestone: M7 → M8

Updated

18 years ago
Whiteboard: DEPEND - Intl

Updated

18 years ago
Blocks: 7228
(Assignee)

Updated

18 years ago
Target Milestone: M8 → M9

Comment 8

18 years ago
Same as bug #4681?

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
Should be fixed by Ender-based text widget.  See bug #6262.

*** This bug has been marked as a duplicate of 6262 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

18 years ago
Verified as dup.
You need to log in before you can comment on or make changes to this bug.