hotmail.com - Windows Live Hotmail (full version) warns on login when accessed from non-Firefox Gecko browsers

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
10 years ago
9 months ago

People

(Reporter: David E. Ross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-all] [serversniff] , URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070802 SeaMonkey/1.1.4 Mnenhy/0.7.5.0
Build Identifier: 

When I go to the Hotmail login page, I can login.  I get the main Hotmail page, but only momentarily.  Then, the browser window goes blank.  The status bar indicates a page has been partially loaded, but my modem stops receiving.  

If I spoof Firefox 2, this doesn't happen.  Then, I have no problem accessing Hotmail.  

This indicates improper sniffing and may be a candidate for blocking bug 334967.  

Reproducible: Always




I also tried spoofing IE 5 on a Mac.  That also allowed me to access Hotmail and get my messages.  However, Hotmail told me that Javascript was not enabled even though it was enabled to change status bar text and to change images.  

See the thread in newsgroup <news://news.mozilla.org:119/mozilla.support.seamonkey> with the subject "Can't Access Hotmail".  As of my reply dated 9/13/2007 8:11 AM in that thread, this was not a problem for me.  I did not try to login to Hotmail for my reply dated 9/13/2007 5:09 PM.
(Reporter)

Comment 1

10 years ago
With Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6)
Gecko/20070802 SeaMonkey/1.1.4, I can logon.  But I can't get the next
page, a welcome page.

If my UA string is Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6, then I get the welcome page.

The welcome page says:
> You are using the classic version of Windows Live Hotmail.
> Have a fast connection and want more features? Try the 
> full version to see message previews in your inbox. (It's free, too.)
However, I have a dial-up connection.  Thus, I continue to use the
classic version.  (Before you tsk-tsk about dial-up, remember that more than 40% of the Internet connections in the U.S. are still dial-up.)  

Others might not have this problem with the full version of Windows Live Hotmail. 

Comment 2

10 years ago
Since this is a spoofing problem, blocking 334967 and platform/os -> All/All.
Blocks: 334967
OS: Windows XP → All
Hardware: PC → All

Updated

10 years ago
Summary: [hotmail.com] Hotmail Cannot Be Accessed From SeaMonkey → hotmail.com - Hotmail (Classic interface) cannot be accessed from non-Firefox Gecko browsers

Updated

10 years ago
Duplicate of this bug: 403082

Comment 4

10 years ago
From the dupe:

"new Hotmail interface does not load in Fx3 beta 1.   The screen stalls on page
loading..   Need to switch to classic view in order to run.

This works fine on Fx 2.0.0.9."

It sounds like they may be sniffing for "Firefox/2" rather than just "Firefox".

Updated

10 years ago
Keywords: relnote
(Reporter)

Comment 5

10 years ago
I am now able to get past the "Welcome" page and view my mail without spoofing, using the UA string [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071030 SeaMonkey/1.1.6].  

However, if I select the link to "Help Central", I get "Browser not supported".  Spoofing with the UA string [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071030 SeaMonkey/1.1.6, NOT Firefox/2.0.0.9], I can reach "Help Central".  

For those of you who want to spoof Firefox, remember that you must set your UA string before attempting to login.  Hotmail sets session cookies to indicate your browser when you login, so you must start spoofing before any such cookies are set.  

Updated

10 years ago
Duplicate of this bug: 405054

Comment 7

10 years ago
Using Firefox 3 Beta 2, attempting to go to mail.live.com when not logged in results in a blank screen.
If you login at login.live.com before going to mail.live.com however, results in the Windows Live Hotmail Loading screen showing up, but all internet activity stops.

At this point, clicking the 'Try the Classic Version' link, results in Firefox entering an infite loop of reloading the page.

Changing the User Agent has no affect what so ever.

Comment 8

10 years ago
(In reply to comment #7)
> Changing the User Agent has no affect what so ever.

Probably because you didn't clear cookies first, and Hotmail has stored a cookie identifying your browser as incompatible.

Comment 9

10 years ago
haha, nope, i found why and i now have the same experience as everyone else.

it was caused by the broken google toolbar.

it wasn't just breaking that either, it was breaking link tooltips, and preventing other sites and site content from loading as well.

i hope google update the toolbar for Firefox 3.0, as nice as the built in searching is, it just doesn't have the same function... custom searches for instance.

Comment 10

9 years ago
Hotmail's UA sniffing seems to be quite sensitive. I've has this problem for quite a while and recently figured out where in the UA string the problem lies. This is over and above any UA sniffing for "firefox" that hotmail does.


With firefox 2 on fedora 8, I'm redirected to the classic interface. My user agent string is:

Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

But, if I change the general.useragent.vendor string to "" in about:config so that the UA string is:

Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.10) Gecko/20071213 Firefox/2.0.0.10

then I get the new mail.live.com interface.


So, the problem seems to be that the UA sniffing is overly sensitive to the vendor string. I don't know if evangelism by mozilla will be able to change this hotmail behaviour, but at least its more likely than if I keep this to myself.


Note: I remember having a similar problem with the firefox UA and the windows live mail beta back in fedora core 4, when the user agent contained something like "uses pango" - and that was enough to throw the sniffing off. I'm not an expert by any means, but I can't help thinking that less strict UA sniffing would be easier to maintain.

Comment 11

9 years ago
Slashdot ran a story some days ago about UA detection bugs in hotmail:
http://linux.slashdot.org/article.pl?sid=08/02/08/1355246

Hotmail Doesn't Work With Linux Firefox 2.0
 
An anonymous reader tips a column up at freesoftwaremagazine.com in which the writer discovers that the latest UI enhancements that Hotmail has recently introduced don't work with Firefox 2.0 under Linux. 
http://www.freesoftwaremagazine.com/columns/hotmail_doesnt_work_with_firefox_2

The writer concludes that the webmail interface has been artificially limited by basic user-agent sniffing. The solution is simple enough — spoofing the User Agent that Firefox reports.

Comment 12

9 years ago
(In reply to comment #11)
> The solution is simple enough — spoofing the User Agent that Firefox reports.

The slashdot article inspired me to finally make comment #10. In my experience, spoofing a windows User Agent is not necessary. Removing the vendor string is sufficient to access the new hotmail interface, the problem is not with firefox identifying as linux.

Comment 13

9 years ago
This is an Issue with the Yahoo interface as well....
(Reporter)

Comment 14

9 years ago
Each Web site affected by incorrect UA string sniffing is a separate bug report.  For very large sites, there might even be several bug reports.  

For Yahoo, your problem might be any of the following:  
Bug 304223
Bug 318665
Bug 334071
Bug 399404

If your problem is truly different from any of those, a new bug report should be submitted.  

Comment 15

9 years ago
In Firefox 3 Beta 4:
Windows Live Mail comes in two versions. Classic, which is similar to the old Hotmail interface, and Full, which is similar to the new AOL interface. The following error surfaces on the Windows Live Hotmail page when loading into an account that is defaulted at the Full version:
You are temporarily on the classic version of Windows Live Hotmail due to an error encountered during login. Before trying again, please clear your cache and cookies.
Firefox 2 does not have this problem.

Comment 16

9 years ago
(In reply to comment #15)
> In Firefox 3 Beta 4:
> Windows Live Mail comes in two versions. Classic, which is similar to the old
> Hotmail interface, and Full, which is similar to the new AOL interface. The
> following error surfaces on the Windows Live Hotmail page when loading into an
> account that is defaulted at the Full version:
> You are temporarily on the classic version of Windows Live Hotmail due to an
> error encountered during login. Before trying again, please clear your cache
> and cookies.
> Firefox 2 does not have this problem.
> 

well yes, that would be because Live Hotmail supports the Firefox 2.0 useragent, there are (messy) ways to get it to work in Firefox 3.0, MSFT know about the issue as its been reported by myself and others, and will not fix it till Firefox 3.0 is final.

IF anyone has any issues with firefox under any OS, on any pc, with any version of firefox, i urge them to report the problem to the Live Hotmail newsgroups.

It is up to MSFT to maintain UA compatibility, and not the Firefox development team.
This seems to be working now on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5.

The only thing i noticed is the throbbler continues to spin in the favicon, but i can see my new hotmail interface just fine.

From options : "You're using the full version of Windows Live Hotmail.

    * Not fast enough? Try the classic version."
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
hm i get "You are temporarily on the classic version of Windows Live Hotmail due to an error encountered during login. Before trying again, please clear your cache and cookies." and i*m not sure how to switch to the new version
hmm, perhaps this was a soft rollout by hotmail to a certain set of users?  Can anyone else here confirm if it works or not for them in beta 5rc2 or the nightly?

Comment 20

9 years ago
better still, Post the mailbox numbers

http://bl137w.blu137.mail.live.com
         ^      ^

this will allow others to view the changed version.
(Reporter)

Comment 21

9 years ago
Yes, it does seem to be working now for the "Classic" interface without spoofing Firefox.  I have not tried the "new" interface because it appears to be designed for broadband while I'm on a dial-up connection.  

Comment 22

9 years ago
Unless I'm mistaken, this is a Tech Evangelism bug about poor UA sniffing, and describes the behaviour of Hotmail/Live Mail with non-firefox gecko browsers.

There are also issues reported with:
* broken sniffing on the vendor string in firefox on linux UAs;
* broken sniffing for firefox 3 / minefield.

If only the last of these is apparently fixed, should this bug be re-opened? Or is the fact that the full version of hotmail is not accessible to certain UAs a separate issue?

Comment 23

9 years ago
i think comment 17 was just giving an update that MS is preparing to roll out the fix, no need to reopen the bug Oliver.

Comment 24

9 years ago
Hi there,

I've installed Firefox 3 final and I'm still having this problem. In fact, I'm having it since Firefox 3 beta 1... Am I the only one ?

Thank you

Comment 25

9 years ago
the live team hasn't rolled out the M14 update yet.

Comment 26

9 years ago
I'm sorry, what means rolled out ? Is it a synonym to "hasn't upgraded to the M14 patch yet" ?

In general, is the problem related to Microsoft or Mozilla ? If it is related to Microsoft, is Mozilla able to solve it on his side or the only solution would be to wait for Microsoft to upgrade their website ?

Thank you 

Comment 27

9 years ago
>
> I've installed Firefox 3 final and I'm still having this problem. In fact, I'm
> having it since Firefox 3 beta 1... Am I the only one ?
> 

No your not the only one.  Same here.  I am still getting the following message with Firefox 3 final.

"You are temporarily on the classic version of Windows Live Hotmail due to an error encountered during login. Before trying again, please clear your cache and cookies."

So Microsoft is supposed to roll out a fix?  It hasn't happened yet.  FF2 never had this problem.

(Reporter)

Comment 28

9 years ago
This bug report was originally about Windows Live Hotmail (classic version).  That version now works for SeaMonkey without any spoofing of another browser.  

From recent comments, there are still problems with Windows Live Hotmail (full version).  The Summary has been updated accordingly.  

Per comment #1, I'm using a dial-up connection, for which the classic version (not the full version) is appropriate.  Thus, I cannot personally assist in diagnosing full version problems or testing possible full version fixes.  (I wish there were some way to remove me from the Reported field of a bug report.)  
Summary: hotmail.com - Hotmail (Classic interface) cannot be accessed from non-Firefox Gecko browsers → hotmail.com - Windows Live Hotmail (full version) cannot be accessed from non-Firefox Gecko browsers

Comment 29

9 years ago
An update for Firefox 3 compatibility will begin rolling out within a month.

Other live services with bugs are also being investigated.
(Reporter)

Comment 30

9 years ago
This problem has been recently observed, both by me and by others.  However, it is not consistently observed, indicating possible maintenance of the Web site by Microsoft.  

Reopening
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

9 years ago
Duplicate of this bug: 464074

Updated

8 years ago
Blocks: 468835

Comment 32

8 years ago
Just for the record, the additional problem described in comment #10 (broken sniffing on the vendor string in firefox on linux UAs) appears to have been fixed for a while. At least, with

"Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.6) Gecko/2009020410 Fedora/3.0.6-1.fc10 Firefox/3.0.6"

as the UA windows live hotmail works fine.

Comment 33

8 years ago
Oliver, would you mind testing on Linux with "Firefox/3.0.6" removed from that UA string, or with a recent Minefield nightly (which will also lack the word "Firefox")?

Comment 34

8 years ago
I tested by changing general.useragent.extra.firefox in about:config to "Minefield", quitting firefox and then restoring the session. I logged into hotmail and browsed around and turned on and off the reading pane without any problems or strange messages. Is there anything else I should be testing for?

I think there's no difference between "Classic" and "Full Mode" in the latest version of hotmail. I do see the string "InboxLight" in the url, but I also see that on a reasonably powerful windows vista laptop.

I also tested from a fedora live-cd I had hanging around (in case I had any cookies interfering with things) with the same results.

Updated

7 years ago
No longer blocks: 468835

Updated

7 years ago
Duplicate of this bug: 591733

Comment 36

7 years ago
For me if the full string contains "Mozilla/5.0" and "Gecko/" and doesn't contain "firefox" after this (where the value of general.useragent.extra.firefox is placed), I am redirected to the mobile version of hotmail. This applies to Minefield, Namoroka, Songbird, etc but also if this part of the user agent string is blank. i.e. "Namoroka/3.6.10pre" doesn't work but "Firefox/3.6.10pre" or "Firefox" does.

Updated

7 years ago
Duplicate of this bug: 596384
is this still happening?
Note that hotmail has been since replaced by https://mail.live.com/
Assignee: english-us → nobody
Status: REOPENED → NEW
Component: English US → Desktop
Whiteboard: [country-all] [serversniff]
(Reporter)

Comment 39

3 years ago
I no longer use Hotmail or its replacement.  While I have no further interest in this bug report, that does not mean there is no Tech Evangelism bug here.  Someone else will have to confirm whether this is indeed still a bug.
"Please upgrade your web browser
To get the most out of Outlook.com, we recommend that you upgrade your web browser. Upgrading should only take a few minutes.

    Download the latest version of Microsoft Internet Explorer
    Or upgrade your current version of Mozilla Firefox

If you don't upgrade, you can still continue to your inbox. However, Skype calling, chatting in Messenger, and instant actions might not work properly. "

So, a "soft warning" because they don't understand what Firefox version you're using, but you're allowed to continue.
Summary: hotmail.com - Windows Live Hotmail (full version) cannot be accessed from non-Firefox Gecko browsers → hotmail.com - Windows Live Hotmail (full version) warns on login when accessed from non-Firefox Gecko browsers
Keywords: relnote

Comment 41

9 months ago
This is now working with 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/42.0 SeaMonkey/2.39
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.