Remove Delete button when a News item is selected

VERIFIED DUPLICATE of bug 64729

Status

P3
normal
VERIFIED DUPLICATE of bug 64729
19 years ago
14 years ago

People

(Reporter: nbaca, Assigned: scottputterman)

Tracking

({polish})

Trunk
Future
All
Windows 95
polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

19 years ago
Build 2000-05-16-09M16: Win95
Also applies to Linux and Mac

Overview: When a News Server, Newsgroup or News Message is selected the 
Delete button displays in the Mail Toolbar.

Expected Results: The Delete button should be removed.
(Reporter)

Updated

19 years ago
Keywords: ui
QA Contact: lchiang → nbaca
(Reporter)

Comment 1

19 years ago
Adding jglick to Cc: list for clarification.

The Delete button may need to be disabled, depending on what implementation is 
chosen. Should there be a delete button? If so then should it be disabled when 
the following are selected:

- News Message (or change button to say Cancel)
- Newsgroup (or change button to say Unsubscribe)
- News Server

Comment 2

19 years ago
In 4.x, the "Delete" button is replaced with a "Mark" button when a Newsgroup, 
News Server, or News posting is selected.

IMO, I don't think the "Mark" button is necessary.  Its not a common enough 
action to be on the Toolbar.

My preference would be to Remove the Delete button from the Toolbar since it 
would NEVER be enabled when a News group/server/posting has focus.  Can we do 
this?  The other buttons would need to shift to the left when this happens.

We could leave the button and rename it "Cancel" but this isn't a very common 
action either, and button would probably be disabled most of the time anyway.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Assignee)

Updated

19 years ago
Keywords: nsbeta3, polish
(Assignee)

Comment 3

19 years ago
Mail Triage is marking [nsbeta3-]
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future

Comment 4

18 years ago
*** Bug 52196 has been marked as a duplicate of this bug. ***
*** Bug 54083 has been marked as a duplicate of this bug. ***
Actually, I miss having the mark button on the tool bar. When I finish picking
and choosing which news to read under 4.x, I go up to mark and "Mark all as
read" This is sort of a delete-like action.

I fixed this recently.  this is a duplicate of a fixed bug.

*** This bug has been marked as a duplicate of 64729 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 10

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.