RSS feed preview page is broken

VERIFIED FIXED in Firefox 3 beta1

Status

()

Firefox
RSS Discovery and Preview
--
blocker
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: stephend, Assigned: mano)

Tracking

({regression})

Trunk
Firefox 3 beta1
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
Build ID: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007092204 Minefield/3.0a9pre

Summary: RSS feed subscription is broken.

Regression from bug 395496.

Steps to Reproduce:

1. Load http://jtbatson.blogspot.com/ (or any URL with an RSS feed)
2. Click on the RSS feed icon in the location bar
3. Choose "Subscribe to..." from the popup menu
 
Expected Results:

From there, I should be able to subscribe to the RSS feed

Actual Results:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFeedWriter.init]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/feeds/subscribe.js :: SH_init :: line 47"  data: no]

Error: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavHistoryService.removeObserver]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: file:///C:/Program%20Files/Minefield/components/FeedWriter.js :: FW_close :: line 792"  data: no]
Source File: file:///C:/Program%20Files/Minefield/components/FeedWriter.js
Line: 792
(Reporter)

Updated

10 years ago
Blocks: 395496

Updated

10 years ago
Duplicate of this bug: 397226

Comment 2

10 years ago
screen shot :
now, http://img507.imageshack.us/img507/1641/fv1bg0.jpg
before, http://img507.imageshack.us/img507/3516/fv2qs1.jpg

1) default readers (my yahoo,bloglines,google) are not displayed in drop down menu.
2) "always...." text is missing.
3) reader's favicon is missing. [additional]
Subscribing to a feed works if you have Firefox set to skip the preview, so it's really only the preview page that's broken.
Flags: blocking-firefox3?
(Reporter)

Updated

10 years ago
Summary: RSS feed subscription is broken → RSS feed preview page is broken
With a fresh profile using today's build I cannot add a feed at all from foxnews.com. When I check the checkbox then any subsequent visits to other pages allow me to add the feeds from those pages. So the initial feedback the user gets is that RSS may be broken.

(In reply to comment #3)
> Subscribing to a feed works if you have Firefox set to skip the preview, so
> it's really only the preview page that's broken.
> 

(In reply to comment #4)
> With a fresh profile using today's build I cannot add a feed at all from
> foxnews.com. When I check the checkbox then any subsequent visits to other
> pages allow me to add the feeds from those pages. So the initial feedback the
> user gets is that RSS may be broken.
> 
Confirmed, severity should really be Blocker for this one

(Reporter)

Comment 6

10 years ago
Setting as blocker since this is stopping us from testing.
Severity: major → blocker

Comment 7

10 years ago
Not just Vista, it's broken on my Linux builds as well.

Comment 8

10 years ago
I can confirm.
Have a problem with this on Linux too.
OS: Windows Vista → All
Hardware: PC → All
Assignee: nobody → mano
Flags: blocking-firefox3? → blocking-firefox3+
Created attachment 282762 [details] [diff] [review]
patch
Attachment #282762 - Flags: review?(gavin.sharp)
Created attachment 282770 [details] [diff] [review]
working...
Attachment #282762 - Attachment is obsolete: true
Attachment #282770 - Flags: review?(gavin.sharp)
Attachment #282762 - Flags: review?(gavin.sharp)
Attachment #282770 - Flags: review?(gavin.sharp) → review+
mozilla/toolkit/content/widgets/menulist.xml 1.32
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M9

Comment 12

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092920 Minefield/3.0a9pre ID:2007092920

confirmed, fixed now.

BTW, no reader favicon on/in pull-down is intended or will be fixed ?
(Reporter)

Comment 13

10 years ago
(In reply to comment #12)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007092920
> Minefield/3.0a9pre ID:2007092920
> 
> confirmed, fixed now.
> 
> BTW, no reader favicon on/in pull-down is intended or will be fixed ?

I get reader favicons working on Mac, but in my XP SP2 VM, I don't see them until I mouse through the dropdown select list; it appears that it doesn't build them until selection, which is weird.

Pal, can you file a spin-off bug?

Comment 14

10 years ago
(In reply to comment #13)
> Pal, can you file a spin-off bug?
> 

filed, bug 398130
(Reporter)

Comment 15

10 years ago
Verified FIXED using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007100505 Minefield/3.0a9pre and

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007100504 Minefield/3.0a9pre
Status: RESOLVED → VERIFIED

Comment 16

10 years ago
Mano, why did you put the mutation listener back in to menulist here?
(In reply to comment #16)
> Mano, why did you put the mutation listener back in to menulist here?

Because addBroadcastListenerFor doesn't work in non-XUL documents (like the feed preview page).
You need to log in before you can comment on or make changes to this bug.