[feed preview] reader favicon on pull-down is missing

RESOLVED DUPLICATE of bug 591969

Status

()

P4
normal
RESOLVED DUPLICATE of bug 591969
11 years ago
8 years ago

People

(Reporter: bugmozz, Assigned: mano)

Tracking

({polish, regression})

Trunk
polish, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
blocking-firefox3.6 -
wanted-firefox3 +
wanted-firefox3.6 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FFT3.5])

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 282981 [details]
screenshot before/now
Flags: blocking-firefox3?
I checked both places the icons appear in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre) Gecko/2007100104 Minefield/3.0a9pre and I see the icons (Preferences and Feed Preview UI). There is a bit of a delay when the icons load in the feed preview UI unless for some reason this is a windows only bug.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007100110 Minefield/3.0a9pre ID:2007100110

I'm not seeing this either

Comment 3

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007100304 Minefield/3.0a9pre ID:2007100304

I can't see it either
It's usually broken the first time, and then works the second time; seems like it's a problem with XUL cache.  I just saw this with today's build: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007100405 Minefield/3.0a9pre
Flags: blocking-firefox3? → blocking-firefox3+
Is there a regression range for this?  This doesn't seem that bad, actually..
Keywords: polish
Target Milestone: --- → Firefox 3 Mx
(Reporter)

Comment 6

11 years ago
re-checked, with new profile.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007110823 Minefield/3.0b2pre ID:2007110823

if favicons are not displayed at first time,
re-open drop-down and they are displayed.

is this a cache issue mentioned in comment#4 ?


regression range does not become clear for me.
[example] using Build(A),
with old profile, they are not displayed,
but with new profile, they are displayed.
or
with old profile, they are displayed,
but with new profile, they are not displayed.

Updated

11 years ago
Priority: -- → P5

Updated

11 years ago
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
Priority: P5 → P4
Target Milestone: Firefox 3 Mx → Firefox 3 M11
I see this all the time on OS X with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090615 Firefox/3.5 ID:20090615154529

We should find the regression range...
Flags: blocking-firefox3.6?
Keywords: regressionwindow-wanted
OS: Windows XP → All
Hardware: x86 → All
Target Milestone: Firefox 3 beta3 → ---
Whiteboard: [FFT3.5]

Comment 8

9 years ago
Good:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070522 Minefield/3.0a5pre (08)

Icons missing first time in new profile:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070522 Minefield/3.0a5pre (19)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007103103 Minefield/3.0a9pre

Icons missing first time after starting Firefox:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007110103 Minefield/3.0a9pre

Looks like we have two regressions. I'll finish bisecting this later.

Comment 9

9 years ago
> Icons missing first time after starting Firefox:
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007110103
> Minefield/3.0a9pre

This one was caused by the fix for bug 401726. So the places records for the favicons are always getting deleted at shutdown.

Now to figure out the earlier regression...
Blocks: 401726

Comment 10

9 years ago
> Icons missing first time in new profile:
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070522
> Minefield/3.0a5pre (19)

This one was caused by the fix for bug 368745.
Blocks: 368745
Keywords: regressionwindow-wanted
Mano: can you look into this regression, and perhaps add tests so we don't re-regress?
Assignee: nobody → mano
Flags: wanted-firefox3.6+
Flags: blocking-firefox3.6?
Flags: blocking-firefox3.6-
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591969
You need to log in before you can comment on or make changes to this bug.