feed handler icons not shown in feed preview menupopup ( feed reader )

RESOLVED FIXED

Status

defect
RESOLVED FIXED
9 years ago
7 months ago

People

(Reporter: mcdavis941.bugs, Assigned: sicking)

Tracking

Trunk
x86_64
Windows Vista
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

Attachments

(2 attachments)

Looking at the menupopup on the feed preview page, I noticed the icons are missing.  Is that an intentional change?

Also, the current menuitem is highlighting with dark-on-dark colors.

Also, the right border on the menupopup goes missing frequently.

Also, if you happen to be using a third-party theme which displays the icons, you notice that the icon for "choose application" no longer shows.  Instead, it shows the RSS icon, which seems to be because the menuitem receives image="page-livemarks.png", which prevents "application.png" icon from applying via in-theme CSS to the menuitem.  DOM Inspector shows the image attribute is not present on that menuitem in Fx3.6.

STR: 
- show the feed preview by loading http://feeds.nytimes.com/nyt/rss/HomePage
- open the menupopup in the content area at the top of the feed preview page
- notice the icons don't show and other issues (see screenshot)

Mozilla/5.0 (Windows NT 6.0; WOW64; rv:2.0b5pre) Gecko/20100829 Firefox/4.0b5pre

Not sure who to CC on this, but adding some of the people from other feed preview bugs and Jonas Sicking because Bug 546857 touched feed previews.
Also, it doesn't seem right for the feed handlers of disabled add-ons to show in the list, but that's probably a separate issue.
I wonder if this is windows specific. I definitely worked to make sure that the icons kept working, and they are working on my mac.
Assignee: nobody → jonas
blocking2.0: --- → beta6+
It's not Windows-specific, it's Aero-specific. If you had 55 lines of context in https://bug546857.bugzilla.mozilla.org/attachment.cgi?id=467560 then the browser/themes/winstripe/browser/jar.mn hunk would have shown the warning in http://mxr.mozilla.org/mozilla-central/source/browser/themes/winstripe/browser/jar.mn#4
Posted patch Patch to fixSplinter Review
Thanks Phil!
Attachment #470495 - Flags: review?(philringnalda)
Attachment #470495 - Flags: review?(philringnalda) → review?(dolske)
Attachment #470495 - Flags: review?(dolske) → review+
missing icon, bug 398130
the missing right border looks like DW bug 571447.
Forgot to mark this one fixed. Fix was checked in September 1st.

http://hg.mozilla.org/mozilla-central/rev/bf04d87edcba
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 398130
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.