Closed Bug 399154 Opened 14 years ago Closed 8 years ago

relax/expand delimiter parsing of all To: fields

Categories

(Thunderbird :: Message Compose Window, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: charlesaxel.dein, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/419.3 (KHTML, like Gecko) Safari/419.3
Build Identifier: version 2.0.0.6 (20070728)

I think that the email list parsing in Thunderbird seriously lacks efficiency. One cannot make the user responsible for badly syntaxed list of email addresses.

So:
- Thunderbird should be able to recognise any recurring symbol (commas, semicolons, slashes, exclamation mark...)
- Thunderbird should be able to recognise how the email addresses are encapsulated (brackets, single or double angle quotes...)
- Thunderbird should be able to continue even if it found a syntax error, and ask the user (for now, if there is an error in the list, it stop and does not parse the list)

Because for the moment, we will use a word processor in order to replace and make the syntax correct.

It is a general bug since it also affect the list feature in address book. I found a lot of related bug, but I thought it was useful to integrate and unify all the related issues.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Well, there is bug 242693...

> One cannot make the user responsible for badly syntaxed list of email
addresses.

I disagree. There is no point allowing all kind of jiberish in the address field, especially as it's very simple to use commas.
It is not the same bug, since this bug is just related to semicolon.

> I disagree. There is no point allowing all kind of jiberish in the address
> field, especially as it's very simple to use commas.

Evidently, but to some extent. Computer are supposed to help human beings when it is possible, not the contrary.
Please file separate bug for address book
Component: General → Message Compose Window
QA Contact: general → message-compose
Summary: Smarter and comprehensive parsing of all To: fields *and* email list in addressbook list → expand delimiter parsing of all To: fields
Depends on: 210521
Depends on: 258653
No longer depends on: 210521
Summary: expand delimiter parsing of all To: fields → relax/expand delimiter parsing of all To: fields
(In reply to Charles-Axel Dein from comment #0)

> I think that the email list parsing in Thunderbird seriously lacks
> efficiency. One cannot make the user responsible for badly syntaxed list of
> email addresses.

> So:
> - Thunderbird should be able to recognise any recurring symbol (commas,
> semicolons, slashes, exclamation mark...)

This request is invalid, because even slashes and exclamation marks can be valid parts of email addresses, see

http://en.wikipedia.org/wiki/Email_address#Valid_email_addresses
which says that the following email address is valid:
!#$%&'*+-/=?^_`{}|~@example.org

> - Thunderbird should be able to recognise how the email addresses are
> encapsulated (brackets, single or double angle quotes...)

(In reply to Magnus Melin from comment #1)
> I disagree. There is no point allowing all kind of jiberish in the address
> field, especially as it's very simple to use commas.

+1. 

> - Thunderbird should be able to continue even if it found a syntax error,
> and ask the user (for now, if there is an error in the list, it stop and
> does not parse the list)
> [...]
> It is a general bug since it also affect the list feature in address book.

We can't have multiple bugs in one report. 

(In reply to Wayne Mery (:wsmwk) from comment #3)
> Please file separate bug for address book
+1

The only thing which I find surprising is that even after bug 242693 / bug 258653 we don't immediately expand semicolon-separated recipients on a single recipient input line:

a@b.com; b@d.com   then press ENTER

actual result: not expanded
expected result: expand into two single addresses on two recipient lines

However, mail will be sent correctly, so parsing happens before sending (perhaps by design, to avoid users getting too comfortable with illegal ; separator.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.