Last Comment Bug 400467 - Java broken on Vista after Firefox 2.0.0.8 upgrade (says Java Not Found, Or Not Working)
: Java broken on Vista after Firefox 2.0.0.8 upgrade (says Java Not Found, Or N...
Status: VERIFIED FIXED
: regression, verified1.8.1.10, verified1.8.1.9
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: 1.8 Branch
: x86 Windows Vista
: -- major (vote)
: mozilla1.9beta1
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
: Gregory Szorc [:gps]
Mentors:
http://pogo.com
: 400422 400490 400597 400609 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-19 15:11 PDT by Mary Brosh
Modified: 2007-11-15 07:35 PST (History)
24 users (show)
mbeltzner: blocking1.9+
mtschrep: blocking1.8.1.9+
dveditz: blocking1.8.1.10+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Regedit file to workaround this bug (236 bytes, text/plain)
2007-10-22 17:02 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
no flags Details
installer patch (2.26 KB, patch)
2007-10-22 17:08 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
moco: review+
dveditz: approval1.8.1.9+
dveditz: approval1.8.1.10+
Details | Diff | Splinter Review
as checked in to the branches (2.43 KB, patch)
2007-10-23 10:51 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
no flags Details | Diff | Splinter Review

Description Mary Brosh 2007-10-19 15:11:57 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

I just updated my version this morning & ever since when I go to load a game that's the message that comes up I can access this site with IE version7 so I believe it is a problem with this critical update

Reproducible: Always

Steps to Reproduce:
1.Go to Pogo.com
2.access a game might have to create an account
3.click to load the game
Actual Results:  
took forever to open & when it did there was the java not working, or found message.

Expected Results:  
opened & allowed me to play the game like it did right before I installed those critical updates
Comment 1 Marcia Knous [:marcia - use ni] 2007-10-19 15:19:01 PDT
Mary: Can you please use this site and report which version of Java it shows: http://www.javatester.org/version.html?
Comment 2 Mary Brosh 2007-10-20 05:26:12 PDT
(In reply to comment #1)
> Mary: Can you please use this site and report which version of Java it shows:
> http://www.javatester.org/version.html?

I am running Java Version 1.60_03
Comment 3 Ria Klaassen (not reading all bugmail) 2007-10-20 16:09:30 PDT
*** Bug 400490 has been marked as a duplicate of this bug. ***
Comment 4 Hernán Pablo Alvarez 2007-10-20 21:44:24 PDT
I suffered this bug too (Windows Vista, Java 1.6.0 update 3 and Firefox 2.0.0.8) but I think I've found a workaround:

* Right click Firefox icon and choose "Run as administrator"
* Accept UAC prompt
* Enter any site which use a Java applet, Java should load normally
* Close Firefox
* Run Firefox again, but in normal mode (without administrator privileges)

Java should work correctly after that.
Comment 5 Ria Klaassen (not reading all bugmail) 2007-10-21 09:24:01 PDT
This works fine with Windows XP and it appears to be Vista only.
Comment 6 Ria Klaassen (not reading all bugmail) 2007-10-21 12:56:21 PDT
*** Bug 400609 has been marked as a duplicate of this bug. ***
Comment 7 Mary Brosh 2007-10-21 15:09:50 PDT
(In reply to comment #4)
> I suffered this bug too (Windows Vista, Java 1.6.0 update 3 and Firefox
> 2.0.0.8) but I think I've found a workaround:
> * Right click Firefox icon and choose "Run as administrator"
> * Accept UAC prompt
> * Enter any site which use a Java applet, Java should load normally
> * Close Firefox
> * Run Firefox again, but in normal mode (without administrator privileges)
> Java should work correctly after that.

This worked & fixed it thank You !!!
Comment 8 Daniel Veditz [:dveditz] 2007-10-21 15:38:42 PDT
*** Bug 400422 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Veditz [:dveditz] 2007-10-21 15:47:36 PDT
rob_strong: any idea what we changed that would cause Java to need a UAC prompt? Or why that prompt is suppressed for non-admin accounts?

Bug 400422 describes the specific problem of being unable to play Java-based games at pogo.com
Comment 10 Carsten Book [:Tomcat] 2007-10-21 16:58:34 PDT
(In reply to comment #5)
> This works fine with Windows XP and it appears to be Vista only.
> 

I can confirm this Bug for Vista and JRE 1.6 update 3. I need to use explicit the Option "Run as Administrator" (comment #4) to run java games at pogo. Even when i run Vista with a Admin User Account.  

Its a regression. 

Firefox 2.0.0.7 is fine (don`t need to run Firefox in "Run as Administrator" mode" with JRE 1.6.3) and 2.0.0.8.
Comment 11 Benjamin Smedberg [:bsmedberg] 2007-10-21 17:06:20 PDT
This is almost certainly due to bug 378598: we explicitly embed a manifest to runas=invoker. This means that vista compatibility mode is no longer active, and attempts to write to the program directory or UAC-protected registry keys, which would previously have been redirected to the virtual filestore/registry, now fail.

It would be good to run under filemon/regmon to see what operations are failing and notify Sun... plugins really shouldn't be failing because we stopped enabling vista compatibility mode.
Comment 12 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-10-21 17:56:09 PDT
*** Bug 400422 has been marked as a duplicate of this bug. ***
Comment 13 Carsten Book [:Tomcat] 2007-10-21 18:01:58 PDT
*** Bug 400490 has been marked as a duplicate of this bug. ***
Comment 14 WADA 2007-10-21 19:28:15 PDT
(In reply to comment #11)
> what operations are failing

Following has been reported to Bugzilla Japan.
  It was Name=CurrentVersion in next key. (version number of Gecko is held)
  - HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\mozilla.org\Mozilla (when x64)
  - HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla             (when x86)
    (On my Win-XP SP2/32bit, CurrentVersion=1.8.1.2 was found in this key) 
Reporter says checked by Process Monitor.
( http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=5900 , In Japanese)

Note:
Use of above entry is possibly a result of solution for crash of Bug 83376.
Comment 15 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-21 20:58:34 PDT
It appears that Java is trying to open that key with write access even though it doesn't appear to try to write anything. By giving my account full control of HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla a random Java game that wasn't working - in fact it crashed the browser - works fine.
Comment 16 WADA 2007-10-21 22:52:47 PDT
(In reply to comment #15)
> even though it doesn't appear to try to write anything.

To Robert Strong: 
Is it true even when CurrentVersion doesn't exist in the registry key of HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla?
(I think that workaround of comment #4 indicates;                             ) 
(  Once the entry is created/written, no further write permission is required.)
Comment 17 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-21 22:56:53 PDT
I already had HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla CurrentVersion = 1.9a8pre in my registry and it still exhibited this problem for me and removing the permissions I added caused the bug to reappear. That's what led me to believe it was failing due to specifying write access when opening the key.

I can change the permissions on HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla via the installer and via helper.exe during Software Update to workaround this issue with Java. The NSIS Access Control plugin would be necessary and I have a working patch.
http://nsis.sourceforge.net/AccessControl_plug-in

In the patch I gave Authenticated Users Full Access which equates to Full Control and Read in the registry permissions... I believe this should be sufficient.
Comment 18 WADA 2007-10-21 23:11:29 PDT
(In reply to comment #17)
> CurrentVersion = 1.9a8pre

It may be a cause of problem that workaround of comment #4 won't work in your environment.
When browser sniffing, beta version is not usually recognized. I guess that similar version detection logic is used by Sun Java. I think Sun Java is not an exception of Murphy's Raw.
What will happen when CurrentVersion=1.8.1.2 or CurrentVersion=1.9.1.1 is set? 
Comment 19 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-21 23:22:49 PDT
WADA, running as administrator does work since then you have write access... I am proposing a fix we can deploy to users quickly without having to run as administrator. So, by granting Full Access permissions to authenticated user for that reg key the problem no longer exists.

btw: I did try out release versions for CurrentVersion and it doesn't matter what the value is.
Comment 20 Benjamin Smedberg [:bsmedberg] 2007-10-22 06:18:12 PDT
Can we make sure we get a bug report filed with Sun as well?
Comment 21 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-22 10:27:22 PDT
The logic that Java is using for updating that key value is strange. After changing it to an official release value it crashed the first time and worked the second time. So, it is entirely possible that an official release value that matches the actual release works. Also, adding the actual value to HKCU and removing the mozilla.org key from HKLM didn't help.

http://crash-stats.mozilla.com/report/index/6c604e57-806a-11dc-b3fb-001a4bd43ed6?date=2007-10-22-06

I reported a bug to http://bugs.sun.com/ and it has a Review ID of 1094708 but it won't appear until they triage it
Comment 22 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-22 12:32:31 PDT
I haven't had time to verify this but it is possible we are causing this at
http://lxr.mozilla.org/seamonkey/source/modules/plugin/base/src/nsPluginDirServiceProvider.cpp#258
Comment 23 Benjamin Smedberg [:bsmedberg] 2007-10-22 12:46:17 PDT
Or line 374, but it looks like that code fails gracefully if it is unable to open/set the registry key.
Comment 24 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-22 17:02:40 PDT
Created attachment 285805 [details]
Regedit file to workaround this bug

It turns out that an installer modified my permissions without my knowing it which was causing the strange behavior for me and that adding the value for CurrentVersion during install will fix this.

You can download the attached regedit file and import it into your registry to workaround this bug and you will be prompted by UAC to import it.

Patch coming up
Comment 25 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-22 17:08:28 PDT
Created attachment 285807 [details] [diff] [review]
installer patch

All this does is add the GRE version to the value of CurrentVersion under HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla when the value is not the same as the version being installed.

I verified that adding this value under HKCU doesn't help Java so that isn't going to help. If having this value is truly necessary for Java we should probably get them to also check under HKCU and have our code add it there when the value is incorrect under HKLM. As is, we only update it when it doesn't exist.

Many thanks to Seth Spitzer for sending me his registry permissions so I could fix my own that were mucked up by some f#4$n company's installer.
Comment 26 (not reading, please use seth@sspitzer.org instead) 2007-10-22 17:28:31 PDT
robert, looks good.  just a few question / comments to make sure I understand:

1)  the browser/installer/windows/nsis/installer.nsi is for when the user runs the installer and the browser/installer/windows/nsis/shared.nsh change is for PostUpdate, right?

2)  will this change have any impact on side-by-side installs?  (does this make it so the last version of firefox to update and do PostUpdate or to be installed "win", and be able to use java?)

3)  do we need to delete this key on uninstall?
Comment 27 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-22 18:10:08 PDT
(In reply to comment #26)
> robert, looks good.  just a few question / comments to make sure I understand:
> 
> 1)  the browser/installer/windows/nsis/installer.nsi is for when the user runs
> the installer and the browser/installer/windows/nsis/shared.nsh change is for
> PostUpdate, right?
Correct

> 2)  will this change have any impact on side-by-side installs?  (does this make
> it so the last version of firefox to update and do PostUpdate or to be
> installed "win", and be able to use java?)
I don't have a clue as to what the value is used for by Java since just adding 1.1 made it so Java worked.

> 3)  do we need to delete this key on uninstall?
The uninstall process is going to have to jump through some hoops to do this properly since Java uses it and Java could be used by other Mozilla apps including XULRunner apps (e.g. Songbird, etc.) so there is no way I know of to easily tell that it is ok to remove this key on uninstall. Until there is a reliable way to tell I am not going to remove this key on uninstall.
Comment 28 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-22 18:11:06 PDT
Requesting blocking1.9 since this also affects the trunk and we have a beta release soon and a patch.
Comment 29 (not reading, please use seth@sspitzer.org instead) 2007-10-22 18:25:49 PDT
Comment on attachment 285807 [details] [diff] [review]
installer patch

r=sspitzer

robert, thanks for answering my questions.
Comment 30 Mike Beltzner [:beltzner, not reading bugmail] 2007-10-22 21:04:14 PDT
Blocking, aye. Not sure if it's an M9 blocker, but request approval when you're ready?
Comment 31 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-22 21:13:55 PDT
Comment on attachment 285807 [details] [diff] [review]
installer patch

It be ready matey! Arghhh
Comment 32 Phil Ringnalda (:philor) 2007-10-22 23:28:30 PDT
*** Bug 400597 has been marked as a duplicate of this bug. ***
Comment 33 Daniel Veditz [:dveditz] 2007-10-23 09:50:57 PDT
Comment on attachment 285807 [details] [diff] [review]
installer patch

approved for 1.8.1.9 and 1.8.1.10, a=dveditz for release-drivers

For 1.8.1.9 please land on the GECKO181_20071004_RELBRANCH. 1.8.1.10 is the normal 1.8 branch
Comment 34 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-23 10:51:21 PDT
Created attachment 285893 [details] [diff] [review]
as checked in to the branches
Comment 35 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-23 10:52:26 PDT
Checked in to trunk

Checking in mozilla/browser/installer/windows/nsis/installer.nsi;
/cvsroot/mozilla/browser/installer/windows/nsis/installer.nsi,v  <--  installer.nsi
new revision: 1.38; previous revision: 1.37
done
Checking in mozilla/browser/installer/windows/nsis/shared.nsh;
/cvsroot/mozilla/browser/installer/windows/nsis/shared.nsh,v  <--  shared.nsh
new revision: 1.17; previous revision: 1.16
done

Checked in to MOZILLA_1_8_BRANCH

Checking in mozilla/browser/installer/windows/nsis/installer.nsi;
/cvsroot/mozilla/browser/installer/windows/nsis/installer.nsi,v  <--  installer.nsi
new revision: 1.3.2.28; previous revision: 1.3.2.27
done
Checking in mozilla/browser/installer/windows/nsis/shared.nsh;
/cvsroot/mozilla/browser/installer/windows/nsis/shared.nsh,v  <--  shared.nsh
new revision: 1.3.2.11; previous revision: 1.3.2.10
done

Checked in to GECKO181_20071004_RELBRANCH

Checking in mozilla/browser/installer/windows/nsis/installer.nsi;
/cvsroot/mozilla/browser/installer/windows/nsis/installer.nsi,v  <--  installer.nsi
new revision: 1.3.2.27.2.1; previous revision: 1.3.2.27
done
Checking in mozilla/browser/installer/windows/nsis/shared.nsh;
/cvsroot/mozilla/browser/installer/windows/nsis/shared.nsh,v  <--  shared.nsh
new revision: 1.3.2.10.2.1; previous revision: 1.3.2.10
done
Comment 36 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-23 11:09:02 PDT
To reproduce remove the following registry key and try to launch a Java game
HKLM\Software\mozilla.org

sample Java game
http://www.flyordie.com/games/online/games.html?lang=en&game=8Ball&room=801&rs=1
and click "Play as Guest"

To verify the fix remove the key as above
Run the installer and try to play a Java game
and
After a Software Update try to play a Java game (remember to remove the key first)
Comment 37 Robert Strong [:rstrong] (use needinfo to contact me) 2007-10-23 12:35:24 PDT
Filed bug 400878 for the underlying issue
Comment 38 Carsten Book [:Tomcat] 2007-10-24 08:15:58 PDT
verified fixed 1.8.1.9 using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.9pre) Gecko/2007102404 BonEcho/2.0.0.9pre and the steps for testing from rob. My tests pass and so i can play the game. Also Java is working fine.

Adding verified keyword.
Comment 39 Mickey Frome 2007-10-24 17:08:52 PDT
Thank You al for your help on V 2.0.0.8 @Fly or Die Reversi. I right clicked and ran as administrator. Problem solved and working fine.
Comment 40 Carsten Book [:Tomcat] 2007-10-26 09:55:04 PDT
verified fixed on trunk with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007102605 Minefield/3.0a9pre and the steps to reproduce from comment #36

- Verified Fixed
Comment 41 Carsten Book [:Tomcat] 2007-11-15 07:35:09 PST
verified fixed 1.8.1.10 using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.10pre) Gecko/2007111503 BonEcho/2.0.0.10pre and pogo games - working fine

- Adding verified keyword

Note You need to log in before you can comment on or make changes to this bug.