Closed Bug 401136 Opened 12 years ago Closed 12 years ago

Implement sort results in search results page

Categories

(addons.mozilla.org Graveyard :: Public Pages, enhancement)

x86
All
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
4.x (triaged)

People

(Reporter: roniziv, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

Implement a "sort results" in search results page similar to the way implemented on the category browsing page

Reproducible: Always

Steps to Reproduce:
1. enter a search term on the AMO site search field
2. press "search"
3.
Actual Results:  
the search results page opens - there is no sort option

Expected Results:  
the search results page opens - sort options appear in the beginning of the page, same way as in add-ons category browsing page
OS: Windows XP → All
Version: 3.0 → 3.2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 3.x (triaged)
Duplicate of this bug: 426117
Now with advanced search capability, you can determine the sort order.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Would it be possible in the future to implement the sort buttons in search results the way they are in category browsing? Because if you want to resort search results at the moment, you have to:

1. Toggle the advanced search mode on.
2. Select how you want to sort the results in the drop-down.
3. Click the search arrow and wait for the results.

Whereas to resort the results when you are browsing a category, there is only one step:

1. Click the button for the way you want to sort the results and wait for the page to reload.

Also, it's quite easy to miss the Advanced search mode toggle link.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.