Last Comment Bug 401931 - Tabbrowser performance optimizations
: Tabbrowser performance optimizations
Status: RESOLVED FIXED
: meta, perf
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: P2 normal with 2 votes (vote)
: Firefox 3 beta2
Assigned To: Ryan Flint [:rflint] (ping via IRC for reviews)
:
: Dão Gottwald [:dao]
Mentors:
http://wiki.mozilla.org/User:Rflint/P...
Depends on: 353785 387345 393734 410128
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-31 12:37 PDT by Ryan Flint [:rflint] (ping via IRC for reviews)
Modified: 2012-01-16 13:35 PST (History)
18 users (show)
vladimir: blocking‑firefox3-
vladimir: wanted‑firefox3+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ryan Flint [:rflint] (ping via IRC for reviews) 2007-10-31 12:37:19 PDT
Tracker for work to be done to improve tabbrowser performance for both common user actions and traditional metrics.
Comment 1 Robert Sayre 2007-10-31 12:45:26 PDT
URL of the list is http://wiki.mozilla.org/User:Rflint/Performance:Tabbrowser

(I found it confusing)

Comment 2 Mike Connor [:mconnor] 2007-11-08 07:23:06 PST
We need to do this for b2 since I expect it'll screw with extensions among other things.
Comment 3 Mike Schroepfer 2007-11-28 10:35:54 PST
Ping on this - any progress here?
Comment 4 Reed Loden [:reed] (use needinfo?) 2007-11-28 11:14:06 PST
Why is a meta bug blocking-firefox3+?
Comment 5 Ryan Flint [:rflint] (ping via IRC for reviews) 2007-11-28 11:17:54 PST
The largest and most breakage-prone parts of this are mostly in on Linux and Windows - Mac will follow soon and I'll be filing some more dependancies for targets I've found with dtrace.
Comment 6 Vladimir Vukicevic [:vlad] [:vladv] 2008-03-14 13:09:10 PDT
Flipping blocking-fx3 -- the only remaining bug here is not blocking 1.9/blocking fx3.
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-01-16 13:34:04 PST
Gavin, is this bug finished?

Note You need to log in before you can comment on or make changes to this bug.