Closed Bug 402125 Opened 12 years ago Closed 12 years ago

Pinstripe theme should specify unified titlebar color (to look less clashy for beta)

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3 beta1

People

(Reporter: mconnor, Assigned: mano)

References

()

Details

Attachments

(1 file, 3 obsolete files)

We shouldn't have this odd Tiger/Leopard hybrid for now, see URL for a screenshot.  has ui-r from beltzner on IRC
Attachment #287021 - Flags: review?(mano)
Attachment #287021 - Flags: approvalM9?
Attached patch across all windows (obsolete) — Splinter Review
Assignee: mconnor → mano
Attachment #287021 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #287022 - Flags: review?(mconnor)
Attachment #287022 - Flags: approvalM9?
Attachment #287021 - Flags: review?(mano)
Attachment #287021 - Flags: approvalM9?
Attachment #287022 - Attachment is patch: true
Attachment #287022 - Attachment mime type: application/octet-stream → text/plain
Attached patch second chance, please? (obsolete) — Splinter Review
Attachment #287022 - Attachment is obsolete: true
Attachment #287024 - Flags: review?(mconnor)
Attachment #287024 - Flags: approvalM9?
Attachment #287022 - Flags: review?(mconnor)
Attachment #287022 - Flags: approvalM9?
Version: unspecified → Trunk
Summary: clean up titlebar to look less clashy for beta → Pinstripe theme should specify unified titlebar color (to look less clashy for beta)
Attachment #287024 - Attachment is obsolete: true
Attachment #287072 - Flags: review?(mconnor)
Attachment #287072 - Flags: approvalM9?
Attachment #287024 - Flags: review?(mconnor)
Attachment #287024 - Flags: approvalM9?
Comment on attachment 287072 [details] [diff] [review]
remove the toolbar background

Can't approve unreviewed patches, mconnor can renom after he's done the review.
Attachment #287072 - Flags: approvalM9?
So this will look tiger style on 10.5? :(
That's better than the current icon set on Leopard toolbars, IMO, so I'm fine with that for now.  I also don't want to get into a bunch of per-app chromereg stuff until we have time to fix fallout.
Comment on attachment 287072 [details] [diff] [review]
remove the toolbar background

yeah, this looks great!
Attachment #287072 - Flags: approvalM9?
Attachment #287072 - Flags: review?(mconnor) → review+
Flags: in-litmus+
Flags: blocking-firefox3?
Comment on attachment 287072 [details] [diff] [review]
remove the toolbar background

a=beltzner for M9
Attachment #287072 - Flags: approvalM9? → approvalM9+
Flags: blocking-firefox3? → blocking-firefox3+
Keywords: checkin-needed
mozilla/toolkit/themes/pinstripe/global/global.css 1.16
mozilla/toolkit/themes/pinstripe/global/jar.mn 1.36
mozilla/toolkit/themes/pinstripe/global/toolbar.css 1.9
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
mozilla/toolkit/themes/pinstripe/global/globalBindings.xml 1.22
Depends on: 402627
Depends on: 402654
This is not a good fix. It causes bad visual problems - the whole app looks albino and suffers badly from bug 402654 (check out the Preferences window). It is hard to tell when a window has focus or not because of the color.

Instead of turning on the unified look now we should just change the background color of the toolbar on 10.5 to match the darker title bar, or just back this patch out and do nothing for b1 (how could this possibly be a blocker anyway?). This solution's regressions are too bad to accept, imho. Makes the app look totally crazy, at least it looked like a Mac app before if a less-than-pretty one.
Verified fix on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; es-ES; rv:1.9a9pre) Gecko/2007110520 Minefield/3.0a9pre.  

Toolbar is now showing a more uniform grey color.
Status: RESOLVED → VERIFIED
Blocks: 406828
You need to log in before you can comment on or make changes to this bug.