[RTL] Need a better way to control the statusbar direction

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: tomer, Assigned: tomer)

Tracking

(Blocks 1 bug, {intl, rtl})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(3 attachments, 1 obsolete attachment)

Assignee

Description

12 years ago
Text in Hebrew Minefield apper wrong in the status bar due to the fact that we want it to be LTR for URLs but RTL for Status text "Waiting for...". 

Previous versions has #statusbar-display{
direction: ltr !important;} in intl.css, but this seem to break the status messages.

Comment 1

12 years ago
Moving over a flock of granparadiso RTL bugs to Firefox for triage.
Component: he-IL / Hebrew → General
Keywords: intl
Product: Mozilla Localizations → Firefox
Version: unspecified → Trunk
I see that the Persian localization [1] solves this by inserting bidi embedding controls in the localized strings, e.g. 

[RLE]TRANSFERRING DATA FROM [LRE]%1$S[PDF]...[PDF]

[1] http://mxr.mozilla.org/l10n/source/fa/netwerk/necko.properties

Axel, is it possible to mix UTF-8 and escapes (\u202a etc.) in properties files rather than using invisible characters, which make life very difficult when editing?

Comment 3

12 years ago
Unicode escapes still work, and will remain to work in .properties files.
Assignee

Comment 4

12 years ago
Any solution for this issue, or we'll have to do the same *workaround* the Persians did?
I think the workaround is actually the most practical solution here.
QA Contact: hebrew.he → general

Updated

12 years ago
Assignee

Updated

12 years ago
Blocks: fx3-l10n-he

Updated

11 years ago
Blocks: fx35-l10n-fa

Updated

11 years ago
No longer blocks: Persian-Fx3.5

Comment 6

11 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
Assignee

Comment 7

11 years ago
Posted file necko.properties with RLE/LRE..PDF (obsolete) —
Assignee

Comment 8

11 years ago
Some extra whitespaces removed.
Attachment #321418 - Attachment is obsolete: true
Assignee

Comment 9

11 years ago
Posted patch patchSplinter Review
This is very important fix we should get fixed before going final, as it is visually appear on every request.
Assignee: nobody → tomer
Status: NEW → ASSIGNED
Attachment #321420 - Flags: approval1.9?
Assignee

Comment 10

11 years ago
I've added /l10n/he/netwerk/necko.properties into the patch of bug 433777 attachment 321801 [details] [diff] [review]. 

ar people - You might wish to do the same in your locale. 
http://mxr.mozilla.org/l10n/source/ar/netwerk/necko.properties
Depends on: 433777

Comment 11

11 years ago
This has been reported in launchpad as well 
https://bugs.edge.launchpad.net/ubuntu/+source/firefox-3.0/+bug/234029
Assignee

Comment 12

11 years ago
fixed and landed for 'he'. 
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED

Updated

10 years ago
No longer blocks: fx35-l10n-fa

Updated

10 years ago
Blocks: Persian
Assignee

Comment 13

9 years ago
As Firefox 4 is around the corner, I'd suggest reopening this bug in order to find a better way to do it, as RLE..PDF is not the expected solution.

Updated

9 years ago
Duplicate of this bug: 477189
You need to log in before you can comment on or make changes to this bug.