Closed Bug 403346 Opened 17 years ago Closed 16 years ago

Dreamweaver 'preview in browser' broken on nightly build

Categories

(Camino Graveyard :: OS Integration, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Camino2.0

People

(Reporter: mark, Assigned: bugzilla-graveyard)

References

Details

(Keywords: fixed1.8.1.15, regression)

Attachments

(1 file)

1.21 KB, patch
alqahira
: review+
stuart.morgan+bugzilla
: superreview+
Details | Diff | Splinter Review
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.10pre) Gecko/20071110 Camino/1.6a1pre (like Firefox/2.0.0.10pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.10pre) Gecko/20071110 Camino/1.6a1pre (like Firefox/2.0.0.10pre)

dreamweaver's 'preview in browser' function is broken in the nightly builds if camino is already open yet works if dreamweaver has to launch camino
it works fine in the latest stable 1.5.3

Reproducible: Always

Steps to Reproduce:
1. launch camino
2. launch dreamweaver, and open html page
3. select preview in browser 
Actual Results:  
will switch to camino but will not preview page

Expected Results:  
opened the html page from dreamweaver
I'd bet Dreamweaver is not sending us the right event now.
What changed in this regard from 1.5.3 to the 1.6 branch?
Confirming using Dreamweaver CS 3.

(In reply to comment #2)
> What changed in this regard from 1.5.3 to the 1.6 branch?

Since Smokey CCed Peter, I'm guessing he thinks this is caused by our AppleScript support changing. That and him saying "event" kind of convinces me.
Status: UNCONFIRMED → NEW
Ever confirmed: true
That wasn't an "I don't believe you"; that was a "what, specifically, broke this?"

cl
Keywords: regression
We need someone to take a look at this and log the AppleEvents.
Flags: camino1.6.1?
(In reply to comment #5)
> We need someone to take a look at this and log the AppleEvents.

By which I mean, if you have Dreamweaver and are willing to get your hands dirty a little, ping Peter for help; he doesn't have Dreamweaver, so he can't debug this himself.
I wasn't sure what you meant by pinging him (ping him on IRC?), but I went ahead and sent him an email.
Attempted to debug this with Peter, but couldn't figure this out.

When trying to preview in 1.6RC1 from Dreamweaver, Camino says:

2008-04-09 16:45:37.111 Camino[4486:10b] Suite NSCoreSuite, apple event code 0x3f3f3f3f

2008-04-09 16:45:37.116 Camino[4486:10b] Suite NSTextSuite, apple event code 0x3f3f3f3f

2008-04-09 16:45:37.149 Camino[4486:10b] Suite CaminoSuite, apple event code 0x4d4f5a43

2008-04-09 16:45:37.151 Camino[4486:10b] Suite InternetSuite, apple event code 0x4755524c

2008-04-09 16:45:37.153 Camino[4486:10b] Suite NSCoreSuite, apple event code 0x636f7265

2008-04-09 16:45:37.156 Camino[4486:10b] .scriptSuite warning for attribute 'boundsAsQDRect' of class 'NSWindow' in suite 'NSCoreSuite': 'NSData<QDRect>' is not a valid type name.

2008-04-09 16:45:37.156 Camino[4486:10b] .scriptSuite warning for attribute 'document' of class 'NSWindow' in suite 'NSCoreSuite': 'NSDocument' is not a valid type name.

2008-04-09 16:45:37.157 Camino[4486:10b] .scriptSuite warning for argument 'SaveOptions' of command 'Close' in suite 'NSCoreSuite': 'NSNumber<SaveOptions>' is not a valid type name.

2008-04-09 16:45:37.158 Camino[4486:10b] .scriptSuite warning for result type of command 'Open' in suite 'NSCoreSuite': 'NSDocument' is not a valid type name.

2008-04-09 16:45:37.158 Camino[4486:10b] .scriptSuite warning for argument 'SaveOptions' of command 'Quit' in suite 'NSCoreSuite': 'NSNumber<SaveOptions>' is not a valid type name.

2008-04-09 16:45:37.159 Camino[4486:10b] .scriptSuite warning for attribute 'boundsAsQDRect' of class 'NSWindow' in suite 'NSCoreSuite': 'NSData<QDRect>' is not a valid type name.



When previewing in 1.5.5 from Dreamweaver (which works), Camino says:

2008-04-09 16:58:34.534 Camino[4682:10b] Suite NSCoreSuite, apple event code 0x3f3f3f3f

2008-04-09 16:58:34.539 Camino[4682:10b] Suite NSTextSuite, apple event code 0x3f3f3f3f

2008-04-09 16:58:34.616 Camino[4682:10b] Suite Camino, apple event code 0x4d4f5a43

2008-04-09 16:58:34.628 Camino[4682:10b] Command: Camino.OpenURL

Direct Parameter: file:///Mac Mini/Various/School/CSIS 133 Web Development Tools/Student Homepage/webdevtools/survey.html

Receivers: (null)

Arguments:    {

    }

2008-04-09 16:58:34.781 Camino[4682:10b] Result: (null)
To summarize from irc: they are sending us the old WWW!OURL, rather than GURLGURL, and we lost support for that in the rewrite. We should re-add deprecated support for WWW!OURL, so that we handle people sending it, but people won't write new scripts using it.

We'll take a patch for this in whatever 1.6.x we can.
Target Milestone: --- → Camino2.0
Attached patch fix, I hopeSplinter Review
Here's what I think is a patch for this, based on the IRC conversation and some discussion with Peter.

Dave, are you still doing your own builds? If so, you should be able to apply this patch via the usual process and test it. If not, I'm sure Smokey or someone else would be happy to make a test build for you, although I'm told that with trunk, you can simply apply the change to the SDEF file (inside the app package, in the Resources folder) and re-launch the application.

cl
Assignee: nobody → cl-bugs-new
Status: NEW → ASSIGNED
Attachment #317649 - Flags: review?(alqahira)
I'm not doing my own builds, but I added the command to SDEF file of my trunk nightly and it worked perfectly. Dreamweaver's preview in browser will once again work in Camino even if it is already open. Thanks!
Comment on attachment 317649 [details] [diff] [review]
fix, I hope

>+		<command name="DeprecatedGetURL" 

Since the name for the event/command with the "WWW!OURL" signature is OpenURL (at least everywhere else in the world), please make this "DeprecatedOpenURL" instead (and below in the "Cocoa name" part).

>code="WWW!OURL" description="Open a URL in Camino via applications that use a deprecated AppleEvent model. Included for compatibility purposes only. Scripts should *never* use this command. Use 'open location' instead." 

Make this read "Open a URL in Camino via the deprecated OpenURL AppleEvent. Included for compatibility purposes only; scripts should use 'open location' instead." or the like.

I tested this on 10.5.2 and 10.3.9, and happily "hidden" is preserved in the .sdef->.script* translation.  The patch also works as expected as far as I can test.

I also did some further checking, and Safari does support the WWW!OURL event even though it is not in the dictionary  or the raw .scriptSuite/.scriptTerminology files (how I don't know).  Therefore, it is important for us to keep this event as long as 

tell application "Safari"
     «event WWW!OURL» "https://bugzilla.mozilla.org/"
end tell

continues to work.

r=ardissone with those changes (can be made post-sr or on checkin)
Attachment #317649 - Flags: superreview?(stuart.morgan)
Attachment #317649 - Flags: review?(alqahira)
Attachment #317649 - Flags: review+
Comment on attachment 317649 [details] [diff] [review]
fix, I hope

sr=smorgan with Smokey's changes.
Attachment #317649 - Flags: superreview?(stuart.morgan) → superreview+
Checked in on the trunk and the MOZILLA_1_8_BRANCH in advance of 1.6.1 (with my changes, plus changing the two ' to &ldquo; and &rdquo; to keep stray ' out of the file).

If this bug is a pain point for you, you should be able to grab tomorrow's branch (or trunk) nightlies to get a build with this fix.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Component: General → OS Integration
Flags: camino1.6.1? → camino1.6.1+
Keywords: fixed1.8.1.15
QA Contact: general → os.integration
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.