Closed Bug 403497 Opened 12 years ago Closed 11 years ago

Smart Bookmarks and other Places folders are not (should be) automatically renamed when language version / locale is changed

Categories

(Firefox :: Bookmarks & History, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: cbook, Unassigned)

References

Details

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b1) Gecko/2007110904 Firefox/3.0b1

Steps to reproduce: 
-> Install the DE Firefox 3 Beta 1 RC
-> The Places Toolbar Folder with recently starred pages etc is named as "Orte" and the descriptions are in german
-> Install the en-US Firefox 3 Beta 1 RC
-> The places toolbar folder is still named "Orte" and not "Places" also the descriptions in the Places toolbar folder are still german

So the Places Toolbar Folder stays in the language of the first installation. There is no modification when a other language is installed and replace the first language.
Duplicate of this bug: 419517
Severity: normal → enhancement
Summary: Places Toolbar Folder not renamed when language version is changed → Smart Bookmarks and other Places folders are not (should be) automatically renamed when language version / locale is changed
Duplicate of this bug: 465936
If these were static items that could not be removed by the user, I'd consider this a bug. However, these are transient items that can be modified in any way (moved, renamed, deleted, etc), so the items might not even be identifiable or even exist at the point of the locale change.

A workaround would be to delete the browser.places.smartBookmarksVersion pref. This will cause these items to be recreated in the current locale.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.