Last Comment Bug 404032 - include desktop entry file
: include desktop entry file
Status: RESOLVED DUPLICATE of bug 296568
: intl, l12y
Product: Firefox
Classification: Client Software
Component: Shell Integration (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-16 07:14 PST by Matěj Cepl
Modified: 2008-02-27 14:20 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
originally from Ubuntu (2.45 KB, text/plain)
2007-11-16 07:19 PST, Matěj Cepl
no flags Details

Description Matěj Cepl 2007-11-16 07:14:12 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en; rv:1.8.1.9) Gecko/20071105 Epiphany/2.20 Firefox/2.0.0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en; rv:1.8.1.9) Gecko/20071105 Epiphany/2.20 Firefox/2.0.0.9

This is a complementary bug to bug 371734 for Firefox. All Linux distributions carry some .desktop file to integrate with the desktop environment. It would help uniting i18n to have one upstream {firefox,thunderbird,seamonkey,etc.}.desktop file.

Format for .desktop file is standardized on http://standards.freedesktop.org/desktop-entry-spec/latest/

Reproducible: Always

Steps to Reproduce:
1. Take a look at the menu of your preferred environment
2.
3.
Actual Results:  
unlocalized string (e.g., "Firefox Web Browser")

Expected Results:  
localized string (e.g., "Firefox Webový prohlížeč" in cz_CZ).
Comment 1 Matěj Cepl 2007-11-16 07:19:06 PST
Created attachment 288999 [details]
originally from Ubuntu

This file is currently from Ubuntu
http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_2.0.0.8+2nobinonly-0ubuntu3.diff.gz
but will be in Fedora as well
(https://bugzilla.redhat.com/show_bug.cgi?id=383411)
Comment 2 [:Aleksej] 2008-02-27 14:20:02 PST

*** This bug has been marked as a duplicate of bug 296568 ***

Note You need to log in before you can comment on or make changes to this bug.