Add option "Group Folders" to bookmark sorting to show folders first

VERIFIED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
VERIFIED WONTFIX
11 years ago
9 years ago

People

(Reporter: Andrés Delfino, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112003 Minefield/3.0b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2pre) Gecko/2007112003 Minefield/3.0b2pre

Group Folders would allow to have folders separated from pages in bookmarks menus. Folders would be "grouped" before pages.

Reproducible: Always
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

11 years ago
Ideally, "Group Folders" should change sorting to have its own menu:

Sort
  |---By Name
  |---------------- (separator)
  |---Group Folders (check box)

Updated

11 years ago
Severity: normal → enhancement
Component: Bookmarks → Places
QA Contact: bookmarks → places

Comment 2

11 years ago
A duplicate of 404542 (or vice versa).
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> A duplicate of 404542 (or vice versa).
> 

Please read comments.
(Reporter)

Comment 4

11 years ago
This bug is about an option to tell Firefox to sort folders grouped before users'
bookmarks, as explained in Description.
(Reporter)

Comment 5

11 years ago
The menu shown in Description would appear when right clicking a bookmark or folder. It's compatible with the menu shown in Description of bug 404542.
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Windows Explorer does this automatically.
OS X Finder doesn't provide the functionality.

I don't think that we should be providing an option, but we might want to observe OS standard ways of organizing the view. That would be a seperate bug, though.

This one is WONTFIX. If you want to file a separate bug on always matching the OS standard way of organizing folders within item listing, please go ahead.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Flags: blocking-firefox3? → blocking-firefox3-
Resolution: --- → WONTFIX
> If you want to file a separate bug on always matching the
> OS standard way of organizing folders within item listing, please go ahead.

Filed bug 408775 on this.
(Reporter)

Updated

11 years ago
OS: Windows XP → All
Hardware: PC → All
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.