Closed Bug 404611 Opened 14 years ago Closed 13 years ago

web services review for zh-CN Firefox 3 release

Categories

(Mozilla Localizations :: zh-CN / Chinese (Simplified), defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Future

People

(Reporter: mic, Assigned: shaohua.wen)

References

Details

Attachments

(2 files, 2 obsolete files)

checking default list of web services for search, RSS and new features webcalendar and webmail.

Please advise if any changes should be made for Firefox 3.
here is the list of plug-ins I have
google
yahoo
amazon
baidu
ebay
taobao

can you confirm RSS feed: BBC
confirm RSS readers: my yahoo, bloglines, igoogle
webmail defaults are suggested as Yahoo Mail, GMail, Hotmail 
webcal defaults are suggested as Google Calendar, Yahoo Calendar, Schedule World, icalExchange, 30boxes

thanks
Mic
for the search plugins: I think, for Chinese users, amazon need to be dapted to localized site: amazon.cn

For the other RSS/webmail/webcal things, I don't know how to confirm, can you show me some hints? thanks!
ok on amazon.cn
for your RSS - i can see that you already have blogline, google and yahoo so that's cool
webcal and webmail is a NEW feature. you can get more information about how to do that from these links:
http://wiki.mozilla.org/Firefox3/L10n_Requirements#Web-Based_Protocol_Handling
http://wiki.mozilla.org/Firefox3/ContentManagement:Handlers#Protocols

LMK if that helps
thanks
mic
here's what I have as final list of changes for zh-CN from Jack and Localizer+community, please confirm and add patch:

live bookmark/RSS feed should be: Sina News  http://rss.sina.com.cn/news/marquee/ddt.xml

search engines: Google, Baidu, BaiDu ZhiDao, PaiPai, Amazon, Eachnet (eBay local partner), CC

RSS readers: Bloglines, Google, My Yahoo

mailto and calendar protocols will use defaults
Hardware: PC → All
Attached patch search plugin patch (obsolete) — Splinter Review
Attachment #303668 - Flags: review?(mic)
Whiteboard: needs-gavin
Summary: web services review → web services review for zh-CN Firefox 3 release
Attachment #303668 - Flags: review?(mic) → review?(gavin.sharp)
For the RSS, seems that we have some other options than Sina (e.g. http://www.xinhuanet.com/rss.htm)
Sina's RSS seems not updated frequently.

For the Paipai search engine, since both taobao and paipai doesn't support using firefox to pay, and we are going to remove taobao, I think we should not add paipai either.

For the Baidu Zhidao search engine, I also discussed with some community members, since we already have baidu, it seems a duplication, do we really need this?

If I remember right, Jack may have some ideas about PaiPai compatibility, Jack?

The reason Jack and others had suggested Baidu Zhidao was because the user experience was so different from their general search engine and that community driven search is incredibly popular in China it would justify having both. Jack may have more to say on that...
We have Paipai agreed to test and optimize web pages to be more W3C compatible, sot that decided to have them in. (better than TaoBao in terms of attitude) 

I've discussed with ShaoHua, we both agreed to stay with the list at http://wiki.mozilla.org/Firefox_web_services_Review
Shaohua,
per comment #7, can you create a new patch then?  thanks
Whiteboard: needs-gavin → needs-patch, needs-gavin
Comment on attachment 303668 [details] [diff] [review]
search plugin patch

>Index: browser/profile/bookmarks.html

>-        <DT><A HREF="http://zh-CN.fxfeeds.mozilla.com/zh-CN/firefox/livebookmarks/" FEEDURL="http://zh-CN.fxfeeds.mozilla.com/zh-CN/firefox/headlines.xml" ID="rdf:#$HvPhC3">最新头条</A>
>+        <DT><A HREF="http://zh-CN.fxfeeds.mozilla.com/zh-CN/firefox/livebookmarks/" FEEDURL="http://rss.sina.com.cn/news/marquee/ddt.xml" ID="rdf:#$HvPhC3">新浪新闻</A>

You shouldn't be changing this URL directly. We keep these URLs the same, but change the redirect on the server side. That way we can mitigate if the load is too much for the feed provider to handle. Please remove this change.

I think the correct procedure for requesting these changes are to file a mozilla.org::Server Operations bug, like bug 377873, requesting that the URL be redirected to the new feed, and have Mic approve the new URL.

>Index: browser/searchplugins/baiduzhidao.xml

>+<Url type="text/html" method="GET" template="http://zhidao.baidu.com/q">
>+  <Param name="word" value="{searchTerms}"/>
>+  <Param name="tn" value="ikaslist"/>
>+  <Param name="ct" value="17"/>
>+  <Param name="pn" value="0"/>
>+  <Param name="rn" value="10"/>

Are all of these parameters needed? Have you asked the Baidu people whether they're correct? If you or Mic have contacted them it would be good to put the conclusions in a bug comment.

>Index: browser/searchplugins/list.txt

>+creativecommons

This engine isn't listed at http://wiki.mozilla.org/Firefox_web_services_Review or mentioned in this bug - was this an intentional change?

>Index: browser/searchplugins/paipai.xml

>+<Url type="text/html" method="GET" template="http://search1.paipai.com/cgi-bin/comm_search1">
>+  <Param name="KeyWord" value="{searchTerms}"/>
>+  <Param name="keywordtype" value="goods"/>
>+  <Param name="shoptype" value=""/>
>+  <Param name="sClassid" value=""/>
>+  <Param name="image" value="+"/>
>+  <Param name="sf" value="5"/>
>+  <Param name="ADTAG" value="40.1.1"/>

Same comment about the parameters - would be good to confirm they're all needed/correct.

>\ No newline at end of file

Please add a new line.

I will mark this r- for now, but this patch looks fine otherwise. I will r+ a patch that addresses these comments.
Attachment #303668 - Flags: review?(gavin.sharp) → review-
Whiteboard: needs-patch, needs-gavin → needs-patch
>+creativecommons
I just checked the http://wiki.mozilla.org/Firefox_web_services_Review, in zh-CN section , the last search engine mentioned is "CC", I just guessed it could be Abbreviation of CreativeCommons, maybe Jack could confirm it?

For those parameters, they are reverse engineered by doing a real search through a jmeter proxy server, So I get to know what's been submitted, and put them into the search engine plugin.Currently I don't know who I can contact in baidu and paipai. 
Depends on: 418944
Hello ShaoHua,

CC = Crative Commons
Hello ShaoHua,

For those parameters, can you please contact with Jia, jmi@mozilla.com (I added him on cc list). I remember he worked out them already. 
(In reply to comment #10)
> >+creativecommons
> I just checked the http://wiki.mozilla.org/Firefox_web_services_Review, in
> zh-CN section , the last search engine mentioned is "CC", I just guessed it
> could be Abbreviation of CreativeCommons

Ah, yes, you're right, I just missed it. Sorry about that.

> For those parameters, they are reverse engineered by doing a real search
> through a jmeter proxy server, So I get to know what's been submitted, and put
> them into the search engine plugin.Currently I don't know who I can contact in
> baidu and paipai.

OK. It would be good to confirm with a representative from the search engines if possible.
per comment 12, Jia, it would be best if you could share those parameters in this bug so we have a clear record. thanks
Hi Mic, 

Here is the URI parameters for the search engines:

BaiduSearch:
<Url type="text/html" method="GET" template="http://www.baidu.com/baidu?wd={searchTerms}&amp;tn=monline_dg" />

BaiduZhidaoSearch:
<Url type="text/html" method="GET" template="http://zhidao.baidu.com/q?word={searchTerms}&amp;ct=17&amp;pn=0&amp;pt=monline_ik&amp;tn=ikaslist&amp;rn=10" />

EachnetSearch:
<Url type="text/html" method="GET" template="http://search2.eachnet.com/search/{searchTerms}--0--productlist------basicsearch.html?adid=song_tkisswin_014_search_srp" />

PaipaiSearch:
<Url type="text/html" method="GET" template="http://search.paipai.com/cgi-bin/comm_search?KeyWord={searchTerms}&amp;sf=18" />

Hope this will help
Attachment #303668 - Attachment is obsolete: true
Attachment #304984 - Flags: review?(gavin.sharp)
Can you leave the parameters in <Param> form, rather than putting them all in the <Url> "template" attribute? It makes it much easier to see exactly what parameters exist, and what their values are.
Attachment #304984 - Attachment is obsolete: true
Attachment #305200 - Flags: review?(gavin.sharp)
Attachment #304984 - Flags: review?(gavin.sharp)
Whiteboard: needs-patch → needs-gavin
Comment on attachment 305200 [details] [diff] [review]
updated for Gavin's comment

These changes look good, thanks!

One concern, though: it would be a good idea to confirm the Amazon parameters with Amazon.cn, since you are not using the en-US amazon plugin. You may have already done this, but it isn't listed in the bug. Do they want a Firefox-specific parameter? The en-US Amazon plugin uses <Param name="sourceid" value="Mozilla-search"/> .
Attachment #305200 - Flags: review?(gavin.sharp) → review+
Whiteboard: needs-gavin
here is what we do in other countries for Amazon
http://wiki.mozilla.org/Firefox3/L10n_Requirements#Amazon

I will try and contact Amazon ASAP for the search parameters, if I don't hear form them quickly I'd suggest for B4 we use the en-US parameter and then fix for follow on release (assuming that makes sense Gavin)
(In reply to comment #20)
> I'd suggest for B4 we use the en-US parameter and then fix for follow on release
> (assuming that makes sense Gavin)

Makes sense to me, assuming you're talking about the Mozilla parameter specifically. Amazon.cn appears to use a different search mechanism than the en-US version, so the other en-US parameters are not relevant.

I think we can definitely ship b4 as-is, assuming the plugin is functional when tested in the browser.
Shaohua and Jack - from Comment #3 you were both ok with en-US defaults for mailto and calendar. Calendar includes 30boxes. Are there any zh-CN options for calendar? just double checking
Thanks for asking...But I got no idea about zh-CN options for calendar. 
The default options should be OK.
Here's my list of left-overs:

Eachnet's plugin should be called eachnet, not ebay-zh-CN.

amazondotcom-zh-CN.xml should be called amazondotcn. More importantly, we still don't have confirmed search paramaters for this one, AFAICT.

The removal of yahoo needs a corresponding change in region.properties, removing 
browser.search.order.2 = Yahoo

mailto: and webcal: will be en-US defaults, right? I still see a FIXME in region.properties.
Whiteboard: needs-jack, needs-patch
jack or kev may have the latest on amazon - Jack any ideas?

mailto and webcal - per comment #23, think we're ok unless Jack or others have ideas?
i have pinged Jack on this, we should be ok with amazon.cn the way it is AFAIK they have reviewed what we've done to date and are pleased.

on mailto and webcal we should be ok per an email conversation I had with jack. Shaohua can you confirm you are ok with this and add patch or make changes as needed please. 
The browser.search.order.2 in region.properties is still open, and we're still not done with the search plugins, eachnet.xml and amazondotcn.xml. I want those plugins be named right, so that we have a proper understanding what they're doing.

I have decided that we're going to go for en-US defaults for webcal (30 boxes) and mailto (yahoo mail). Anything else should go into follow-up bugs for 3.0.x.

To make this clear, the missing changes are blockers to shipping zh-CN, please get those worked on, time is running out.
I'm OK
(In reply to comment #27)


Actually, Eachnet has been take over by ebay. www.ebay.com.cn will link to the same address as www.eachnet.com, they should be the same thing from my understanding. If you insist, I can change the file name...

For amazondotcn.xml, I will update the file name ASAP.
Do we need a patch for this?

(In reply to comment #28)
For the browser.search.order.2 in region.properties, maybe Jack can give us an idea.
Yes, please create a patch.

I think it's Jack's or Li's call whether we link to ebay.com.cn or eachnet.com, but we should use the right plugin-in name whichever way.

There's no technical requirement to keep a second ordered search engine, but again, this is on Jack's lap now.
We can use eachnet.com, since ebay.com.cn is also pinting to eachnet.com

Thanks, so then we need a patch to create and use eachnet.xml.

Jack, any comment on search engine ordering for position 2 instead of yahoo, or should we just drop that ordering step?
Please use Baidu for position 2. 
Attachment #314337 - Flags: review?(jguo)
Comment on attachment 314337 [details] [diff] [review]
rename searchplugins

technical review from me on this one.

As soon as you have Jack's review, too, please land this patch with a check-in comment referencing this bug and the reviews, and describing the changes.

Thanks.
Attachment #314337 - Flags: review+
This is O.K.

Thanks. 
Attachment #314337 - Flags: review?(jguo) → review+
checked in.

cvs -z9 commit -m "Bug 404611: web services review for zh-CN Firefox 3 release r=l10n&jguoBug 40461..." -- browser\searchplugins\amazondotcom-zh-CN.xml browser\searchplugins\eBay-zh-CN.xml browser\searchplugins\list.txt browser\chrome\browser-region\region.properties browser\searchplugins\amazondotcn.xml browser\searchplugins\eachnet.xml (in directory E:\holywen\workspace\l10n-trunk\zh-CN\)
Removing browser/searchplugins/amazondotcom-zh-CN.xml;
/l10n/l10n/zh-CN/browser/searchplugins/amazondotcom-zh-CN.xml,v  <--  amazondotcom-zh-CN.xml
new revision: delete; previous revision: 1.1
done
Removing browser/searchplugins/eBay-zh-CN.xml;
/l10n/l10n/zh-CN/browser/searchplugins/eBay-zh-CN.xml,v  <--  eBay-zh-CN.xml
new revision: delete; previous revision: 1.4
done
Checking in browser/searchplugins/list.txt;
/l10n/l10n/zh-CN/browser/searchplugins/list.txt,v  <--  list.txt
new revision: 1.12; previous revision: 1.11
done
RCS file: /l10n/l10n/zh-CN/browser/searchplugins/amazondotcn.xml,v
done
Checking in browser/searchplugins/amazondotcn.xml;
/l10n/l10n/zh-CN/browser/searchplugins/amazondotcn.xml,v  <--  amazondotcn.xml
initial revision: 1.1
done
RCS file: /l10n/l10n/zh-CN/browser/searchplugins/eachnet.xml,v
done
Checking in browser/searchplugins/eachnet.xml;
/l10n/l10n/zh-CN/browser/searchplugins/eachnet.xml,v  <--  eachnet.xml
initial revision: 1.1
done
Checking in browser/chrome/browser-region/region.properties;
/l10n/l10n/zh-CN/browser/chrome/browser-region/region.properties,v  <--  region.properties
new revision: 1.19; previous revision: 1.18
done

***** CVS exited normally with code 0 *****
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: needs-jack, needs-patch
You need to log in before you can comment on or make changes to this bug.