History sidebar should show stars and tags

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
11 years ago
5 years ago

People

(Reporter: Jared Stafford, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b1) Gecko/2007110903 Firefox/3.0b1

The history sidebar currently does not indicate starred pages. I think this would be helpful, since starring too many pages without actually adding them as bookmarks causes older ones to be bumped off the places menu. Also, maybe the history could have a view option to only view starred items.

Reproducible: Always
Confirming as a new feature request. Seems a desirable feature. I did a search but couldn't find an obvious dupe.
Status: UNCONFIRMED → NEW
Component: History → Places
Ever confirmed: true
OS: Linux → All
QA Contact: history → places
Hardware: PC → All
Version: unspecified → Trunk

Comment 2

11 years ago
Created attachment 290205 [details] [diff] [review]
add star to the history panel

this is an attempt to implement that, it is working fine, but i'm not sure it is the right place to set the image (maybe a css should be used?) and if 40px fixed width is fine for the column. 
I'm waiting for input before asking review...

Comment 3

11 years ago
Created attachment 290206 [details] [diff] [review]
Show star in the history sidebar
Attachment #290205 - Attachment is obsolete: true

Comment 4

11 years ago
in Bug 405549 Beltzner said "The history sidebar should show stars and tags like the locationbar drop down does, but the bookmarks sidebar should just show tags."
updating title to indicate it should also show tags
Summary: History sidebar should show stars → History sidebar should show stars and tags

Updated

11 years ago
Attachment #290206 - Attachment filename: history-panel-star.patch → show stars in the history sidebar

Updated

11 years ago
Attachment #290206 - Attachment description: fix the constant definition... → Show star in the history sidebar
Attachment #290206 - Attachment filename: show stars in the history sidebar → history-panel-star.patch

Comment 5

11 years ago
note: implementing a star column could be unified with bug 387747

questions:
1. column type should be called COLUMN_TYPE_BOOKMARKED or COLUMN_TYPE_STARRED?
2. should the star be clickable or only an indicator?
3. should unstarred items show empty stars or nothing (connected to 2.)
4. there is a better way of getting the chrome star icon than hardcoding its url?
5. should star column come before or after title? if it comes before will be strange when grouped since there will be 2 icons after the group glyph and then the title
Marco, is there any ongoing work on this bug?
Assignee: nobody → mak77
Status: NEW → ASSIGNED

Comment 7

10 years ago
Alex has marked as a WONTFIX the library starring ui so i doubt if also this is somehow a WONTFIX. needs ui def
Keywords: uiwanted
(In reply to comment #7)
> Alex has marked as a WONTFIX the library starring ui so i doubt if also this is
> somehow a WONTFIX. needs ui def

Alex, any related comments from your side?
Personally I think instead of spending too many cycles on the history sidebar we should get started on completely redesigning our history UI.  The sidebar is a pretty ineffective way to find something out of your history.
Alex, a complete rewrite would take its time. We already have a patch on hand on this bug? Shouldn't we try to get this in? I believe that would be a nice improvement to see already bookmarked pages.
Can you attach a screen shot so I can get a sense of how the UI changes with this patch?

Updated

10 years ago
Whiteboard: [needs UX definitions]
unassigning, sidebar needs a redesign, no reason to take temporary hacks
Assignee: mak77 → nobody
Keywords: uiwanted
Whiteboard: [needs UX definitions]

Updated

9 years ago
Status: ASSIGNED → NEW
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
considered the sidebar is "old-style" technology that we are evaluating to remove, this is not worth the time.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 15

5 years ago
Now when screens are wide, is it not a time to *start* using sidebars?
You need to log in before you can comment on or make changes to this bug.