Using classic mode in windows, left hand side of address/URL bar and search bar look wrong

RESOLVED FIXED

Status

()

Firefox
Shell Integration
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: stevee, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
Created attachment 290700 [details]
top screenshot before bug 398020, bottom screenshot after

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007112805 Minefield/3.0b2pre ID:2007112805

Check the screenshot. In Windows Classic mode, the URL bar and search bar looks strange, like it's trying to be 3D but failing.

Looks normal: 20071123_2127_firefox-3.0b2pre.en-US.win32
Looks naff: 20071123_2208_firefox-3.0b2pre.en-US.win32

Checkins to module PhoenixTinderbox between 2007-11-23 21:27 and 2007-11-23 22:07 : 
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1195882020&maxdate=1195884479

--> bug 398020

Comment 1

10 years ago
Do you mean the textfields themselves or the favicon and search engine boxes?
(Reporter)

Comment 2

10 years ago
Morphing bug to cover the fact that the left hand side of the address bar and the left hand side of the search bar doesn't really fit.
Summary: Using classic mode in windows, address/URL bar and search bar look wrong → Using classic mode in windows, left hand side of address/URL bar and search bar look wrong

Comment 3

10 years ago
Created attachment 298965 [details] [diff] [review]
patch

Gavin: this is what I was referring to in bug 413312 comment 4.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #298965 - Flags: review?(gavin.sharp)

Comment 4

10 years ago
Created attachment 298966 [details]
screenshot
Comment on attachment 298965 [details] [diff] [review]
patch

>Index: browser/themes/winstripe/browser/browser.css

> #urlbar > .autocomplete-history-dropmarker:hover {
>   background-color: -moz-dialog !important;
>+  background-image: url(chrome://browser/skin/tabbrowser/tab-active-bkgnd.png);

I wonder if it will perhaps upset themers that overriding that image will affect both the tab bar and location bar?

>Index: browser/themes/winstripe/browser/searchbar.css

> .searchbar-engine-button {

>+  background-image: url(chrome://browser/skin/tabbrowser/tab-active-bkgnd.png);
>+  background-repeat: repeat-x;

For some reason that I don't fully understand, this styling doesn't apply to the button when there's a search engine to install (e.g. at any site that has an advertised search plugin, technorati.com and b.m.o).

Comment 6

10 years ago
(In reply to comment #5)
> I wonder if it will perhaps upset themers that overriding that image will
> affect both the tab bar and location bar?

I can't think of such an image for the tabs that would look totally out of place for these button-like elements in the nav toolbar. I guess many themers don't particularly care about Windows Classic, so this would just work out of the box (and could therefore be considered a feature). Those who do care can change it easily.
Alternatively, we could package the same image twice or rename the existing image to something more generic. Doesn't really sound appealing to me.

> For some reason that I don't fully understand, this styling doesn't apply to
> the button when there's a search engine to install (e.g. at any site that has
> an advertised search plugin, technorati.com and b.m.o).

Could it be that you accidentally added the background image to |.searchbar-engine-button > .button-box| rather than |.searchbar-engine-button|? |.searchbar-engine-button[addengines="true"] > .button-box| is where we add the blue coma, which would replace a previously set background image.

Updated

10 years ago
Attachment #298965 - Attachment is obsolete: true
Attachment #298965 - Flags: review?(gavin.sharp)

Updated

10 years ago
Assignee: dao → nobody
Status: ASSIGNED → NEW

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 414183
Resolution: --- → FIXED
(Reporter)

Comment 7

10 years ago
Created attachment 307262 [details]
address bar now with rounded end

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030405 Minefield/3.0b5pre ID:2008030405

Still doesn't look right to me dao. The inside bevel color is missing (compare the left hand side of the search bar).

Comment 8

10 years ago
Yes, it's round as per bug 414183. We don't draw the inside bevel because the theme code doesn't know about your OS theme. We could handle Windows 2000 as a special case, but that doesn't help Win XP/Vista Classic, which are more important targets.
(Reporter)

Comment 9

10 years ago
Yes, I filed this bug against win2k, but I'm on XP now (where the screenshot was taken from).
You need to log in before you can comment on or make changes to this bug.