Last Comment Bug 406848 - change mail.prompt_purge_threshhold to true
: change mail.prompt_purge_threshhold to true
Status: RESOLVED DUPLICATE of bug 341206
: dataloss, privacy
Product: Thunderbird
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: All All
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 152675
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-04 13:10 PST by T. Six
Modified: 2008-09-04 13:07 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description T. Six 2007-12-04 13:10:21 PST
User-Agent:       Mozilla/5.0 (rv:1.8.1.10) Gecko/20071022 GNU/Linux Firefox/2.0.0.10
Build Identifier: Version 2.0.0.6 (20071022)

With a recent thread on ML i came again across a problem with Thunderbird
that i had myself 1 or 2 years ago.

Thunderbird uses mailbox files to store mails and an aditionally *.msf file
for meta data of that mbox-file.
Now when you delete a mail in TB it only disappears in the mail pane but is
still physically stored on harddisc in the mbox.
To really delete a mail then s.o. has to "compact" that folder.

New users (or those not interrested in technic) wont notice that and then the
profile folder can become very large.
In the specific thread the OP had mails back from 2005 still in his profile
which had grown up to 2 gig.
2 gig is approximately where we come to filesystem limitations (max size per
file)

Now to prevent that i call for commend on change the default of:
pref("mail.prompt_purge_threshhold", false);

to
pref("mail.prompt_purge_threshhold", true);

that way a user gets a dialog when the threshold (default is 100kB iirc) is
reached and gets asked to "compact" (read as really physically delete all
previous in TB deleted mails) that folder.


I have searched bugzilla.mozilla.org for bugs like that and coulnd´t find
one. Also on launchpad is no similar bug report it seems.

So i would like to know is it feasible to solve that somehow?

Reproducible: Always

Steps to Reproduce:
1. send lots of mails
2. delete them in Thunderbird
3. check size of profile directory
Actual Results:  
with default settings the profile is growing and growing, even when a user delets his mails in Thunderbird.

Expected Results:  
pref("mail.prompt_purge_threshhold", true);

delete mails physicaly after the default threshold (performance)
Comment 1 T. Six 2007-12-05 13:31:15 PST
i reported this bug also in Ubuntu, since that's the distri i use.

that bug has some information important to here:
https://bugs.launchpad.net/ubuntu/+source/mozilla-thunderbird/+bug/174207/comments/1

https://bugs.launchpad.net/ubuntu/+source/mozilla-thunderbird/+bug/174207/comments/7

this quote is from:
http://kb.mozillazine.org/Compacting_folders#How_to_compact_folders
Comment 2 Magnus Melin 2007-12-06 04:14:03 PST
Basically tb version of bug 205756, also see bug 286888.
Comment 3 Daniel Veditz [:dveditz] 2008-09-04 12:33:16 PDT
Confirming rather than duping to bug 205756 since that's morphed into the Seamonkey version.

Tagging "privacy" because we regularly hear from users horrified to find their "deleted" private mails are still sitting on their disk (often found after having them imported into another progam).

Tagging "dataloss" because of the max file-size and/or quota issues raised in comment 0.
Comment 4 Daniel Veditz [:dveditz] 2008-09-04 13:07:49 PDT
Found an earlier version

*** This bug has been marked as a duplicate of bug 341206 ***

Note You need to log in before you can comment on or make changes to this bug.