If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Show "This article applies to" info for Firefox version and OS

RESOLVED WONTFIX

Status

support.mozilla.org
Knowledge Base Software
RESOLVED WONTFIX
10 years ago
6 years ago

People

(Reporter: djst, Unassigned)

Tracking

unspecified
Future
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
At the top of an article, there should be a text specifying what versions of Firefox and what OSes the article applies to.

Basic text mockup (will attach a screenshot mockup later):

Applies to: [x] Firefox 2  [x] Firefox 3
Operating Systems: [x] Windows  [ ] Mac OS X  [ ] Linux

This requires five categories, and also UI to check/uncheck these categories when editing an article.

We shouldn't be more detailed than this, in my opinion. Adding categories for e.g. Windows XP, Windows Vista, etc will only clutter the information and reduce its usefulness.

In the future, this should also be used to filter search results based on OS and version of Firefox, but that's a separate bug.

Comment 1

10 years ago
is this going to be merged into bug 388960?
No, but it can be based on the additional categories we have set up. (at least the Firefox version part)
(Reporter)

Updated

9 years ago
Target Milestone: --- → 1.0

Updated

9 years ago
Duplicate of this bug: 413192
If bug 413192 is a dupe of this, then we need to create additional categories for each OS.
(Reporter)

Comment 5

9 years ago
Yes we probably do, but let's figure out the right solution first.
(Reporter)

Comment 6

9 years ago
OK, so here's my proposed solution to this:

1. Add categories for the OSes (Windows, Linux, Mac) similar to how we already have categories for the Fx versions.
2. Make the SHOWFOR items only show the items corresponding to the selected categories. Make them always show, even if SHOWFOR isn't used in the article, but only use links on the items that are being used. E.g. if only the OS SHOWFOR filters are being used, make the Firefox version selections black and unlinked, but keep the OS filters linked and automatically detected.
3. Change heading and layout.

The current layout is:

-----------------------------------
[ Actions                         ]
[     * Print                     ]
[     * Edit this page            ]
[     * Translate this page       ]
[                                 ]
[ Show content customized for:    ]
[     * Windows | Linux | Mac OS  ]
[     * Firefox: 2.0 | 3.0 | 3.1  ]
-----------------------------------


Proposed new layout:

-----------------------------------
[ This article applies to:        ]
[     * Windows | Linux | Mac OS  ]
[     * Firefox: 2.0 | 3.0 | 3.1  ]
[                                 ]
[ Actions                         ]
[     * Print                     ]
[     * Edit this page            ]
[     * Translate this page       ]
-----------------------------------


One potential problem with this proposal is that the heading "This article applies to" doesn't hint that people can click on the visible items to customize the view. Suggestions on how to make that obvious welcome. 

Maybe the fact that the selections are links is a sufficient hint. If not, one way is to add a small text under the options, e.g. 

-----------------------------------
[ This article applies to:        ]
[     * Windows | Linux | Mac OS  ]
[     * Firefox: 2.0 | 3.0 | 3.1  ]
[                                 ]
[     Some subtle text explaining ]
[     how to use SHOWFOR.         ]
[                                 ]
[ Actions                         ]
[     * Print                     ]
[     * Edit this page            ]
[     * Translate this page       ]
-----------------------------------
(Reporter)

Comment 7

9 years ago
Created attachment 361754 [details]
Mockup of new layout
(Reporter)

Comment 8

9 years ago
Created attachment 361756 [details]
Mockup with text description

Here's how it could look like with a short description of how to use SHOWFOR. Note that if we want to use a description like this, it should only be shown if the article is actually using SHOWFOR. Otherwise, the text should be hidden, and the selections should be plain text rather than links.
Just a minor note: In the editor we currently have 2 categories on the left and 6 on the right, which looks very odd <http://ilias.ca/sumo/082-editor.png>. I agree with adding 3 more, but we should see if there's anything we can do to address aesthetics of the editor.
(In reply to comment #8)
> Created an attachment (id=361756) [details]
> Mockup with text description

Looks good, but would you object to putting the extra text under the selectors rather than under "this article applies to?" I think people will still see it there but it won't interrupt the original message.
(Reporter)

Comment 11

9 years ago
Created attachment 362691 [details]
Mockup with text description below selectors

(In reply to comment #10)
> 
> Looks good, but would you object to putting the extra text under the selectors
> rather than under "this article applies to?" I think people will still see it
> there but it won't interrupt the original message.

This is how that would look like.
I do like that much better, myself.
For clarification: What happens if someone visits an article that does not apply to them? For instance, if a Firefox 3.0 user visits <http://support.mozilla.com/kb/Private+Browsing>.
(Reporter)

Comment 14

9 years ago
(In reply to comment #13)
> For clarification: What happens if someone visits an article that does not
> apply to them? For instance, if a Firefox 3.0 user visits
> <http://support.mozilla.com/kb/Private+Browsing>.

The automatic detection will still detect that the user is running 3.0 and display the notification that's already included in that article.

The "This article applies to" section will, however, only show 3.1 since that's the only category that is selected.

(In reply to comment #12)
> I do like that much better, myself.

What I'm still not sure of is whether we need this description at all, or if the fact that the labels are links (and colored as such) is a sufficient hint. Cc'ing Neil for UX feedback.

Updated

9 years ago
Depends on: 480566

Updated

9 years ago
Target Milestone: 1.0 → 1.1
Given the way the additional categories make the editor look (see bug 480566), should we delay this until the new article editor is being implemented?
(Reporter)

Comment 16

9 years ago
Bug 480566 should depend on a slight touchup of the way we present categories. I don't see this being blocked by a complete article editor refresh.
Filed bug 481971
(Reporter)

Comment 18

9 years ago
No time for this for 1.1. :(
Target Milestone: 1.1 → Future

Updated

8 years ago
Depends on: 482840

Comment 19

6 years ago
I don't think we need it anymore with the fast release cycle, the Firefox version/OS selectors and warnings in articles that apply only to some Firefox versions or OSes.
We will be doing *something* like this, as part of the bigger UX overhaul, but the specifics don't really look anything like this anymore.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.