Strange behavior in the suggestion panel while typing RTL text in the address bar

RESOLVED DUPLICATE of bug 402118

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 402118
11 years ago
9 years ago

People

(Reporter: tomer, Unassigned)

Tracking

(Blocks: 1 bug, {rtl})

Trunk
Firefox 3 beta3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 292681 [details]
Shoshanna's screenshot. Note the position of each marked suggestion term.

The folks in Mozilla-IL discovered a regression while typing Hebrew (or any other RTL characters) in the address bar. The suggested items are not bidi-aware. 

Steps to reproduce: 
a. Enter any site with Hebrew title in it (such as the Hebrew Wikipedia at he.wikipedia.org).
b. Type in the address bar text that exist in that page (the string "עמוד ראשי" is the title of that page).
c. The suggestion string dance.

Tested environments:
Firefox3b2pre on Linux and OSX, both in he-IL and en-US.
(Reporter)

Updated

11 years ago
Component: he-IL / Hebrew → Places
Product: Mozilla Localizations → Firefox
QA Contact: hebrew.he → places
Target Milestone: --- → Firefox 3 M11
Version: unspecified → Trunk
(Reporter)

Updated

11 years ago
Flags: blocking-firefox3?
Component: Places → Location Bar and Autocomplete
QA Contact: places → location.bar
Is this a dupe of bug 402118?
(Reporter)

Comment 2

11 years ago
oops?

Marking as dupe.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402118

Updated

11 years ago
Flags: blocking-firefox3?
(Reporter)

Updated

10 years ago
Blocks: 415606

Updated

10 years ago
Blocks: 412273

Updated

10 years ago
Blocks: 415597

Updated

10 years ago
No longer blocks: 412273

Comment 3

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl

Updated

10 years ago
No longer blocks: 415606

Updated

10 years ago
Blocks: 412273

Updated

9 years ago
No longer blocks: 415597

Updated

9 years ago
Blocks: 285718
You need to log in before you can comment on or make changes to this bug.