Closed Bug 409242 Opened 12 years ago Closed 11 years ago

Fix test from bug 407937

Categories

(Toolkit :: XUL Widgets, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 487631

People

(Reporter: enndeakin, Assigned: enndeakin)

References

Details

Attachments

(1 file)

Attached patch fixes issuesSplinter Review
This fixes a number of issues with the hastily written test for bug 407937

- rounds the position numbers
- uses the if/else blocks properly
- remove a couple of menuitems so that the menu fits into the little test iframe
- when appending menuitems, append a lot more to ensure that it is larger than the screen for large monitors
- also fixes test_popup_scaled.xul to reset the scale after the test so as not to affect later tests
Attachment #294067 - Flags: review?(mano)
Assignee: nobody → enndeakin
Comment on attachment 294067 [details] [diff] [review]
fixes issues

Test only changes
Attachment #294067 - Flags: approval1.9?
Comment on attachment 294067 [details] [diff] [review]
fixes issues

Approval isn't require for tests.
Attachment #294067 - Flags: approval1.9?
s/require/required/
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
I suspect this caused win2k03 to turn orange with failures in these tests, so I backed it out. (It turned red immediately after this was checked in due to box sickness, and the failures showed up several hours later when the box was kicked.)

*** 45373 ERROR FAIL | mouse click on trigger after_start position |  | /tests/toolkit/content/tests/widgets/test_popup_button.xul
*** 45425 ERROR FAIL | open popup anchored after_start position |  | /tests/toolkit/content/tests/widgets/test_popup_button.xul
*** 45432 ERROR FAIL | open popup anchored after_end position |  | /tests/toolkit/content/tests/widgets/test_popup_button.xul
*** 45488 ERROR FAIL | open popup anchored with attribute after_start position |  | /tests/toolkit/content/tests/widgets/test_popup_button.xul
*** 45495 ERROR FAIL | open popup anchored with attribute after_end position |  | /tests/toolkit/content/tests/widgets/test_popup_button.xul
*** 45658 ERROR FAIL | open popup with open property after_start position |  | /tests/toolkit/content/tests/widgets/test_popup_button.xul
*** 45762 ERROR FAIL | large menu top |  | /tests/toolkit/content/tests/widgets/test_popupincontent.xul
*** 45763 ERROR FAIL | large menu bottom |  | /tests/toolkit/content/tests/widgets/test_popupincontent.xul
*** 45768 ERROR FAIL | shorter menu again height shortened | got 0, expected 74 | /tests/toolkit/content/tests/widgets/test_popupincontent.xul
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
winxp01 has been showing failures in these tests too, intermittently all day:

*** 45762 ERROR FAIL | large menu top |  | /tests/toolkit/content/tests/widgets/test_popupincontent.xul
*** 45763 ERROR FAIL | large menu bottom |  | /tests/toolkit/content/tests/widgets/test_popupincontent.xul
*** 45768 ERROR FAIL | shorter menu again height shortened | got -1, expected 74 | /tests/toolkit/content/tests/widgets/test_popupincontent.xul
> - also fixes test_popup_scaled.xul to reset the scale after the test so as not
> to affect later tests

I just retracked this down... it's causing at least one test failure for me.  Can at least this part re-land?
I fixed this as part of bug 487631.
Status: REOPENED → RESOLVED
Closed: 12 years ago11 years ago
Flags: in-testsuite+
Resolution: --- → DUPLICATE
Duplicate of bug: 487631
You need to log in before you can comment on or make changes to this bug.