Last Comment Bug 409845 - [Mac] 'Preferences' and 'Quit Thunderbird' are disabled in Calendar mode and Task mode
: [Mac] 'Preferences' and 'Quit Thunderbird' are disabled in Calendar mode and ...
Status: VERIFIED FIXED
:
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: 0.9
Assigned To: Berend Cornelius
:
:
Mentors:
: 418370 428143 429502 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-26 07:00 PST by Shinya Kuribayashi
Modified: 2010-10-19 10:35 PDT (History)
13 users (show)
dbo.moz: blocking‑calendar0.9+
dbo.moz: wanted‑calendar0.9+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch v. #1 (6.91 KB, patch)
2008-07-23 07:56 PDT, Berend Cornelius
dbo.moz: review+
Details | Diff | Splinter Review
patch v. #2 (1.52 KB, patch)
2008-07-24 06:28 PDT, Berend Cornelius
dbo.moz: review+
Details | Diff | Splinter Review

Description Shinya Kuribayashi 2007-12-26 07:00:11 PST
Thunderbird 2.0.0.9 + local Lightning 0.8pre build from the latest MOZILLA_1_8_BRANCH,

Steps to Reproduce:
1. Change to Calendar mode or Task mode
2. Press COMMAND+','  , but Preference dialogue doesn't apper.
3. Select Thunderbird -> Preferences..., ditto.
4. Press COMMAND+'q', but Thunderbird doesn't shut down.
5. Select Thunderbird -> Quit Thunderbird, ditto.

Other menus seem to work. I don't know whether this is expected behavior or not of Lightning 0.8pre.
Comment 1 Gary Kwong [:gkw] [:nth10sd] 2008-01-10 05:27:09 PST
Reporter, could you please provide more info on the language of localization for the devs to replicate?

Also, do test with the latest nightlies and post the build ID (date of build etc). Thanks!
Comment 2 Gary Kwong [:gkw] [:nth10sd] 2008-01-10 08:16:30 PST
And on today's test date, I confirm this bug.

Tested on a fresh profile, latest nightly (10 Jan 08 Lightning; TB 2.0.0.9). I had to run with Rosetta due to nightlies for PPC.

More investigation shows that any attempt to access preferences (no matter through mouse or keyboard) doesn't seem to succeed, and this only happens in calendar mode.
Comment 3 Gary Kwong [:gkw] [:nth10sd] 2008-01-10 08:31:03 PST
but everything works correctly again when back to mail mode.
Comment 4 Simon Paquet [:sipaq] 2008-02-08 04:58:06 PST
This does not block the 0.8 release.
Comment 5 daniel 2008-02-18 09:12:16 PST
can confirm this bug in 17-Feb-2008 Nightly build
Comment 6 Andreas Treumann 2008-02-19 01:56:08 PST
*** Bug 418370 has been marked as a duplicate of this bug. ***
Comment 7 Dan Mosedale (:dmose) 2008-04-02 12:30:25 PDT
Because this feels like pretty major functionality loss, it should at least be relnoted, I think.  I'm assuming that it can be worked around just by switching back to mail mode.
Comment 8 Matthew (lilmatt) Willis 2008-04-02 13:38:40 PDT
(In reply to comment #7)
You assume correctly.  Once you switch back to Mail, the menu items and shortcut keys all work again.
Comment 9 Simon Paquet [:sipaq] 2008-04-02 15:27:26 PDT
relnote added
Comment 10 Stefan Sitter 2008-04-10 00:39:43 PDT
*** Bug 428143 has been marked as a duplicate of this bug. ***
Comment 11 Shinya Kuribayashi 2008-04-15 09:57:49 PDT
I managed to tracked down with ppc mac-xpi binary using Rosetta. 

Regression range: Works in Lightning 0.8pre (2007-11-29-03)
                  Fails in Lightning 0.8pre (2007-11-30-04)

Checkins during regression range: http://tinyurl.com/4cnfxa

Hope this helps.
Comment 12 Stefan Sitter 2008-04-17 08:29:25 PDT
*** Bug 429502 has been marked as a duplicate of this bug. ***
Comment 13 Berend Cornelius 2008-07-23 07:56:05 PDT
Created attachment 330930 [details] [diff] [review]
patch v. #1

I added some special treatment for the mentioned menuitems.
Comment 14 Daniel Boelzle [:dbo] 2008-07-23 08:20:23 PDT
Comment on attachment 330930 [details] [diff] [review]
patch v. #1

add
+#ifdef XP_MACOSX
>+var quitMenu = null;
>+var prefMenu = null;
#endif

works on Mac; r=dbo
Comment 15 Berend Cornelius 2008-07-23 08:45:56 PDT
patch checked in on trunk and MOZILLA_1_8_BRANCH

-> FIXED
Comment 16 Andreas Treumann 2008-07-23 23:52:57 PDT
Checked in nightly build 2008072321 -> bug is not fixed correctly

STR
===

- start thunderbird
- switch to calendar/task mode
- switch back to mail mode
- try to open the preferences dialog via menu or COMMAND+',' -> nothing happens ( same with 'Quit Thunderbird' or COMMAND+'q')

Without calendar/task mode switch it is possible to use the commands in mail mode. 
Comment 17 Berend Cornelius 2008-07-24 06:28:48 PDT
Created attachment 331089 [details] [diff] [review]
patch v. #2

This additional patch should fix it...
Comment 18 Berend Cornelius 2008-07-24 06:48:58 PDT
patch v. #3 checked in on trunk and MOZILLA_1_8_BRANCH

->FIXED
Comment 19 Andreas Treumann 2008-07-24 23:05:01 PDT
Checked again with nightly build 2008072420 -> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.