Favicon not used for some feeds after visiting an entry

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
P4
normal
RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: Brian Polidoro, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
For some feeds the favicon of the site is not used for the livemark entries after visiting that entry.  

A couple of feeds that don't work anymore are slashdot and the bbc headlines feed present in new profiles.  

Other feeds like Digg and Planet Mozilla still work.

This goes back to the end of the hourly archive so I couldn't narrow it down more:
12-21 nightly works
12-21 1836 broke
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-12-21+04%3A00%3A00&maxdate=2007-12-21+17%3A09%3A00&cvsroot=%2Fcvsroot
Flags: blocking-firefox3?
(Reporter)

Comment 1

10 years ago
bonsai time wasn't quite right:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-12-21+04%3A00%3A00&maxdate=2007-12-21+18%3A36%3A00&cvsroot=%2Fcvsroot
(Reporter)

Updated

10 years ago
Duplicate of this bug: 412290
(Reporter)

Updated

10 years ago
Duplicate of this bug: 413990
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P3

Updated

10 years ago
Priority: P3 → P4
Not blocking on this bug for final ship. Would take a safe enough patch if one comes through.
Flags: wanted-firefox3+
Flags: blocking-firefox3-
Flags: blocking-firefox3+
(Reporter)

Updated

10 years ago
Blocks: 400544
(Reporter)

Updated

9 years ago
OS: Windows XP → All
(Reporter)

Updated

9 years ago
Duplicate of this bug: 445116
(Reporter)

Comment 6

9 years ago
This suddenly works for Slashdot but I think that may be because of something like they changed their favicon.  

Changing the URL field to the default headlines feed from the BBC which still doesn't work.  
The BBC feeds seem to be working for me now in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081010 Minefield/3.1b2pre

Comment 8

9 years ago
For what it's worth, when this bug showed up, among my feeds, it broke the favicon appearance of the Opera Desktop Team RSS (http://my.opera.com/desktopteam/), as well as the Burning Edge one (http://www.squarefree.com/burningedge/).
Now, the Opera favicons show up again, but the Burning Edge ones still don't.
The Burning Edge site does not appear to use favicons at all. Presumably this would be why none show up in RSS feeds entries?

Comment 10

9 years ago
You're right, I thought there was one before...
I guess default read/unread icons could be chosen for favicon-less sites, but that's another issue.
is this still reproduceable? any valid STR around?
This now WORKSFORME on all feeds that were previously busted for me.
(Reporter)

Comment 13

9 years ago
Is there a file size limit for the favicon like there was with FF2?  

I'm thinking in this case the sites changed their favicons to one that works.  I'm kicking myself for not trying to save and attach a favicon when filing the bug.
(In reply to comment #13)
> Is there a file size limit for the favicon like there was with FF2?  

yes, but we usually try to convert the favicon to a 16*16 png if it's bigger than 1024B, if the conversion fails we still save the favicon until it is smaller than 10KB, if that's bigger we don't save it.
At least the favicon on http://www.squarefree.com seems to be broken. Brian could this be something you have been seen when you filed that bug? Or did the favicon show up perfectly in the location bar?
(Reporter)

Comment 16

9 years ago
Like comment 9 says it doesn't look like squarefree has a favicon. I don't see one in IE7 or Opera either.

When I go directly to http://www.squarefree.com/favicon.ico I get this: <The image “http://www.squarefree.com/favicon.ico” cannot be displayed, because it contains errors.> Opera prompts me to download the file.  IE7 says "No favicon.".

So that looks like a corrupt icon or something like that.
I spoke to soon in comment 12. It appears in the latest nightly Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081029 Minefield/3.1b2pre the BBC favicons do not appear again. 

Some discussion on issues with live bookmarks with this build at http://forums.mozillazine.org/viewtopic.php?f=23&t=924795&st=0&sk=t&sd=a&start=15
(In reply to comment #11)
> is this still reproduceable? any valid STR around?

1. Go to http://news.bbc.co.uk
2. Bookmarks menu, 'subscribe to this page'
3. Subscribe using live bookmarks.
4. Add to bookmarks menu.

Will add a screenshot of the BBC feed with visited entries showing the BBC favicon. Using nightly build 20081029 built from http://hg.mozilla.org/mozilla-central/rev/5bd6876be7f2 no further favicons are added when unread feeds are read.
Created attachment 345332 [details]
BBC feed showing favicons that stopped working on 08-10-29
The problems in the 08-10-29 build was caused bug 462379. This now WORKSFORME again.
Hardware: x86 → All
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Updated

6 years ago
Depends on: 613588
we don't use anymore the page icons, the new status uses visited coloring and so this should be fixed by bug 613588
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.