when a place matches the url bar autocomplete due to a tag, show the bookmark title (instead of the page title) in the result

RESOLVED DUPLICATE of bug 416211

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 416211
11 years ago
11 years ago

People

(Reporter: Seth Spitzer, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
when a place matches the url bar autocomplete due to a tag, show the bookmark title (instead of the page title) in the result

see also bug #411452:  when a url bar search term is in both the place title and the bookmark title, show the bookmark title in the result

The fix for this would be to both the SQL we use for mDBTagAutoCompleteQuery (see CreateAutoCompleteQueries()) and to the query we build up when the search term is multiple words (see utoCompleteTagsSearch())

additionally, we will need to fix the code that calls AppendMatch() for tag matches to be similar to the code that calls AppendMatch() for non-tag matches.
This will be fixed by bug 401660.
Depends on: 401660
Duping to bug 416211 which has a testcase.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 416211
You need to log in before you can comment on or make changes to this bug.