fixed and new Hungarian dictionary add-ons

VERIFIED FIXED

Status

VERIFIED FIXED
11 years ago
3 years ago

People

(Reporter: nemeth, Assigned: morgamic)

Tracking

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2) Gecko/2007121016 Firefox/3.0b2

1. Mozilla Add-on site contains a bad and badly licensed Hungarian dictionary add-on. The original MySpell dictionary (except its license) has been replaced with the incompatible Hunspell version in the add-on version 1.1.3.
The result is unacceptable spell checking in Firefox 2, see Bug 392011.
Also this add-on is old for Firefox 3 beta.

I have made two new Add-on, a fix for Firefox 2, and a Hunspell version (for Firefox 3 beta):

http://downloads.sourceforge.net/magyarispell/hungarian_dictionary-1.1.3.1-fx+zm+tb.xpi
http://downloads.sourceforge.net/magyarispell/hungarian_dictionary-1.1.4-fx+zm+tb.xpi

I tried to upload them, but I've got the "you don't have the permission to update this add-on" message. We need to replace the bad add-on with the new ones on Mozilla dictionary page.

2. We ask to add default Hungarian spelling dictionary to the localized version of Firefox and Thunderbird. The license of the Hungarian dictionary has been changed to LGPL/GPL/MPL tri-license on your request.


Reproducible: Always

Steps to Reproduce:
1/1. Install Hungarian dictionary add-on version 1.1.3 from https://addons.mozilla.org/en-US/firefox/browse/type:3 in Firefox 2.
1/2. Set Hungarian language in the context menu of a text area
1/3. Write the following Hungarian words in the text area: elmegy,  lenéz,  széttép,  kiszalad.

2/1. Install a localized Hungarian Firefox 2 (unfortunately, there is no localized 3 beta).

Actual Results:  
1. The words are underlined, and the spell checker suggests "el megy", "le néz" etc.

2. There is no Hungarian spell checking in Hungarian Firefox 2: see languages menu item of text are context menu.

Expected Results:  
1. Recognize elmegy, lenéz, etc. common Hungarian words. 

2. There is default Hungarian spell checking in Hungarian versions of Mozilla products.
Status: UNCONFIRMED → NEW
Component: Extension Compatibility → Add-ons
Ever confirmed: true
Product: Firefox → addons.mozilla.org
QA Contact: extension.compatibility → add-ons
(Reporter)

Comment 1

11 years ago
The second part of this issue (default spelling dictionaries in localized versions) needs a global solution: more and more MPL licensed spelling dictionaries will be there (we have already Hungarian, Polish, Arabic etc.).
Summary: bad Hungarian dictionary add-on and missing Hungarian spell checking dictionary in the localized versions of Firefox and Thunderbird → change Hungarian dictionary add-on, also add to the localized versions of Firefox and Thunderbird
(Reporter)

Updated

11 years ago
Severity: normal → major

Comment 2

11 years ago
File a separate bug on the Hungarian localization? https://bugzilla.mozilla.org/enter_bug.cgi?product=Mozilla%20Localizations

It'd be good to update http://wiki.mozilla.org/L10n:Dictionaries#Hungarian, too, as that's the central point of reference I use to find out if I have to worry about a particular dictionary or not.
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> File a separate bug on the Hungarian localization?
> https://bugzilla.mozilla.org/enter_bug.cgi?product=Mozilla%20Localizations

I have made a new issue about the default dictionaries of localized products: Bug 414344.

> 
> It'd be good to update http://wiki.mozilla.org/L10n:Dictionaries#Hungarian,
> too, as that's the central point of reference I use to find out if I have to
> worry about a particular dictionary or not.

We do. Could you update the Hungarian add-on? It would be fantastic.

Thanks for your help,
László

> 

(Reporter)

Comment 4

11 years ago
(In reply to comment #2)
> File a separate bug on the Hungarian localization?
> https://bugzilla.mozilla.org/enter_bug.cgi?product=Mozilla%20Localizations

For the first part: András Tímár, the leader of the Hungarian localization has also no access or permission to update the Hungarian add-on. Please, help!
(Reporter)

Comment 5

11 years ago
Created attachment 300190 [details] [diff] [review]
Fixed Hungarian Add-on for MySpell (Firefox 2, etc.)

Tested on Firefox 2 and Firefox 3 beta 2
(Reporter)

Comment 6

11 years ago
Created attachment 300192 [details] [diff] [review]
Hungarian Add-on for Hunspell (Firefox 3)

Tested with Firefox 3 beta 2
(Reporter)

Comment 7

11 years ago
Hungarian localization team cannot update the broken Hungarian dictionary Add-on on Mozilla AMO site, so we need your help. Add-ons have been attached.
Component: Add-ons → Dictionaries
Hardware: PC → All
Summary: change Hungarian dictionary add-on, also add to the localized versions of Firefox and Thunderbird → fixed and new Hungarian dictionary add-ons
(Reporter)

Updated

11 years ago
Blocks: 392011
(In reply to comment #7)
> Hungarian localization team cannot update the broken Hungarian dictionary
> Add-on on Mozilla AMO site, so we need your help. Add-ons have been attached.
> 

I replaced the currently hosted dictionary on AMO with your first attachment (for FF2, etc.).  I'll bring up FF3 support and dictionaries in the AMO meeting tomorrow to figure out how we're going to handle that.
Whiteboard: https://bugzilla.mozilla.org/show_bug.cgi?id=412386

Updated

11 years ago
Whiteboard: https://bugzilla.mozilla.org/show_bug.cgi?id=412386
(Reporter)

Comment 9

11 years ago
Created attachment 300213 [details] [diff] [review]
 Fixed Hungarian Add-on for MySpell (Firefox 2, etc.)

Also MySpell dictionary has been relicensed to GPL/LGPL/MPL.
Attachment #300190 - Attachment is obsolete: true
QA Contact: add-ons → dictionaries
(Reporter)

Comment 10

11 years ago
(In reply to comment #8)
> I replaced the currently hosted dictionary on AMO with your first attachment
> (for FF2, etc.).  

I'm very glad of your great help. Many thanks for it.

I'm sorry, I have just recognized, that I put the license file of the new Hunspell dictionary to the MySpell package. I fixed it, and relicensed the old
GPLed MySpell dictionary to GPL/LGPL/MPL, too. Now the license of the hosted Hungarian dictionary is ok.

> I'll bring up FF3 support and dictionaries in the AMO meeting
> tomorrow to figure out how we're going to handle that.
> 

The best for the users of the Hungarian localisation will be the default Hungarian dictionary (Bug 414344). Perhaps AMO dictionary page might have a button "dictionaries for Firefox 3 or newer", too.

By the way, now the product version numbers of Hungarian Add-ons constrain MySpell dictionary only for Firefox 2 and the new Hunspell dictionary for Firefox 3 (but Hunspell is backward compatible with MySpell).

Thanks again, László
Severity: major → normal
> > I'll bring up FF3 support and dictionaries in the AMO meeting
> > tomorrow to figure out how we're going to handle that.
> > 
> 
> The best for the users of the Hungarian localisation will be the default
> Hungarian dictionary (Bug 414344). Perhaps AMO dictionary page might have a
> button "dictionaries for Firefox 3 or newer", too.
> 
> By the way, now the product version numbers of Hungarian Add-ons constrain
> MySpell dictionary only for Firefox 2 and the new Hunspell dictionary for
> Firefox 3 (but Hunspell is backward compatible with MySpell).
> 

So, would it be best to replace what is there the Hunspell version and make it available to all versions of all applications?

Also, I'd be happy to add someone as an author for the add-on so they could update the dictionary and meta-data when needed.
(Reporter)

Comment 12

11 years ago
(In reply to comment #11)
> > Firefox 3 (but Hunspell is backward compatible with MySpell).
> > 
> 
> So, would it be best to replace what is there the Hunspell version and make it
> available to all versions of all applications?

I was wrong. Most of recent Hunspell dictionaries are backward compatible with MySpell (because they don't uses special features of Hunspell), but Hungarian is not. For example, the the preferred Hungarian Hunspell dictionary is UTF-8 encoded, but MySpell doesn't support Unicode encoding.

> 
> Also, I'd be happy to add someone as an author for the add-on so they could
> update the dictionary and meta-data when needed.

I'm happy to be this author. I'd like to update the old MySpell dictionary with the new words of the Hungarian Hunspell dictionary in the near future, so this permission would be a great help. Thanks, László

I just added the current author of the dictionary for any comments before I add anyone else as an author.  Sorry for not having you on the discussion earlier.
(Reporter)

Comment 14

11 years ago
(In reply to comment #13)
> I just added the current author of the dictionary for any comments before I add
> anyone else as an author.  Sorry for not having you on the discussion earlier.
> 

Hi Lőrinc,

Unfortunately, we were not be able to inform you, that there were a lot of problems with your Hungarian Add-on update (see http://mozilla.fsf.hu).
If you don't mind, the Hungarian localization team will ensure the future Hungarian dictionary updates. Thanks, Laci

Comment 15

10 years ago
Currently the Hungarian dictionary addon (http://releases.mozilla.org/pub/mozilla.org/addons/3386/) is not available at AMO. It simply does not appear on the list (neither for Firefox nor for Thunderbird). 

The maintaner of the Hungarian dictionary addon (Németh László) currently does not have right to update it on AMO.

Could you please advise how to improve the situation.

Thanks!

Comment 16

10 years ago
I noticed that this add-on was disabled, I've re-enabled it. Now, to add the author, can you please add the AMO-registered email adddress(es) and I can add these as authors to the add-on.
(Reporter)

Comment 17

10 years ago
(In reply to comment #16)
> I noticed that this add-on was disabled, I've re-enabled it. Now, to add the
> author, can you please add the AMO-registered email adddress(es) and I can add
> these as authors to the add-on.
> 

Thank you very much. Our e-mail addresses:

András Tímár (lead of Hungarian language team): timar@fsf.hu
László Németh (author of the dictionary): nemeth@openoffice.org

We may have an other problem with the dictionary update: the Submit Add-on Step 1 (Upload File) form doesn't contain the "Hungarian" option in the Default Locale selection box. If it is a problem, could you help us in that, too? Thanks, László

Comment 18

10 years ago
(In reply to comment #16)
> I noticed that this add-on was disabled, I've re-enabled it. Now, to add the
> author, can you please add the AMO-registered email adddress(es) and I can add
> these as authors to the add-on.

Hello Basil, 

Could you please add us at your earliest convenience. Thanks! The users of this extension are literally "crying and begging" for the update and we cannot do that. Unfortunately they think we are lazy and/or incompetent. We have tried to add a new extension but the system did not let to use the same ID (hu@dictionaries.mozilla.org). I think we should update the original one.

Best regards,
Andras
Mike Morgan (morgamic) is taking over responsibility for AMO from Basil.  He or Rey Bango should be able to take care of this.  cc:ing both of them.

Comment 20

10 years ago
Mike, Rey, do you think you can help us to fix this issue?
(Assignee)

Comment 21

10 years ago
I spoke with Andras and we are going to attempt to contact the current owner one last time and if he does not respond I will hand ownership over to Andras.

Comment 22

10 years ago
Current owner (Pap Lorinc) responded, resigned, and agreed to hand ownership over to me and Laszlo. Mike, can you please proceed. Thanks.
(Assignee)

Comment 23

10 years ago
Ownership transferred to Andras.
Assignee: nobody → morgamic
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 24

10 years ago
verified
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.